Crash



  • Hi!
    I just had a crash…
    I sent crash report from my box 2 minutes ago.
    Can someone please check it out and let me know what went wrong?

    I have no crash file, I deleted it after sending...

    Many thanks!


  • Rebel Alliance Developer Netgate

    kernel trap 12 with interrupts disabled
    
    Fatal trap 12: page fault while in kernel mode
    cpuid = 0; apic id = 00
    fault virtual address   = 0x38
    fault code              = supervisor read, page not present
    instruction pointer     = 0x20:0xc0aac287
    stack(pointer           = 0x28:0xc4785bdc
    frame pointer           = 0x28:0xc4785c2c
    code segment            = base 0x0, limit 0xfffff, type 0x1b
                            = DPL 0, pres 1, def32 1, gran 1
    processor eflags        = resume, IOPD = 0
    current process         = 11 (idle: cpu0)
    
    Fatal double fault:
    eip = 0xc0e86789
    esp = 0xc470588c
    ebp = 0xc47858e4
    cpuid = 0; apic id = 00
    panic: double fault
    cpuid = 0
    Uptime: 2d19h51m13s
    
    db:0:kdb.enter.default>  show pcpu
    cpuid        = 0
    dynamic pcpu = 0x30d100
    curthread    = 0xc49948a0: pid 11 "idle: cpu0"
    curpcb       = 0xc4785d80
    fpcurthread  = none
    idlethread   = 0xc49948a0: tid 100003 "idle: cpu0"
    APIC ID      = 0
    currentldt   = 0x50
    db:0:kdb.enter.default>  bt
    Tracing pid 11 tid 100003 td 0xc49948a0
    tc_windup(c4785c4c,c0a53787,0,c4785c94,c158e560,...) at tc_windup+0x17
    tc_ticktock(0,c4785c94,c158e560,27,c4785c64,...) at Script command 'bt' returned error
    

    Could be BIOS/ACPI or clock related ("tc" in this case is timecounter)

    Though I would seriously start to doubt the hardware if this is happening randomly and it worked fine before.



  • Huh OK, this is first time this happened…
    Probably old HW...



  • Hi!

    Just one more question…
    If this happens again, is there a way that pfsense would automatically reboot itself?

    Regards,
    M


  • Rebel Alliance Developer Netgate

    Normally it will automatically reboot itself after such a crash.

    Are you on NanoBSD? Or a full install?



  • I`m on full install, when this happened, firewall did not rebooted itself unfortunatley…


  • Rebel Alliance Developer Netgate

    Did you install from iso/memstick or OVA?
    Did you do a custom install?

    The only way it might have not rebooted is if you didn't make any swap space for the crash dumps, though it should be doing that either way.



  • Huh I installed from ISO, it was full default install on 80GB disk…


  • Rebel Alliance Developer Netgate

    Custom install or a quick/easy install?

    What does this show?

    swapinfo
    
    sysctl debug.ddb
    


  • Ummm it just happened again jimp!
    1 week almost preciese timing and my box is locked again.
    oh crap :S

    I have to come home from work, then I`ll be able to see output of those commands…

    Offtopic:
    I have pppoe connection and another Hyper-V pfsense VM....
    Can I do a redundant situation in case of HW is locked up like now?

    Thanks!



  • Maybe it has nothing to do with your problem, but haven't you set RAM disks? (System->Advanced->Miscellanous : RAM Disk Settings (Reboot to Apply Changes) ) ?



  • I have just submitted new crash log for inspection…



  • Hi guys!

    It was borked MB. I tried to upgrade to latest version and it borked kernel as well…  I had non bootable HDD, I replaced everything
    managed to rescue config.xml and now I`m up and running again :)

    I have just one question though...
    I rescued config.xml, can I somehow rescue RRD graph data too?
    I have old HDD which is working OK but new system is now on other HDD...

    Thanks!



  • They are in /var/db/rrd



  • Thanks gogol!

    Do I just copy/paste to new HDD and thats it?

    Regards,
    M



  • You will overwrite what was created of course



  • It turned out that motherboard was to blame…
    From 4 on-board ports 2 were giving me send/receive errors...
    I bought new system with intel d2500cce which should last longer that this one (2 yrs)...

    Thanks all!


Log in to reply