X750e - won't boot from CF;



  • well, First off,
    My Firebox has been upgraded
    Pentium-M 2ghz
    2GB ram
    16GB 600x card (trancend?)
    pico-PSU (80w)

    my issue is recent, I was running 2.1-RC1 alright, I installed/removed a few extra packages (squid3, haproxy, varnish) to attempt to do some reverse proxy (not that I knew what I wanted to do is possible)

    then the unit started to freeze/reboot

    the network would die, and windows boxes would complain that the network is unreachable (wired)

    web interface would time out, and SSH was unreachable - I would go to the unit and the LCD would read:
    "Booting OS…." - so I assumed it was self-rebooting - I power cycled it, it always came up.

    every time it came up, it had a bug report to send to pfsense - usually about php files for a package that was installed/removed (squid3 mostly)
    now, I assumed, by my general lack of pfsense embedded experence, I might have just done something wrong, so lets backup settings and wipe.
    backed up, then shut down and pulled the CF card, re-wrote the 2.1 snapshot, and now, it doesn't boot.

    I have wiped the bios 2-3 times, always going back and setting the heads to (2) for the bigger CF card.
    it always (albit slowly) passes the memory test, and always gets to "booting OS..."
    which blinks the storage 3 times rapidly, then, sits there.
    I assumed once or twice, that hey, it's a CF card, it is slow, so, it had been left to boot for 3-4 hours. (had other things to do, so it wasn't that long, on purpose)

    I have had OTHER issues with this firebox, that may, or may not be related.

    -LAN would resolve to the world (DHCP/DNS) OPT1-OPT3 would not, they were on the msk, same settings for all 4, same NAT/firewall settings, differnt DHCP subnets.
    -I HAD the powerbrick for the PICO, but removed it, because I was having the system acually TURN OFF on me. I assumed it was heat.

    EDIT: changed the topic, the extra !!!??? removed, what was I thinking?


  • Netgate Administrator

    16GB is big. I'm not sure anyone has tried such a large card, still you say it was working fine before.
    The sequence for setting the CHS parameters can be key. Some cards/boxes seem fussier than others in my experience.
    Reset the CMOS (pull the battery and move the jumper for 10s).
    Boot into the bios and keep the IDE settings as 'auto'. Force it to re-detect the card. Save the settings and exit.
    Boot into the bios again and change it to CHS heads=2. Does it see the card as less than 512MB? Save settings and exit.
    Should boot. If not go back into he bios and check it's remembered the settings. Is the battery flat?

    Is the 2.1 snapshot you're using the one that has previously worked?

    New DHCP server instances default to handing out a /32 subnet. It's easy to overlook that and end up with clients that can't reach anything.

    Steve



  • I went for the 16GB, on account of the 600x speed rating, and it DID make a difference. (the 4gb card i had, had the sandisk "error that can be ignored (I forgot, and am mobile, so google-fu isn't readily available)
    I will attempt the bios reset again.

    the image I am retrying IS one that worked.

    I have replaced the battery once already (found that it was dead, the hard way)

    I THOUGHT i setup a /24 on the dhcp servers,
    say, 192.168.2.0/24 but I'll revisit that again, as you say, it's easy to overlook.

    I may pickup a 4gb card on the way home, thank you so far for everything on this!


  • Netgate Administrator

    You won't be seeing anything like the cards rated speed because DMA is disabled by default on the NanoBSD images. Usually it's not worth spending more on faster cards for that reason. If you re-enable DMA/UDMA you'll find pfSense won't boot and throws DMA errors. There is a hardware workaround for that if you can solder.  ;)

    Steve



  • well, that's good to know, what about IDE drives? :P
    yes I can solder,
    no I havn't had a chance with the unit as of yet.


  • Netgate Administrator

    If you install the nano image to a hard drive you'll still only get PIO speeds. However you could re-enable DMA since all the hardware is there to support it. Full install is full speed by default.

    See this post for the hardware mod to enable UDMA CF support. I've not tried it.  ;)
    http://forum.pfsense.org/index.php/topic,56572.0.html

    Steve



  • I plan on trying it, but trying to decide if this is the way to go,

    or use this :
    http://www.kingspec.com/product_xx28.html

    which i have a few of… right now, due to being at work, I can only read the forums and wish, and think what I may have done wrong.


  • Netgate Administrator

    Sure, run the nano image off that. Should work great. Edit /boot/loader.conf to remove the line disabling DMA for full speed. That file may be overwritten by a firmware update. Not all (most of mine) X-Core-e boxes have the IDE socket populated, that may be an issue.

    Steve

    Edit: The correct way to enable DMA, which will survive an update is detailed here:
    http://doc.pfsense.org/index.php/Boot_Troubleshooting#NanoBSD_on_Newer_Hardware



  • mine is populated, but these devices happen to run with the 44-pin IDE configuration (laptop IDE) which requires use of the rear connector. (with dell/hp adapter of course)

    I know we are going back and forth here, so, install NAN0-image to the ssd DOM, as if it was a CF card, then boot from it;
    I have to ask, what do i "LOSE" from using a nano; over a full install? (not interested in snort, or massive cache)

    BTW, you're help and work on this platform got me into pfsense more than "oh nice, a router"; I'm a Systems Admin by hobby and profession,
    but honestly, always left the deep networking up to, the network guys.



  • Quick interjection…

    Id bet you will kill this quickly with a full install - but not nano.

    http://www.kingspec.com/product_xx28.html


  • Netgate Administrator

    I would definitely run nano on that but others have run DOMs with a full install without issue.
    By running Nano you loose access to some packages, I forget exactlt which but I think Asterisk and LightSquid are the important ones. You can't cache in Squid, as you've said, Snort can be an issue when it updates. You loose any persistent logging as it's all held in RAM but you can use an external syslog server.

    Steve



  • @kejianshi:

    Quick interjection…

    Id bet you will kill this quickly with a full install - but not nano.

    http://www.kingspec.com/product_xx28.html

    perhaps, but on a offnote, I've been using kingspec SSD's for 3+ years? (mostly the DOM styles), and had 1 fail in use, and 2 DOA, I've had "mainstream" SSDs fail with a much higher %; names I won't drop here, because it's not relevant. is that a long time? no, it's not. I understand that. at the same time, their entire line was geared for industrial useage; do i use kingspec on a desktop? never have; never will if I can help it, the performace I desire, will not be there. (OMG raid-0 SSDs? nooooO! ;P)

    stephenw10;
    that seems fine for me, NANO it is; I use an external log server (even at home, call me obsessive) anyway; thank you for all the advice for this new-guy :P



  • I think any SSD can go the distance if its not abused.  I think a full install + squid cache will abuse any small MLC SSD.
    Nano shouldn't.  I'd boot nano off my crappy ATP earthdrive thumb drive even.



  • update guys;

    I havn't touched this box in a while, will let you know how it goes as soon as i get the chance.


Log in to reply