ZFS - a possible source of some 2.1 whackiness?



  • These show up at boot, post 2.1 upgrade. Unstable behavior is certainly the description as compared to 2.0.3, which I gather did not use ZFS (at least nothing shows up in the logs on a search.)

    I guess we are using ZFS as of 2.1, and it's not liking the tuning:

    Sep 21 11:14:12	kernel: ZFS WARNING: Recommended minimum kmem_size is 512MB; expect unstable behavior.
    Sep 21 11:14:12	kernel: ZFS filesystem version 5
    Sep 21 11:14:12	kernel: ZFS storage pool version 28
    Sep 27 10:52:20	kernel: ZFS WARNING: Recommended minimum kmem_size is 512MB; expect unstable behavior.
    Sep 27 10:52:20	kernel: ZFS filesystem version 5
    Sep 27 10:52:20	kernel: ZFS storage pool version 28
    Oct 1 16:32:32	kernel: ZFS WARNING: Recommended minimum kmem_size is 512MB; expect unstable behavior.
    Oct 1 16:32:32	kernel: ZFS filesystem version 5
    Oct 1 16:32:32	kernel: ZFS storage pool version 28
    

    Mind you, the items in question are not on the system tunables page, so I'm not all that sure how best to resolve them if they were not set correctly in the upgrade process. Sure, theres a + to add to GUI tunables, but syntax and appropriate values are non-obvious (to me anyway - I don't spend much time that far into the guts of the system, normally.)

    Sep 21 11:14:12	kernel: ZFS WARNING: Recommended minimum kmem_size is 512MB; expect unstable behavior.
    Sep 21 11:14:12	kernel: Consider tuning vm.kmem_size and vm.kmem_size_max
    Sep 27 10:52:20	kernel: ZFS WARNING: Recommended minimum kmem_size is 512MB; expect unstable behavior.
    Sep 27 10:52:20	kernel: Consider tuning vm.kmem_size and vm.kmem_size_max
    Oct 1 16:32:32	kernel: ZFS WARNING: Recommended minimum kmem_size is 512MB; expect unstable behavior.
    Oct 1 16:32:32	kernel: Consider tuning vm.kmem_size and vm.kmem_size_max
    

    OK, looking into the log without keyword search, evidently these are in /boot/loader.conf - still not obvious what to set them to.

    $ cat /boot/loader.conf.bak
    autoboot_delay="3"
    vm.kmem_size="435544320"
    vm.kmem_size_max="535544320"
    kern.ipc.nmbclusters="0"
    hw.usb.no_pf="1"
    

    changed to:

    $ cat /boot/loader.conf
    autoboot_delay="3"
    vm.kmem_size="512000000"
    vm.kmem_size_max="535544320"
    kern.ipc.nmbclusters="0"
    legal.intel_ipw.license_ack="1"
    hw.usb.no_pf="1"
    

    Still getting ZFS warning after the above modification (also found the legal.intel_ipw.licence_ack easter egg hiding in the log…that message, 4x over, at least went away.)



  • ZFS is NOT used in 2.1
    This is just a message that should not be there AFAIK…

    Ahhh and link: http://forum.pfsense.org/index.php?topic=62156.0



  • This is a major issue for me.  Just upgraded from 2.03 and REGRETTING IT!!!
    My first problem (related to this post) is that my router now boots intermittently,  it pauses or STOPS boot process while displaying the following (copied from above):
    Sep 27 10:52:20 kernel: ZFS filesystem version 5
    Sep 27 10:52:20 kernel: ZFS storage pool version 28

    These messages happen after it finds and loads the driver for the AVRIQ-USB virtual CD-ROM device (my avocent KVM over IP dongle.) Any help in stopping ZFS from trying to instanstiate a storage pool at a boot (which I DID NOT CONFIGURE) would be greatly appreciated.

    Thanks.



  • BTW, just tested and the same issue happens when I boot wihtout the AVRIQ-USB dongle, so it's not the driver.  ARRGH!!!



  • @daehnomel:

    This is a major issue for me.  Just upgraded from 2.03 and REGRETTING IT!!!
    My first problem (related to this post) is that my router now boots intermittently,  it pauses or STOPS boot process while displaying the following (copied from above):
    Sep 27 10:52:20 kernel: ZFS filesystem version 5
    Sep 27 10:52:20 kernel: ZFS storage pool version 28

    These messages happen after it finds and loads the driver for the AVRIQ-USB virtual CD-ROM device (my avocent KVM over IP dongle.) Any help in stopping ZFS from trying to instanstiate a storage pool at a boot (which I DID NOT CONFIGURE) would be greatly appreciated.

    Thanks.

    Got the same exact problem here.  had to waste half a day off blowing out my pfsense and putting all the settings back… really sucks!



  • ZFS isn't used at all, it's simply in the kernel if someone wants to do something with it.

    djlax152: what were you attempting, and what happened?



  • Although ZFS is not used I also changed the loader.conf settings just to eliminate the warning message.

    512000000 is not 512 MB

    512 MB = 512 * 1024^2 = 536870912

    #vm.kmem_size="435544320"
    #vm.kmem_size_max="535544320"
    vm.kmem_size="536870912"
    vm.kmem_size_max="536870912"


  • LAYER 8 Global Moderator

    so where exactly do you make this change.. I wouldn't mind removing that error on the boot..


  • Rebel Alliance

    /boot/loader.conf      ;)


  • Netgate Administrator

    You should put that in loader.conf.local no?



  • @stephenw10:

    You should put that in loader.conf.local no?

    Yes, always put user-defined things in .local so upgrades don't overwrite.


Log in to reply