Lock up at POST



  • I've been using pfSense on a particular PC (Gateway 510x) for a few years now and have loved every minute.  Unfortunately, my 2.5" 20GB SATA hard drive died on me a few days ago.  No problem, I have a backup.  So, I installed a 2.5" 120GB SATA hard drive and installed pfSense-memstick-2.1 to my USB key and installed to the hard drive.  Immediately after the RAM check during POST, the whole PC locks up.  I tried another hard drive, same thing.  I tried flashing nanobsd to a usb key, and it does the same thing.  I installed windows on the hard drive and it boots fine.  I tried installing pfsense-1.2.3 and 1.2 and it locks up, too.  I flashed the latest BIOS from Gateway, and no change.

    I assume something changed with the filesystem that is causing it to not boot on this hardware anymore.  Considering that I was running 2.1 prior to the crash, there has to be some way to get it installed, but I can't think of anything else to try.

    Does anyone have any ideas?  I finally have it running with a LiveCD and my config.xml on USB, but that just feels wrong.

    Please help!


  • Netgate Administrator

    How locked up is it? Does the Num-Lock key work?

    When exactly does it lock? Do you see the PCI device information etc?

    It sounds suspiciously like you may have accidentally used an image that uses a serial console. Which image are you flashing to the usb stick exactly?

    Steve



  • There is no response from the num lock key, or any other.  It locks up just after the RAM count during the time I would expect it would be detecting devices attached via PATA or SATA.  I've used several different images.  If I use one of the memstick images, it will boot, but when I install to the hard drive, the system won't boot until I've cleaned the HD on another PC.  I'm confident I'm not using a serial image.

    pfSense-1.2.3-RELEASE-LiveCD-Installer.iso - CD boots, but locks up after install to hard drive
    pfSense-2.1-RELEASE-4g-i386-nanobsd_vga.img - USB locks up PC
    pfSense-memstick-2.1-RELEASE-i386.img - USB boots, but locks up after install to hard drive

    Thanks for the help!


  • Netgate Administrator

    Hmm, very odd. Hard to imagine what the pfSense installer could possibly do to the drive that would have any effect on the bios drive detection.  :-\ I'm not sure what to suggest really. Do you have another drive you could try? Though given that a USB stick with the Nano imagine written to it also fails…..

    Steve



  • I'm pretty sure I tried another drive, but at this point I'm not positive.  What's really strange to me is that I installed Windows 7 on the same drive and it booted up and worked fine, so the installer has to be doing something different.


  • Netgate Administrator

    Indeed, very strange. What can the installer do to the drive that crashes the bios drive detection code?  :-\

    Have you tried setting the IDE channel to manual in the bios?

    Steve



  • I'm not sure what you mean by setting the IDE channel to manual, but I did set SATA to legacy with no change.


  • Netgate Administrator

    Sorry too many threads open at once! I forgot you were using SATA.
    I would definitely try any SATA detection options you have. Still can't see how the pfSense bootloader could possibly effect that.
    Bootloader or SATA errors show themselves much further along the boot sequence.

    Steve



  • I agree, which is what makes this so frustrating.  If I had another spare PC laying around, I would just forget about it and move on.  Unfortunately, that's not an option for me.



  • @mrhanman:

    Does anyone have any ideas?  I finally have it running with a LiveCD and my config.xml on USB, but that just feels wrong.

    Very strange you can get it running with a CD; it's almost certainly a hardware problem.  Get it running from a live CD (linux, pfSense, rescuecd, whatever), then get to a command prompt and look at the boot messages.  See if the disk and controller are detected.  If so, see if you can mount it and access it normally.

    If you have been running running the live CD by disconnecting the boot hard drive, then go into the bios and change the boot order to CD first.  If the computer hangs with the drive plugged in, I'm 99% sure it's a hardware problem.  Try a new SATA cable, and also try both disks in another computer if possible.

    Maybe your first problem was not a bad drive per se, but a failing controller?

    Also might want to run memtest while you're at it (from one of those same CDs)



  • Hmm, google tells me your system has two SATA-150 HD controllers, but the CD is still an IDE connection, so it makes sense why a CD could work if the sata subsystem is failing or failed.

    Try the drive in the other sata connection, otherwise dig through your junk pile for a IDE hard drive.


Log in to reply