Pfsense on Dell PowerEdge r720 Issue??



  • Hi all,

    I just purchase Dell PowerEdge r720 with Broadcom 5719 4 1Gb ports and Broadcom 5720 4 1Gb ports.  i  installed pfSense 2.1 amd64 on Dell PowerEdge r720 without initial configuration. After Installation i m not able to configure my interfaces and  following warning on top of options:

    ls: *.xml: No such file or directory
    Config.xml is corrupted and is 0 bytes.  Could not restore a previous backup.

    i tried the help from pfSense discussions and followed the instructions but not work for me
    –----------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Several users have noted issues with certain Broadcom network cards, especially those built into Dell hardware. If you find that your bce cards are behaving erratically, dropping packets, or causing system crashes, then you may want to apply the following tweaks, especially on amd64.

    In /boot/loader.conf.local - Add the following (or create the file if it does not exist):

    kern.ipc.nmbclusters="131072"
    hw.bce.tso_enable=0
    hw.pci.enable_msix=0

    That will increase the amount of network memory buffers, disable TSO directly, and disable msix.

    https://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards

    kindly help me to solve this issue



  • im glad I read this.

    im running dell 1950 with 2 builtin Broadcom nics. and 8 addtl' Bcom nics.


  • Netgate Administrator

    @zerokool
    Yep, you should definitely apply those tweaks. Also your 'stuck at 36%' issue is common on Dell hardware as I said.

    @zohaib
    What media are you installing onto? That error looks like it can't read the config file for some reason. Bad disk perhaps or unsupported disk controller or controller mode.

    Steve



  • thanks for ur response,

    @stephenw10

    i am istalling on 500GB, SATA, 3.5in, 7.2K RPM Hard Drive
    installation didnt stuck at 36% successfully install but after installation i get this warning

    ls: *.xml: No such file or directory
    Config.xml is corrupted and is 0 bytes.  Could not restore a previous backup.

    and assign interface option not working.. i can go to shell



  • zerokool , can you share your experience to solve this issue, and can you elaborate more which RAID  controller or no RAID you are using.


  • Netgate Administrator

    You might try a 4GB partition for root. Though your error looks different. 500GB is far larger than you need, if you have a smaller one try that.
    See: https://doc.pfsense.org/index.php/Boot_Troubleshooting

    What disk controller are you using?

    Steve



  • I am using SATA (Serial ATA).
    i also install on RAID 1, i have PERC H310 Integrated RAID Controller.


  • Netgate Administrator

    So perhaps your raid controller isn't recognised correctly. Have you tried not using raid 1?

    Steve


  • Netgate Administrator

    See mine and JimPs replies in this thread:
    https://forum.pfsense.org/index.php/topic,71941.0.html
    Some users have reported that eventually it will install if you wait long enough.  ::) It's not something I've ever encountered personally.

    Steve



  • Steve

    Successfully installed pfSense without RAID 1 but same issue warning on option top

    ls: *.xml: No such file or directory
    Config.xml is corrupted and is 0 bytes.  Could not restore a previous backup.


  • Netgate Administrator

    Presumably you aren't trying to restore a config file? Do you have something connected that pfSense might be looking for a restorable file on, like a USB memory stick?
    Is this error actually causing a problem? Can you make changes to the config and save them?

    Steve



  • No nothing is attached,

    yes this Problem is main issue i cant do anything except option 8: Shell.
    I cant Assign Interfaces, Set Interfaces IP, no configuration nothing.



  • does the r720 have an sdcard slot on the motherboard? if yes => try removing the sdcard if one is in there


  • Netgate Administrator

    Hmm, odd that it's not reading the config file but is able to install. Just to be sure you are installing not running from the live DVD?
    If you have console access can you check the dmesg for any other errors? In the config.xml file there in /conf/?
    Do you have a /conf.default folder? Try copyign the config.xml from there to /conf.

    This is not something I've run into otherwise I'd probably be more help. It has happened before though (search the forum) so one of the devs will probably have a solution.

    Steve



  • @heper

    No  sdcard slot on the motherboard and nothing is attached.



  • @stephenw10

    pfSense is installed on HardDisk not running from Live DVD.



  • @zohaib where you able to resolve the issue? Having the same problem.


Log in to reply