Static DHCP not showing in DNS


  • Rebel Alliance Netgate Administrator

    I had this working then we had a power outage, and the reboot stopped it working.

    I have DHCP with static mappings to a few hosts… media and freepbx are the big ones that i would like to get going again.

    I cannot ping them from the diag screen in the GUI, and when I do an nslookup:

    chris@media:~$ nslookup media 192.168.91.1
    Server: 192.168.91.1
    Address: 192.168.91.1#53

    ** server can't find media: NXDOMAIN

    chris@media:~$ nslookup laptop3 192.168.91.1
    Server: 192.168.91.1
    Address: 192.168.91.1#53

    Name: laptop3
    Address: 192.168.91.210

    same machine, but I do an NSlookup of a DHCP client

    I go to my firewall:
    ping pfsense
    ping: cannot resolve pfsense: Unknown host
    [2.1-RELEASE][admin@pfsense.home]/etc(44):

    I'm wondering where I should turn next.

    On the DHCP page:
    I have enable registration of dhcp in dns
    .home as my domain
    and my static mappings

    On DNS forwarder:
    Enable DNS forwarder check
    Register DHCP leases in DNS forwarder checked
    Register DHCP static mappings in DNS forwarder checked
    Resolve DHCP mappings first checked

    Query DNS servers sequentially unchecked
    Require domain  unchecked

    Do not forward private reverse lookups checked

    I'm not sure what other information would be useful, no errors that I see in the DHCP logs or system logs pertaining to DNS/DHCP events…


  • Rebel Alliance Netgate Administrator

    I rebooted and it was resolved.

    I changed nothing.