Problem after installation



  • Hi.

    I need to install router-firewall to a not-very new hardware. I did have FreeBSD + pf on the same computer, but I had to install new one. Nevertheless, FreeBSD goes up without problems.

    This is is an AMD64 with 3xRealtek GB, Asus K8V-x.

    When I start pfSense from the liveCD, it works and I like it.

    I can install it (there is no error), but when I try to run new installation from hd, it stalls almost at the beginning.

    Probably there is something missing from the pfSense packet which exists in ordinary FreeBSD.

    I switched off floppy from the BIOS. Unfortunately I can not make LBA permanent - it can only be "auto" or "off".

    Any advice how to make pfSense still work on this hardware or should I go to longer way and build it up from ordinary BSD myself?

    Thanks in advance.

    Mikk


  • Netgate Administrator

    Where exactly does it fail to boot?

    What sort of drive are you booting from?

    Steve



  • F1 pfSense

    F6 PXE
    Boot: F1
    |

    … and that's all.

    There is 120GB Maxtor DiamondMax Plus 9 Primary IDE in moment, but just in case I tried Hitachi Deskstar before and problem was the same.

    Mikk


  • Netgate Administrator

    Ok so it looks like it's hanging at the 'spinner' trying to load the kernel.

    I take it, since you mentioned LBA mode, that you've read this:
    https://doc.pfsense.org/index.php/Boot_Troubleshooting#BIOS.2FDisk_Errors

    Have you tried all those suggestions? I would guess your BIOS is reporting an incorrect geometry.

    Steve



  • That's the spinner. Unfortunately it does not spin at all. Just hang's in this way.
    Yes, I read them. Idea of switching off floppy from BIOS came as well from this document (it didn't help).

    I have no idea, what BIOS thinks about geometry – it does not say and does not complain. But when I install pfSense, then it uses the same geometry as Seagate writes in HD doc: 6Y120L0, ACTUAL CYL: 238,216, MAX CYL: 16,383, HDS: 16, SECT: 63.

    From real working FreeBSD 10.0 dmesg:

    ada0: <maxtor 6y120l0="" yar41bw0="">ATA-7 device
    ada0: Serial Number Y3NRHXFE
    ada0: 133.000MB/s transfers (UDMA6, PIO 8192bytes)
    ada0: 117246MB (240121728 512 byte sectors: 16H 63S/T 16383C)</maxtor>


  • Netgate Administrator

    You could try a 2.2 snapshot, they are built on FreeBSD 10. They are still alpha at this stage but most things work.
    http://snapshots.pfsense.org/

    You are using the latest BIOS? You tried whatever manual harddrive modes are available?

    Steve



  • I did have ordinary FreeBSD 8.3 working on the same hardware before. I also tried 2 pfSense previous releases. They were based also on 8.3, I guess. Nevertheless, I got the same result.

    I tried to switch every HD feature ON and OFF from BIOS, didn't try every combination of them of course.

    When I boot from live-CD, then one moment it writes: "acd0: FAILURE - READ_BIG MEDIUM ERROR". It does not stop on that place and does not complain later.

    Mikke


  • Netgate Administrator

    I have a similar age Asus board in an old box here that absolutely will not boot anything other than Windows. However that's only on it's SATA connectors. It has an early separate SATA chip that appears as a SCSI device. It will boot anything you like via IDE.

    Try disabling the SATA boot ROM.

    Try booting from SATA

    Your board appears to have some RAID functionality, are there any options for that?

    Steve



  • 1. I did not believe into pfSense new version, but I did try. I got few error messages, but finally it came up and works.
    2. This SATA is really not normal one. At least I was not able to force my motherboard boot from it.

    Is This ALPHA stable enough to use? Is it possible, that when it becomes ALPHA -> RELEASE once and I try to upgrade my firewall, it does not boot any more again?

    All the best,
    M


  • Netgate Administrator

    It's relatively stable but there things that are not functioning yet like captive portal and some packages. You should not use it anywhere critical.
    It's unlikely any changes now would affect the boot sequence so 2.2 release will almost certainly work for if snapshots do.

    Steve



  • Thank you very much!


Log in to reply