• Hey guys so Im trying to set up port forwarding for a program that we use at my business and it is just not working. Ive gone through every manual online and nothing. I can get the programs within the network to access the program when i set the client to ip of the host on the network 10.0.0.10, but when i set the client to call the business IP the port forwarding rule doesnt work, ports are 8099/8100.

    Pls help, im trying to get this up and running by the end of the day.


  • Perhaps a little more details? Are you trying to access it from the WAN side to an internal resource or are you sitting behind the firewall and trying to reach it on its public IP. If is the the later, then you need to turn on NAT reflection or use split DNS. I prefer split DNS. So when you are external, it resolves to the external IP, and when you are internal, it resolved to the internal IP. This takes a lot off the firewall.

    Please let us know what you are doing?


  • sorry was punching that out quickly and didnt realize how much detail i missed.

    The database that the clients are trying to reach is behind pfsense. I can access the database with the client program when everyone is on LAN behind the firewall and using the database ip directly (10.0.0.10).

    Before I had it that you could access through WAN through a basic asus router. I simply had port forwarding then turned on to pass requests from 8099-8100 to the database computer. Even people who were on the LAN would have their programs call for the business IP and it would be directed to the database.


  • That is called NAT reflection. This is off by default. You can turn that on to get the same effect.


  • Tried and still no luck, I used NAT and NAT+proxy but nothing.
    I set it in the system -> advanced options first and then also on the NAT itself.

    Here are my current settings
    Firewall NAT:Port Forward                              (NAT Address) (NAT Ports)
    WAN TCP/UDP *  *  WAN Address 8099-8102  10.0.0.10      8099-8102

    Rules
    ID  IPv4 TCP/UDP *  *  10.0.0.10  8099-8102 *  none

    any suggestions??


  • On your firewall rule- click log.  try it again and see what shows up in the firewall logs…

    BTW- what is showing up in the firewall logs when you try?

    On the diagnostics page.  Use packet capture and see if the requests are making the firewall.


  • i checked the logs and the only things making it to wan are outside addresses


  • @adamthepolak:

    i checked the logs and the only things making it to wan are outside addresses

    Just a little more clarification, are you saying that port forwarding is broken completely? i.e. it fails from both outside and inside? Or is it working from the outside and only failing when you try to access it from the inside?


  • I currently cant try outside access for the rest of the day but I will try again tomorrow and post the answer


  • Adam-

    please remember that no one can read your mind.  :o

    Was there a time when those outside the network could reach the server behind your firewall?

    Could they still as of today?

    Or is your only problem that those inside your network cannot use your DNS name to access the server?


  • i know, sorry i cant give the answer right away but im busy working. ill post back asap


  • @adamthepolak:

    i know, sorry i cant give the answer right away but im busy working. ill post back asap

    Keep working Adam.  ;)

    At the risk of being redundant, have you already been through this document? https://doc.pfsense.org/index.php/Why_can't_I_access_forwarded_ports_on_my_WAN_IP_from_my_LAN/OPTx_networks

    I think "Method 2" would most likely solve your trouble easily and cleanly. I works perfectly on every psSense installation I've used it on.

    Note: Method 2 only works if your LAN clients are using DNS and not the actual external IP address and the router LAN IP is first in their DNS server list (either statically or via DHCP). If they are using the external IP address then you'll have to use Method 1 or Method 3.


  • so port forwarding is down completely and i cant access from WAN, im going to take the box home tonight and set it back to defaults and work from there again.

    @MindfulCoyote:

    @adamthepolak:

    i know, sorry i cant give the answer right away but im busy working. ill post back asap

    Keep working Adam.  ;)
    At the risk of being redundant, have you already been through this document? https://doc.pfsense.org/index.php/Why_can't_I_access_forwarded_ports_on_my_WAN_IP_from_my_LAN/OPTx_networks
    I think "Method 2" would most likely solve your trouble easily and cleanly. I works perfectly on every psSense installation I've used it on.
    Note: Method 2 only works if your LAN clients are using DNS and not the actual external IP address and the router LAN IP is first in their DNS server list (either statically or via DHCP). If they are using the external IP address then you'll have to use Method 1 or Method 3.

    I followed method 1 initially

    @chpalmer:

    Adam-
    please remember that no one can read your mind.  :o
    Was there a time when those outside the network could reach the server behind your firewall?
    Could they still as of today?
    Or is your only problem that those inside your network cannot use your DNS name to access the server?

    sorry if i miss info, if anything isnt there then just tell me what to add

  • LAYER 8 Global Moderator

    So is this UDP or TCP.. You have both setup in the forward and firewall rules.

    Nat reflection IMHO should always be last option..  Clients on the local network, should resolve the host of the service your trying to use to its local IP.  Clients on the outside should resolve to your public, and then yes be forwarded in.

    AFIAK udp reflection doesn't even work, or there were issues with it that may have been resolved?  As to details your missing - for starters what version of pfsense are you using?  Is this pfsense a physical box or a VM?