Pfsense on Asrock C2750D4I gives Kernel Panic



  • I have tried to install 2.1.X on this new board I got. It gives kernel panic's on all versions.

    It looks like this in the boot:
    ACPI APIC Table: <intel  tiano =""  ="">panic: AP #1 (PHY# 2) failed!
    cpuid = 0
    KDB: enter: panic</intel >



  • General consensus with the Avoton/Rangely boards is that pfSense 2.1 is too old, based on FreeBSD 8.3.  Either run pfSense 2.1 under a bare metal hypervisor like ESXi, or pitch in and help test 2.2.

    A few months ago I would have recommended ESXi, but 2.2 is coming along nicely now and is quite stable in my experience.


  • Netgate Administrator

    2.2 for the last few days has had some issues with ssh which give me a hard time.
    ESF were (until they ran out of stock) shipping Rangely boxes with 2.1.X installed. I think they're using Supermicro hardware.
    This looks likely to be a bad BIOS problem, check for an update. It could just be a catastrophically unsupported NIC issue!  ;) What NIC do you have?
    Edit: i210s I see. They should be supported by the igb driver in 2.1.1 or newer. Maybe just unsupported PHYs as the error shows.

    Steve



  • I am running 2.2 at the moment. But I have found problems with both SSH (which seems to be known issue) and then OpenVPN!

    I do like running bleeding edge in a way, but I really want OpenVPN to work =)

    // Markus



  • RE: 2.1.5
    I am using Supermicro 5018A-FTN4 which is a octacore system as well and I had to update settings in bios.
    Disable all ACPI funtions
    and drop available CPU's to 4

    Magic! works now until 2.2 is ready for production



  • we ship pfSense 2.1.5 and don't have to disable any cores, or ACPI.

    hint: you're doing it wrong.  (bad magic!)