LoadBalance e FailOver (Squid Não Transparente) Ajuda Por Favor



  • via Firewall aqui funciona, mais com o squid ele se perde por causa do gateway default



  • Pessoal alguem pode dar uma mão ? ou fazer em cenário ??



  • Olá!

    Galera, no PFSense 2.1.X não é mais para usar regras de Floating.

    É só ativar o "Allow default gateway switching" em System>Advanced>Miscellanious.

    Depois configurar os Gateways com um IP externo paramonitoramento, limites de latencia e perca de pacote.

    Agora crie um grupo com esses Gateways, no mesmo Tier te dará balanceamento ativo, com Tier diferente é como um Fail Over apenas.

    Depois crie regras de Firewall em LAN que utilizem a opção de Gateway apontando para esse grupo criado.

    Pronto…

    Testado com PFSense 2.1.4 com Squid não transparente, versões 3, 3-Dev e 2.7 STABLE.



  • LFCavalcanti

    Eu fiz o que vc falou o diferente era o TIER mais deixei igual e exclui a regra Floating e mesmo assim não funcionou eu derrubo o link principal e a navegação para, mesmo fechando o navegador do usuario abrindo novamente e autenticando ele não navega.

    Vc chega a fazer as regras de NAT ?



  • Olá!

    Como está configurado o monitoramento dos seus Gateways?

    Eu só faço regras manuais de NAT Outbound em cenários com topologia mais complexa, onde há MPLS, VPN, etc…



  • Luiz Fernando

    Estão com os ips do google 8.8.8.8 e 8.8.4.4

    Seria possível vc mandar uns prints das conf?

    Obrigado



  • Olá pessoal. Sou novo na fórum mas já uso o PF a algum tempo. Estou rodando o 2.0-RC1 (i386)
    built on Sat Feb 26 15:30:26 EST 2011
    Desta vez estou usando dois links, Virtua 20 Mb com Tier1 e Velox 2 Mb com Tier 2, e apenas uma LAN como 192.168.0.0/24.
    Estou tentando usar o squid transparente com ligthsquid, mas sem sucesso. Quando ativo o Proxy, entre uma mensagem de erro impedindo o acesso a qualquer site. Já fiz isso mas tinha apenas uma wan, e estou errando em algo agora que tem o Failover. Alguém pode dar uma luz pra essa situação? O Failover funciona perfeito, até descobri que tinha que monitorar um ip externo para fazer a virada automática.

    Desde já muito obrigado.



  • Olá davidjrsp.. Boa Tarde!

    Amigo eu segui as informações desse tópico e obtive sucesso… bom primeiro que uso transparente meu proxy. nas minhas confis eu simplesmente criei a regra de Outbound NAT deixando Manual setando assim:

    (WAN  any * * * WAN address * NO)

    (WAN2  any * * * WAN2 address * NO)

    depois só realizar as configurações de Miscellaneous:

    1 Use sticky connections

    2 Allow default gateway switching

    nesse caso utilizei somente a 2.

    nas integrações do proxy server dizem para utilizar um comando mas com isso o squid parava deixei sem e nas regras de floating deixe sem nada..

    se voce usa DNS forwarder marque a LAN e Localhost caso seu pfsense seje o servidor DNS..

    Bom amigo e assim o FailOver ficou 100%

    outra dica é nas configurações de routing marca para o monitor de IP fazer ping a cada 1s por padrão já é mas pode deixar e em Down deixa cerca de 4 s

    passe seu Feedback.  ;D ;D ;D



  • mateus0032

    Obrigado pelo contato,

    Eu não uso proxy transparente, eu autentico com os usuários criados no pfsense.
    Eu fiz as regras parecido com as suas e tbm não funcionou, o squid se perde e fica sem acesso.



  • Boa noite!!

    LFCavalcanti, efetuei as configurações da forma postada por você e obtive sucesso com balanceamento e fail over.
    Obrigado!



  • helberttavares

    Vc fez usando squid não transparente ?



  • Boa noite!

    Davidjrsp, uso proxy transparente.




  • @LFCavalcanti:

    Olá!

    Galera, no PFSense 2.1.X não é mais para usar regras de Floating.

    É só ativar o "Allow default gateway switching" em System>Advanced>Miscellanious.

    Depois configurar os Gateways com um IP externo paramonitoramento, limites de latencia e perca de pacote.

    Agora crie um grupo com esses Gateways, no mesmo Tier te dará balanceamento ativo, com Tier diferente é como um Fail Over apenas.

    Depois crie regras de Firewall em LAN que utilizem a opção de Gateway apontando para esse grupo criado.

    Pronto…

    Testado com PFSense 2.1.4 com Squid não transparente, versões 3, 3-Dev e 2.7 STABLE.

    Em relação a esta sequência, montei, mas ficaram algumas duvidas!

    1ª - Terei que criar dois tipos de grupo de Gateways (uma para load balance e outra para failover)? Não é possível criar somente um grupo que faça as duas atividades?

    2ª - Se tiver que criar dois grupos de Gateways, se houver necessidade de criar uma regra de firewall, automaticamente terei que criar dois??

    -1. Apontando para o grupo de gateway Load Balance?
    -2. Apontando para o grupo de gateway Fail Over?
    -3. Para a regra do proxy (3128) terei que criar duas regras? Uma para o Load Balance e outra para o Fail Over?

    Abraços,



  • Helbert Tavares

    Obrigado pelo retorno possivelmente seja isso então, se eu não uso o proxy o balance funciona direitinho.



  • Aqui, estou como mesmo problema o squid não respeita o balanceamento e somente sai pelo link principal.
    Sem squid, o balancemaento funciona perfeitamente, mas quando colco ele no modo transparente ele somente sai com o gw default.
    Ja testei com regras float, sem regras float
    Com tcp tcp_outgoing_address 127.0.0.1
    Com tcp_outgoing_address forçando o ip do segundo link.
    Nada, até a versão 2.1.3 estava normal com float rules.



  • tpramos

    Tbm nada aqui comigo, quando cai eu mudo o gateway padrao manualmente nas configurações do pfsense.
    :'( ja fiz de tudo aqui mais via proxy sem ser autenticado não ta rolando



  • @helberttavares:

    Boa noite!

    Davidjrsp, uso proxy transparente.

    Você está usando no caso citado 3 placas de redes físicas ? Duas para WAN e uma para saída do proxy transparente ?



  • Olá pessoal RESLVIDO loadbalance com 2 wans depois de muito tempo consegui o X da questão está no squid3 ou squid3 na aba geral desmarque a caixa "Allow users on interface". Pronto soma a velocidade e o download tudo que eu precisava maravilha agora tudo 1000%… Que de certo com quem não esta conseguindo...  ;D ;D ;D

    Att: Mateus Candido



  • Infelizmente houve problemas depois de desativar a opção Allow users on interface não tenho mais bloqueio…  :(

    mesmo setando minha rede em ACL...  :(



  • Mateus

    Tbm não estou conseguindo :(
    o Squid se perde com o gateway e se eu mudo manualmente o gateway padrao quando cai o link principal ele funciona mais tem que ser manualmente trocando para o gateway secundario e deixando ele como gateway padrao



  • O máximo que faz é FailOver…. Continuarei tentando segue anexo...  :'(




  • Todos os procedimentos para proxy não transparente já tentei, mais sem chance :(



  • Boa tarde!
    Pessoal, é possível enviar um print das regras de firewall de vcs?



  • Olá helberttavares!

    segue em anexo… cada configuração deixei pela ultima configuração sendo que já mudei de toda maneira mais nada....



    ![general setup.PNG](/public/imported_attachments/1/general setup.PNG)
    ![general setup.PNG_thumb](/public/imported_attachments/1/general setup.PNG_thumb)


    ![outbound com e sem.PNG](/public/imported_attachments/1/outbound com e sem.PNG)
    ![outbound com e sem.PNG_thumb](/public/imported_attachments/1/outbound com e sem.PNG_thumb)


    ![rules lan.PNG](/public/imported_attachments/1/rules lan.PNG)
    ![rules lan.PNG_thumb](/public/imported_attachments/1/rules lan.PNG_thumb)









  • Boa tarde!

    Mateus0032, em Gateways você configurou os limites de latência e perca de pacotes?
    Não criei regras em Outbound.



  • Olá helberttavares! Esta configurado sim as regras de outbound já estava sem então não obtive resultado então criei para ver o resultado é nada no caso dos limites de latência na minha região são altos de mais então deixei configurados somente nos grupos para member down, só setei 4 segundos para a queda dos links nos gateways. .. Vou colocar os limites e ver se da resultado. … valew pelo feedback. ..  :D



  • Infelizmente continua saindo somente por um link mesmo setando os limites de latência e perca de pacotes… retirei as regras de outbound do floating que estava desativada e tudo mais, oque acontece é que o squid não consegue receber a soma de links. Mas se a net cai o segundo link funciona perfeitamente e o squid recebe o link 2 normal... e nesse momento esta assim operando pelo link 1 de 10mb..



  • mateus0032, lí todo o tópico, estou com a versão 2.1.5 e proxy não transparente, infelizmente nesta versão nem failover funciona, o Squid3 mantém a conexão com o Default Gateway. Nas versões anteriores bastava reiniciar o proxy que ele passava a utilizar o link sem falhas mas na 2.0.5 não consegui de forma alguma. Sem o proxy LoadBalance e FailOver funcionam normalmente.



  • @LFCavalcanti:

    Depois crie regras de Firewall em LAN que utilizem a opção de Gateway apontando para esse grupo criado.

    Testado com PFSense 2.1.4 com Squid não transparente, versões 3, 3-Dev e 2.7 STABLE.

    LFCavalcanti, qual regra vc criou na LAN para permitir somente o squid acessar as portas 80 e 443? Se deixar
    TCP LAN net  * * * LOADBALANCE os usuários conseguirão acessar a Internet sem proxy.



  • Bom Dia a todos!

    Pessoal,

    Pesquisei em sites gringos e brasileiros e só vejo possíveis caminhos, dos quais não funcionam! Se houver algum caso que funcione (se eu estiver errado me corrijam) é gambiarrado, pois já consultei especialistas na ferramenta, foruns, materiais etc., e a informação que tenho é que a partir da versão 2.1.x não há nada especifico para que o FailOver funcione adequadamente com o Squid.

    Sinceramente, desisti de tentar fazer funcionar, até que saia algum recurso oficial e funcione. Resolvi tomar um caminho diferente, criei dois grupos de Gateway, no qual funciona como FailOver somente, sendo:

    -Grupo01 | GW1_Default e GW2_Backup
    -Grupo02 | GW2_Default e GW1_Backup

    O GW1 é o link principal, pois é mais estável e veloz;
    O GW2 é o link secundário, possui uma velocidade inferior e cai com certa frequência.

    Então segui o seguinte caminho, a navegação em sites e acesso ao sistema (que é em nuvem), ou seja, acessos que são visíveis aos usuários, deixei saindo pelo Grupo 01. Equanto que serviços como envio e recebimento de e-mail, deixei saindo pelo Grupo 02, pois uma vez que o usuário envia a mensagem, a mesma fica em segundo plano e o usuário não percebe tanto a performance como o abrir de uma pagina.

    Da forma que sigo no momento, me supre tranquilamente, porque distribui a carga e caso um link cai, o outro assumira normalmente.

    Se alguém tive alguma outra solução mais interessante, compartilhe conosco.

    Abraços,



  • Como vai wssilva, gostaria de saber se o failover Grupo01 funciona com o squid, antes eu utilizava Floating Rules e tcp_outgoing_address 127.0.0.1 mas agora não funciona mais com a 2.1.5, sem squid o balanceamento de carga e failover funcionam normalmente. Na sua configuração o squid passa a utilizar o GW2_Backup quando o GW1_Default cai automaticamente? Eu só consegui que funcione mudando o gateway default para o segundo link manualmente em Routing / Gateways.


Log in to reply