Ntopng stopped working and will not start up



  • This service has been running great and has now all of a sudden stopped working. I tried reinstalling the package and restarted the router and it still will not run.  This is the error being generated in the system log. Any idea what may be causing this?

    
    Aug 26 10:41:38	kernel: re1: promiscuous mode disabled
    Aug 26 10:41:38	ntopng: [Redis.cpp:39] ERROR: to specify a redis server other than the default
    Aug 26 10:41:38	ntopng: [Redis.cpp:38] ERROR: Please start it and try again or use -r
    Aug 26 10:41:38	ntopng: [Redis.cpp:37] ERROR: ntong requires redis server to be up and running
    Aug 26 10:41:38	ntopng: [Redis.cpp:34] ERROR: Unable to connect to redis 127.0.0.1:6379
    Aug 26 10:41:38	kernel: re1: promiscuous mode enabled
    Aug 26 10:41:38	ntopng: [NetworkInterface.cpp:75] WARNING: No capture interface specified
    Aug 26 10:41:38	ntopng: [Prefs.cpp:408] ERROR: Unable to create log C:\Windows\Temp/ntopng.log
    
    


  • did you select an interface within the ntopng Settings?



  • @Cino:

    did you select an interface within the ntopng Settings?

    Yes. Like I said above, this has been working up until now. I've tried all of the interfaces to make sure.



  • I'm not really sure then… try this, remove it. Reboot your box.. Then install it again. Leave default settings and only select your LAN interface... See if this helps..



  • @Cino:

    I'm not really sure then… try this, remove it. Reboot your box.. Then install it again. Leave default settings and only select your LAN interface... See if this helps..

    Still is not working. I don't get it. It's one of my favorite packages and has just straight up stopped working.



  • The regular ntop package isn't working either. It also will not start.

    Aug 26 15:06:09	ntop[7031]: THREADMGMT[t34422669760]: ntop RUNSTATE: INIT(2)
    Aug 26 15:06:09	ntop[7031]: THREADMGMT[t34422669760]: ntop RUNSTATE: PREINIT(1)
    Aug 26 15:06:07	php: /status_services.php: The command '/usr/local/etc/rc.d/ntop.sh stop' returned exit code '1', the output was 'No matching processes were found'
    Aug 26 14:52:46	php: rc.filter_configure_sync: Not installing NAT reflection rules for a port range > 500
    Aug 26 14:52:43	check_reload_status: Reloading filter
    Aug 26 14:52:43	check_reload_status: Syncing firewall
    Aug 26 14:52:42	ntop[52438]: THREADMGMT[t34422669760]: ntop RUNSTATE: INIT(2)
    Aug 26 14:52:42	ntop[52438]: THREADMGMT[t34422669760]: ntop RUNSTATE: PREINIT(1)
    Aug 26 14:52:38	ntop[51676]: THREADMGMT[t34422669760]: ntop RUNSTATE: INIT(2)
    Aug 26 14:52:38	ntop[51676]: THREADMGMT[t34422669760]: ntop RUNSTATE: PREINIT(1)
    


  • I restored my config backup from a few days ago and that solved it. I lost the accumulated data since then but it works at least.



  • "redis" dependency package  - seems not to be enabled.

    it is there, and returns
    set redis_enable to YES in /etc/rc.conf


  • Banned

    @gwaitsi:

    "redis" dependency package  - seems not to be enabled.

    it is there, and returns
    set redis_enable to YES in /etc/rc.conf

    1/ This is not how you enable services in pfSense
    2/ Stop necroposting, this thread is 2,5 yrs old, concerning incredibly buggy PBI packages.

    Someone lock this, please. Just attracting noise.


Locked