NEXCOM NSA 3110



  • I know this question has been asked multiple times in the forums, but i have not found an answer. Does anybody know the steps to configure LCD on a NEXCOM NSA3110. i have loded LCDproc dev, but i can't get it to work.

    I am running the pfsense 2.15.

    Any help will be greatly appreciated.

    Regards



  • Hi skippy007,

    the steps to configure it:

    • Services > lcdproc > Server
    • Com Port = Parallel port1 8/dev/lpt0)
    • Display Size = 2 row 16 columns
    • Driver = Watchguard Firebox whit SDEC
    • Connection Type= 4bit wiring to parallel port
    • Refresh frequency = 5 sec
    • SAVE
    • Status > Services >Lcdproc => Restart

    Enjoy :D

    another trick to set correctly the display's buttons:

    • Diagnostics > Edit File

    • Save/load from path: /usr/local/etc/LCDd.conf

    • Change menu section to:
      [menu]
      MenuKey=Down
      EnterKey=Right
      UpKey=Up
      DownKey=Left

    • Save

    Remembers all the changes involve a rewrite of this file, so after every update you have to manually edit the file and change the section menu.

    Fabio


  • Netgate Administrator

    Make those changes to the 'sdeclcd menu settings' section in /usr/local/pkg/lcdproc.inc if you want them to survive a settings save.

    Steve



  • Thanks for your replies.

    I will try the above instructions tomorrow at work, and will report back.

    Greatly appreciated.

    Skip..



  • @fabio.vigano:

    the steps to configure it:

    Sir, appreciate if you could confirm your steps for the current shipping PFSense. Just tried " LCDproc " package (not devel. version) and your designated driver is not present.

    Alternately, I tried driver " picolcd" which seemed appropriate to me and no luck.

    One edit: lcdproc.service isn't loading.

    Thanks.


  • Netgate Administrator

    The firebox driver is only in the -dev version of the package.

    Steve



  • I can confirm the instructions above do make text appear, however not showing the information selected on "screens" tab as I would expect.

    Just: (line 1) "LCDproc serve", (line 2) "Cli:0 Scr:0".

    Thanks.



  • One quick update on my previous results; after a full halt, cut off and restart, text started to show as expected.

    Thank you all for posts. Happy with the results.

    Regards,


Log in to reply