LIGHTSQUID - Relatório por DNS



  • Galera seguinte estou usando o Lightsquid em um cliente, porém os relatório são gerados por IP.
    Fiz a alteração da configuração IP resolve method (future) - DNS, porém mesmo assim o relatório é gerado por IP.
    Alguma configuração a mais para conseguir gerar por DNS.



  • Você tem que apontar o DNS do PFSense para um servidor DNS que consiga resolver os nomes as maquinas na rede, por exemplo um AD/DNS.



  • Existem várias pessoas com dúvidas qto a configuração do DNS no pfsense sendo que este estando rodando no windows server. Seria legal se alguém postasse as imagens do pfsense configurado! Digo isso porque também configurei e ainda não tenho certeza se o que fiz está 100% correto.
    Abraço!



  • Eu tenho aqui um servidor DNS/DHCP no Windows Server que é o AD também.
    Então todas as máquinas (hosts) estão registrados nele, então basta colocar o primeiro DNS no PFSense em:
    System: General Setup, DNS servers

    Para mim está funcionando bem.

    Creio que seja necessário também, tem que testar, mas no Squid a opção:
    Proxy server: General settings, Use alternate DNS-servers for the proxy-server deve estar apontando para o mesmo servidor DNS.



  • Fiz as configurações Tomas, por enquanto não esta funcionando.

    Uma dúvida, neste caso iria trazer o relatório por nomes somente os micros que estiverem no domínio né?



  • Na verdade os que tiverem cadastrados no DNS Server, os do domínio são automáticos, ou outros você pode fazer manualmente.

    No Squid coloque o DNS do AD também para ele consultar…



  • Boa tarde Tomas.

    Use alternate DNS-servers for the proxy-server - 192.168.0.10

    Nesta opção Tomas do squid Tomas, como você tinha mencionado acima?



  • Isso, depois tente fazer um refresh full para ver se resolve,



  • Eu fiz Brow…não vai mesmo.



  • Olha, não sei te dizer então, pra mim está funcionando.

    Vamos revisar pra ver se está certo:

    Em:
    System: General Setup :
    Opções:
    Domain
    DNS Server Use gateway

    em:
    Services: Proxy Reports (LightSquid, SQStat) -> Settings
    IP resolve method (future)

    Confere como estão estes parametros;

    Na opção Use Gateway está setado? Aqui não uso, pode ser esse detalhe.



  • Segue Tomas as configurações.








  • O campo dominio, ele está com o seu dominio AD?

    Exemplo:
    dominio: empresa.local

    PFSense seria: pfsense.empresa.local;

    Não sei mas pode ser isso.



  • Consegui aqui Tomas, porém não é do jeito que eu queria, mais tudo bem.
    Na tabela ARP percebi que não aparece os hostnames vinculado aos IPs, sendo assim adicionei manualmente uma entrada DNS forwarder, fui no relatório e estava funcionando. Fiz o teste de ping direto do PFSense para um dos micros da rede e não resolvia o DNS. A solução foi tirar o DHCP do meu ADDS e trazer para o PFSense, após isso esta funcionando os relatórios.



  • Certo, mas e o dominio como estava?



  • Adicionei o dominio, porém mesmo assim não funcionava.

    Hoje vou subir uma VM e fazer todas configurações novamente e testar item por item para ver se consigo fazer funcionar com o DHCP no meu ADDS, não quero deixar o DHCP do Firewall.

    Obrigado pelas dicas ae…



  • Subi a VM e refiz todas as configurações, não consegui fazer funcionar com o DHCP no ADDS.

    Por outro lado com o DHCP no próprio firewall esta funcionando 100%.




  • O nome do domínio do seu AD é qual?



  • mobilirotta.srv



  • Realmente não sei o que pode ser.