Lightsquid and sarg not working



  • Lightsquid and sarg not working  :-[



  • lightsquid.cnf

    /usr/local/etc/lightsquid içerisinde lightsquid.cfg dosyasını editleyip

    #path to access.log
    $logpath            ="/var/squid/logs"; olarak squid rapor klasorunun yerini belirtin normal ayarları farklı bir klasor yolu var.

    https://forum.pfsense.org/index.php?topic=82133.msg449421#msg449421

    yukarıdakileri denermisin bende 2.2 de sorunsuz kullanıyorum



  • still did not work
    pfsense 2.2 rc squid3-dev + lightsquid not working
    http://192.168.1.1/lightsquid/index.cgi
    google chrome
    404 - Not Found

    i.e
    blank page



  • Sorry to spoil your christmas, but at this moment 3.3 dev has been removed from the package list.
    Squid 3.4.9 didn't work at all, and 3.4.10 doesn't work either.
    Lightsquid and Sarg do not work on 2.2 yet, we will have to wait until proper packages are released.

    Cheers.



  • squid3 - 3.4.10_2 pkg 0.2 install
    reboot and  shell command
    killall squid
    cd /usr/pbi/squid-amd64/
    cp -r ./local/* /usr/local/
    rm -rf ./local
    ln -s /usr/local ./local
    sync
    squid

    squid is working.

    and
    squidGuard-devel install
    http/https block working :)



  • As cmb pointed out before on another topic, this isn't the right fix for squid 3.x. It works, but there are symbolic links that were never created when the package is installed. Once they are created/corrected, it should work. Only issue i've found so far is with c-icap not starting even after after creating a bunch of symbolic links based on errors when trying to start it manually from the shell. I didn't try transparent mode or ssl mitm as I have no need for it

    Lightsquid uses perl and is experiencing the same issue where no symbolic links were created from what I can tell. I'm also think its missing some options when it was compile.


Log in to reply