TWC IPV6 gateway issues



  • Hello,

    I'm  trying to get ipv6 to work on my lan. All the pc's on the lan have received IPv6 ip's.

    I can ping out ipv6 from pfsense and ping pfsense from the internet.

    I  didn't have many issues last time setting up ipv6 ( was a few versions of pfsense ago)

    Any help would be appreciated.

    ifconfig from ubuntu.

    ifconfig
    eth1      Link encap:Ethernet  HWaddr 0c:c4:7a:08:72:5b
              inet addr:192.168.1.9  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::ec4:7aff:fe08:725b/64 Scope:Link
              inet6 addr: 2605:e000:1417:4136::2000/128 Scope:Global
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:26307431 errors:0 dropped:0 overruns:0 frame:0
              TX packets:11549255 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:38061911039 (38.0 GB)  TX bytes:3417802752 (3.4 GB)
              Interrupt:20 Memory:df400000-df420000
    
    

    From win8

    Microsoft Windows [Version 6.3.9600]
    (c) 2013 Microsoft Corporation. All rights reserved.
    
    C:\Users\shaun>ipconfig
    
    Windows IP Configuration
    
    Ethernet adapter Bluetooth Network Connection:
    
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
    
    Ethernet adapter Ethernet:
    
       Connection-specific DNS Suffix  . : os6.org
       IPv6 Address. . . . . . . . . . . : 2605:e000::c43f
       Temporary IPv6 Address. . . . . . : 2605:e000::2506
       Link-local IPv6 Address . . . . . : fe80::58d5:8241:fdaf:c43f%4
       IPv4 Address. . . . . . . . . . . : 192.168.1.101
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : fe80::1:1%4
                                           192.168.1.1
    
    Tunnel adapter Teredo Tunneling Pseudo-Interface:
    
       Connection-specific DNS Suffix  . :
       IPv6 Address. . . . . . . . . . . : 2001:0:9d38::be7e
       Link-local IPv6 Address . . . . . : fe80::28d6:867e:e80e:be7e%7
       Default Gateway . . . . . . . . . :
    
    Tunnel adapter isatap.os6.org:
    
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : os6.org
    
    C:\Users\shaun>
    











  • Netgate

    
    ifconfig
    eth1      Link encap:Ethernet  HWaddr 0c:c4:7a:08:72:5b
              inet addr:192.168.1.9  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::ec4:7aff:fe08:725b/64 Scope:Link
              inet6 addr: 2605:e000:1417:4136::2000/128 Scope:Global
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:26307431 errors:0 dropped:0 overruns:0 frame:0
              TX packets:11549255 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:38061911039 (38.0 GB)  TX bytes:3417802752 (3.4 GB)
              Interrupt:20 Memory:df400000-df420000
    
    

    Seems like your ubuntu should have 2605:e000:1417:4136::2000/64, not /128. All of the IPv6 addresses on the workstation I'm on now (a mac) are prefixlen 64.  but I don't know if it's necessary.  Seems like unless that /128 is specifically routed to that interface by something it'd be pretty useless.



  • @Derelict:

    
    ifconfig
    eth1      Link encap:Ethernet  HWaddr 0c:c4:7a:08:72:5b
              inet addr:192.168.1.9  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::ec4:7aff:fe08:725b/64 Scope:Link
              inet6 addr: 2605:e000:1417:4136::2000/128 Scope:Global
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:26307431 errors:0 dropped:0 overruns:0 frame:0
              TX packets:11549255 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:38061911039 (38.0 GB)  TX bytes:3417802752 (3.4 GB)
              Interrupt:20 Memory:df400000-df420000
    
    

    Seems like your ubuntu should have 2605:e000:1417:4136::2000/64, not /128. All of the IPv6 addresses on the workstation I'm on now (a mac) are prefixlen 64.  but I don't know if it's necessary.  Seems like unless that /128 is specifically routed to that interface by something it'd be pretty useless.

    Something is wrong with the gateways.

    it doesn't even have a route for ipv6 (ubuntu or windows)

    route
    Kernel IP routing table
    Destination    Gateway        Genmask        Flags Metric Ref    Use Iface
    default        router.os6.org  0.0.0.0        UG    0      0        0 eth1
    192.168.1.0    *              255.255.255.0  U    1      0        0 eth1
    192.168.122.0  *              255.255.255.0  U    0      0        0 virbr0



  • @chaunbot:

    … Something is wrong with the gateways.
    it doesn't even have a route for ipv6 (ubuntu or windows)

    To where from WAN do you request an IPv6? i.e. ISP, other router with a prefix 'smaller' than 64?

    Your WAN and LAN should each have a 128bits/64 IP number, not /128's.
    Proof is on the 'Status:Interfaces' page. Show us the page ?

    Your box on the LAN will get a 128 bit number.
    Tell us how or what method is used to get a box or PC (on the LAN) an IPv6 address.



  • @hda:

    Your WAN and LAN should each have a 128bits/64 IP number, not /128's.
    Proof is on the 'Status:Interfaces' page. Show us the page ?

    Your box on the LAN will get a 128 bit number.

    All I'll say here is not always will this be the case.

    I don't have TWC (Time Warner Cable) so I don't know how their IPv6 is set up, but on Comcast, I can actually run link-local only on the WAN side of my router. If I do request a WAN address, it's a /128, and the gateway is still link-local.

    On the LAN though, you're correct. The address should be a 128-bit /64 address from whatever prefix was delegated.



  • Looking at your WAN/LAN config… It looks correct.. But do you have DHCPv6 server running somehow? They way pfSense GUI configures the files, it doesn't allow DHCPv6 when using a track interface.

    Example of my WAN
    IPv6 Link Local fe80:❌x❌x%em3 
    IPv6 address 2604:2000:x:b0:x❌x:x
    Subnet mask IPv6 128
    Gateway IPv6 fe80::201:x❌x

    Example of my LAN
    IPv6 Link Local fe80::1:1%em2 
    IPv6 address 2604:2000:x❌x❌x:x
    Subnet mask IPv6 64

    From PC
    Default Gateway . . . . . . . . . : fe80::1:1%42
                                                  192.168.0.1

    by chance to you have a ipv6 tunnel setup before? If so, remove all configs for it and see if that helps... Also, have you rebooted your box? When I first setup IPv6 using TWC, I had to reboot my box.. release/renew clients and they were good



  • These computers have never had ipv6. I had it going many moons ago and all these machines are on new installs. No tunnels have been setup.

    I ran wireshark and there are advertisements comming from the LAN side of pfsense. I also changed the prefix to /64 on pfsense and checked the prefix hint box. I've restarted pfsense and my win8 and ubuntu machines several times.

    Perhaps when i enabled ipv6 for the first time the machines on the lan were able to grab address. not sure : /

    Thanks for the help so far.



    @Cino:

    Looking at your WAN/LAN config… It looks correct.. But do you have DHCPv6 server running somehow? They way pfSense GUI configures the files, it doesn't allow DHCPv6 when using a track interface.

    Example of my WAN
    IPv6 Link Local fe80:❌x❌x%em3 
    IPv6 address 2604:2000:x:b0:x❌x:x
    Subnet mask IPv6 128
    Gateway IPv6 fe80::201:x❌x

    Example of my LAN
    IPv6 Link Local fe80::1:1%em2 
    IPv6 address 2604:2000:x❌x❌x:x
    Subnet mask IPv6 64

    From PC
    Default Gateway . . . . . . . . . : fe80::1:1%42
                                                  192.168.0.1

    by chance to you have a ipv6 tunnel setup before? If so, remove all configs for it and see if that helps... Also, have you rebooted your box? When I first setup IPv6 using TWC, I had to reboot my box.. release/renew clients and they were good



  • Ubuntu seems to be getting a /64 now.

    ifconfig
    eth1      Link encap:Ethernet  HWaddr 0c:c4:7a:08:72:5b 
              inet addr:192.168.1.9  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: 2605:e000:1417:4136:ec4:7aff:fe08:725b/64 Scope:Global
              inet6 addr: 2605:e000:1417:4136:7168:fb3c:e6b0:f62a/64 Scope:Global
              inet6 addr: fe80::ec4:7aff:fe08:725b/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:14879 errors:0 dropped:0 overruns:0 frame:0
              TX packets:9985 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:13197253 (13.1 MB)  TX bytes:2401732 (2.4 MB)
              Interrupt:20 Memory:df400000-df420000

    eth2      Link encap:Ethernet  HWaddr 0c:c4:7a:08:72:5a 
              inet6 addr: 2605:e000:1417:4136:ec4:7aff:fe08:725a/64 Scope:Global
              inet6 addr: fe80::ec4:7aff:fe08:725a/64 Scope:Link
              inet6 addr: 2605:e000:1417:4136:b4b0:20f6:f59:8eea/64 Scope:Global
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:2219 errors:0 dropped:56 overruns:0 frame:0
              TX packets:712 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:538723 (538.7 KB)  TX bytes:74923 (74.9 KB)
              Interrupt:16 Memory:df100000-df120000

    lo        Link encap:Local Loopback 
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:1804 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1804 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:520367 (520.3 KB)  TX bytes:520367 (520.3 KB)

    virbr0    Link encap:Ethernet  HWaddr c2:07:6f:46:6e:12 
              inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

    ubuntu ~ # ping6 ipv6.google.com
    PING ipv6.google.com(2607:f8b0:4007:807::200e) 56 data bytes
    ^C
    –- ipv6.google.com ping statistics ---
    4 packets transmitted, 0 received, 100% packet loss, time 2999ms



  • I guess im confused why pfsense thinks the locallink is the ipv6 gateway


  • Netgate

    It is OK to have local links as routers in IPv6.  In fact it's encouraged.  My workstation has a public IP assigned, but my IPv6 default gateway is the local-link of pfSense.  It disconnects the IPv6 subnets (of which there might be many assigned to one segment) from the router links.  It, in a way, creates a layer 2.5.



  • @virgiliomi:

    … If I do request a WAN address, it's a /128, and the gateway is still link-local.

    Stand corrected. I found out (with FB7360 supplying pfSense) the WAN can work as a /128 or a /64, depending on config of the IP supply method. Yes here the gateway is a local address too.



  • Anything new here?


  • Galactic Empire Netgate

    Do not revive old posts. Start a new one and state your issue.


Locked