[RESOLVIDO] Download descontrolado não respeita o limite imposto



  • Prezados,

    Tenho limitado o tamanho dos arquivos em 40000 kilobytes (40Mb) através do Squid Traffic Managment Settings no campo Maximum download size e, no entanto, sites como o mega.co.nz de mesmo proprietário do antigo megadownload tem conseguido extrapolar este limite fazendo downloads acima de 7 Gb!

    Detalhe que estou aplicando o proxy autenticado e sem a autenticação ninguém navega! Mas, qual é o problema?

    Características:

    pfSense 2.1.5-RELEASE (amd64) built on Mon Aug 25 07:44:45 EDT 2014
    Sarg Network Report 2.3.6_2 pkg v.0.6.3
    squid3 Network 3.1.20 pkg 2.1.2
    squidGuard-squid3 Network Management  1.4_4 pkg v.1.9.6



  • Opa,

    Rapaz, nunca tive sucesso utilizando esta opção de delimitador do squid, sempre apresenta um problema diferente.
    Resolvo esta questão criando um Limiter em "Firewall: Traffic Shaper: Limiter" e aplicando a opção em In/Out nas regras de Firewall.

    Com essa não tem erro.

    Espero que lhe ajude,

    []s.



  • Olá j4cky3s,

    Esta alternativa de aplicar o limiter não foi bem sucedida! Apliquei o limiter de 50 kbps e mesmo assim o download no site do mega.co.nz conseguiu extrapolar o limite e consumir a banda completamente.

    Por exemplo, se fosse para fazer um download normalmente como baixar um arquivo de testes no site arquivos.oi.com.br o Squid Traffic Managment Settings no campo Maximum download size irá automaticamente barra os arquivos acima do limite especificado. No entanto, de alguma forma os sites como o mega.co.nz conseguem fazer download dos arquivos de maneira que passa despercebida pelo squid. É como se o download dos arquivos fossem realizados através do carregamento de página web em vez de um download tradicional.

    A seguir está o link de um arquivo de filme para download no site do mega.co.nz cujo título é O Dia em que a Terra parou:

    https://mega.co.nz/#!fA00BTBa!GBiy4wIJjBpWR_yv8P91d33u7C426w93Je1oNILpxy0

    Se seu pfSense conseguir mesmo fazer com que o download de arquivos de sites como este consiga respeitar os limites impostos na configuração, por favor, me ajude a fazer isto!



  • proxy autenticado ou transparente? se for transparente, todo o tráfego https passa sem restrição pelo proxy, ou seja, limite de download não funcionará…



  • Olá Wesmp3,

    Proxy autenticado e somente navegam na porta 3128. Fez o teste de download com o link que postei acima ? Deu certo pra você?



  • Conversei com um amigo nosso que usa o EndianFW e solicitei que fizesse o teste de download de qualquer arquivo no site do mega.co.nz e o resultado é que os downloads realizados neste site estão extrapolando os limites de tamanho de arquivo. Pios que isso é que ele faz o download sugando toda a banda de internet.

    O rapaz disse que o site possui IPv6, mas, não sei até que ponto isto provoca o resultado indesejado. Ele também disse que irá bloquear pelo IP do site. No entanto, são vários os sites que usam o mesmo método de download.  :-\



  • @Goncaze:

    Olá Wesmp3,

    Proxy autenticado e somente navegam na porta 3128. Fez o teste de download com o link que postei acima ? Deu certo pra você?

    Amigo meu Limiter tá em 10mbps e eu sou o IP 126 tou fazendo o donwload do link acima. tá funcionando perfeitamente. Uso proxy transparente. ..

    ![Captura de tela de 2015-02-05 15:28:47.png](/public/imported_attachments/1/Captura de tela de 2015-02-05 15:28:47.png)
    ![Captura de tela de 2015-02-05 15:28:47.png_thumb](/public/imported_attachments/1/Captura de tela de 2015-02-05 15:28:47.png_thumb)



  • wesmp3,

    O seu limiter tá muito alto! Por exemplo, a banda aqui da escola é de 4 Mbps e você limitou à 10 Mbps e isto é o normal/excelente para um site mega.co.nz.

    Faça o teste com o limiter a 250 Kbps ou mesmo 500 kbps e verifique se realmente o download neste site estará respeitando o limiter definido!



  • @Goncaze:

    wesmp3,

    O seu limiter tá muito alto! Por exemplo, a banda aqui da escola é de 4 Mbps e você limitou à 10 Mbps e isto é o normal/excelente para um site mega.co.nz.

    Faça o teste com o limiter a 250 Kbps ou mesmo 500 kbps e verifique se realmente o download neste site estará respeitando o limiter definido!

    blz vou testar… mas a net aqui é 60 mbps... mas testarei com esse limiter.



  • @Goncaze:

    wesmp3,

    O seu limiter tá muito alto! Por exemplo, a banda aqui da escola é de 4 Mbps e você limitou à 10 Mbps e isto é o normal/excelente para um site mega.co.nz.

    Faça o teste com o limiter a 250 Kbps ou mesmo 500 kbps e verifique se realmente o download neste site estará respeitando o limiter definido!

    Olha aí com limiter de 512kbps.




  • wesmp3,

    Uai  :D, que milagre é este? O que foi que você fez? Quais as versões de pacotes e qual é a sua versão do pfSense?

    Você aplica o limiter de que forma? É para cada IP ou para a rede toda?



  • @Goncaze:

    wesmp3,

    Uai  :D, que milagre é este? O que foi que você fez? Quais as versões de pacotes e qual é a sua versão do pfSense?

    Você aplica o limiter de que forma? É para cada IP ou para a rede toda?

    pacotes:
    Lightsquid Network Report 1.8.2 pkg v.2.33
    squid3 Network 3.1.20 pkg 2.1.2
    squidGuard-squid3 Network Management 1.4_4 pkg v.1.9.6

    Versão 2.1.5

    A pergunta é: você quer aplica o limite pra toda rede ou pra um grupo especifico? pois assim são dois modos diferente… no meu caso tá aplicado no range entre 50 a 200. O que tão fora disso são fixo e não passam pelo limiter...



  • wesmp3,

    Estamos usando os pacotes com versões semelhantes! E realmente o Limiter tá funcionando de verdade!  ;D

    Deixa te perguntar mais uma coisa. O seu Status: Traffic Graph está mostrando os IPs com tráfego corretamente, porém, o meu não está fazendo isto. Por acaso, o meu problema pode ser causado pelo SARG que estou usando em vez do LigthSquid ou porque estou usando autenticação com Active Directory?



  • @Goncaze:

    wesmp3,

    Estamos usando os pacotes com versões semelhantes! E realmente o Limiter tá funcionando de verdade!  ;D

    Deixa te perguntar mais uma coisa. O seu Status: Traffic Graph está mostrando os IPs com tráfego corretamente, porém, o meu não está fazendo isto. Por acaso, o meu problema pode ser causado pelo SARG que estou usando em vez do LigthSquid ou porque estou usando autenticação com Active Directory?

    Se O proxy é autenticado, o Traffic Graph não mostrará o trafégo. Tbm já usei o Sarg e ele não influência nisso. Sobre o AD ainda não usei autenticado pra ver esse comportamento..



  • Ok wesmp3,

    Obrigado!!


Log in to reply