Failover doesn't fail-back… how to fix?



  • I have two ISP's,

    WAN1 - FAST 160Gbit - no data cap - buggy
    WAN2 - SLOW 6Mbit - 150gb data cap - solid

    I have failover set right, but once I have teh fast WAN1 back, the states don't drop on the slower capped link.
    (I just got hammered for the first time EVER by going over the cap because I didn't notice this "sticky connection" issue.)

    Anyway I'm SURE this have been discussed, but i cannot locate a solution for force a fail-back.

    I have checked the "kill states" option in advanced setup too.

    What is the preferred solution?



  • Same problem here with 2.2.4.

    Nobody has this problem? Any ideas to solve it?



  • Hi.

    I also have the same problem with my setup:
    WAN1 - 1 Gbps PPPOE, GW group Tier1
    WAN2 - 150Mbps, ISP router, private network, Tier 2

    Trigger: Packet loss.

    It switched to backup instantly (WAN2) but it never falls back to WAN1 (main).

    Any inputs please from more experienced members? Thanks.



  • Update: I read somewhere on the forum that a broken install might be the problem.

    I reinstalled from scratch and it working, a simple failover only. I anyone interested, I will add the full setup later



  • Bug #5090 submitted, feel free to add comments

    https://redmine.pfsense.org/issues/5090#change-20457



  • I am pretty sure this is exactly related to my issue and my most recent detailed post here:

    https://forum.pfsense.org/index.php?topic=86851.msg632594#msg632594



  • I think getting the latest patch (version 2.3.2 p1)and setting the the default gateway on system>routing >gateway group..edit it and  set it to default will solve the problem ..am not sure somehow it worked for me !!  :o  ;D  ;)



  • I'm also facing the same problem, Both gateways are online under Status tab, when wan goes down, it does not switch to wan2 which is in tier 2 trigger level Member down, please let me know the solution if have fixed this kind of issue..



  • try: System -> Advanced -> Miscellaneous : [v] Enable default gateway switching  - check on
    works for me

    2.2.5-RELEASE (i386)
    built on Wed Nov 04 15:50:18 CST 2015
    FreeBSD 10.1-RELEASE-p24


Log in to reply