[SOLVED] IPv6 PPPoe and track interface

  • Hello,


    It seems to work. On my Telekom,ADSL,Annex-J connection it works with the DrayTek settings in post#6 and the pfSense setting in post#9.


    I want to set ipv6. I get a /56 Prefix. My ISP is Telekom. I’m using a DrayTek Modem with pppoe. IPv4 works very fine. But IPv6 don’t’ work. Every night I get a new ipv6-address-range. So I try to work on the LAN with track-interface. Pfsense can ping ivp6.google.com. But the LAN-Interface gets no IPv6 address.

                   (pppoe)           (track interface)    
    DrayTak-Modem <-------> Pfsense <-----------------> LAN


    ifconfig pppoe
    pppoe:  flags=88d1 <up,pointopoint,running,noarp,simplex,multicast>metric 0 mtu 1492
            inet6 fe80::abcc:aeff:fece:c412%pppoe prefixlen 64 scopeid 0xc
            inet6 2003:1234:5678:8fd7:cafe:aeff:fece:affe prefixlen 64 autoconf
            inet --> netmask 0xffffffff
            nd6 options=23<performnud,accept_rtadv,auto_linklocal></performnud,accept_rtadv,auto_linklocal></up,pointopoint,running,noarp,simplex,multicast>


    em2: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=9b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum>ether 00:0c:29:ce:ab:c3
            inet netmask 0xffffff00 broadcast
            inet6 fe80::1:1%em2 prefixlen 64 scopeid 0x3
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active</full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum></up,broadcast,running,simplex,multicast>


    ping6 ipv6.google.com
    PING6(56=40+8+8 bytes) 2003:1234:5678:8fd7:cafe:aeff:fece:affe --> 2a00:1450:4013:c01::71
    16 bytes from 2a00:1450:4013:c01::71, icmp_seq=0 hlim=56 time=34.148 ms

    Thank You


    Edit 1: change MTU from 1300 to 1492 without success.

  • Why is your WAN PPPoE MTU 1300 ?

    IPv6 is sensitive to MTU value. Try 1492.

  • Hallo,


    Why is your WAN PPPoE MTU 1300 ?… Try 1492.

    thanks for your reply. That was only a test. I have set the MTU to 1492, but nothing changed.  :(


  • @snowyrain:

    I have set the MTU to 1492, but nothing changed.

    And including rebooting pfSense ?…

  • Yes, I have restarted pfsense. But it doesn't work. :(

  • Are you using DTv130 pass-tru ? Show your pfSense WAN & LAN webconfig setup.

  • Hello,

    I have made screenshots.

    01-07 DrayTek Modem

    Thank You

    ![01-Internet Access-General Setup.png](/public/imported_attachments/1/01-Internet Access-General Setup.png)
    ![01-Internet Access-General Setup.png_thumb](/public/imported_attachments/1/01-Internet Access-General Setup.png_thumb)
    ![02-Internet Access-PPPoE PPPoA.png](/public/imported_attachments/1/02-Internet Access-PPPoE PPPoA.png)
    ![02-Internet Access-PPPoE PPPoA.png_thumb](/public/imported_attachments/1/02-Internet Access-PPPoE PPPoA.png_thumb)
    ![03-Internet Access-MPoA Static or dynamic IP.png](/public/imported_attachments/1/03-Internet Access-MPoA Static or dynamic IP.png)
    ![03-Internet Access-MPoA Static or dynamic IP.png_thumb](/public/imported_attachments/1/03-Internet Access-MPoA Static or dynamic IP.png_thumb)
    ![04-Internet Access-IPv6.png](/public/imported_attachments/1/04-Internet Access-IPv6.png)
    ![04-Internet Access-IPv6.png_thumb](/public/imported_attachments/1/04-Internet Access-IPv6.png_thumb)
    ![04-Internet Access-Multi PCV VLAN.png](/public/imported_attachments/1/04-Internet Access-Multi PCV VLAN.png)
    ![04-Internet Access-Multi PCV VLAN.png_thumb](/public/imported_attachments/1/04-Internet Access-Multi PCV VLAN.png_thumb)
    ![05-LAN-General Setup.png](/public/imported_attachments/1/05-LAN-General Setup.png)
    ![05-LAN-General Setup.png_thumb](/public/imported_attachments/1/05-LAN-General Setup.png_thumb)
    ![06-LAN-General Setup-IPv6.png](/public/imported_attachments/1/06-LAN-General Setup-IPv6.png)
    ![06-LAN-General Setup-IPv6.png_thumb](/public/imported_attachments/1/06-LAN-General Setup-IPv6.png_thumb)
    ![07-Firewall-General Setup.png](/public/imported_attachments/1/07-Firewall-General Setup.png)
    ![07-Firewall-General Setup.png_thumb](/public/imported_attachments/1/07-Firewall-General Setup.png_thumb)

  • It is important you know or find-out the Telekom protocol to communicate with.
    We can only guess and suggest.

    Set DT-MoDem on PPPoE-protocol values & pass-through (yourscreen-2), not MPoA. No VLAN settings.
    First achieve "bridging" and if there is an IPv4 on the pfSense-WAN.

    Next is IPv6. You could read at another thread, i.e.:

  • It looks like you have "Internet Access >> IPv6 connection type" set to "offline" on the modem?!

    In addition to that, I think if for DHCP-PD to work through PPPoE, you need to check "Request a IPv6 prefix/information through the IPv4 connectivity link", and possibly "Only request a IPv6 prefix, do not request a IPv6 address" as well.

    Really, though, the best way to figure out what's going on is to actually look at the logs.

  • Hello,

    I've done a complete reinstall. I've tried many settings and reboot the system after every change. PFsense gets an IPv4 and IPv6 Address. PFsense can ping ipv6.google.com and other ipv4 hosts.

    But  "Track Interface" didn't work.

    I've a second DSL-Connection with an Fritzbox as Router. This setting works fine. But I don't like double NAT. So I don't want use the Fritzbox.

    Which log files are relevant?


    [2.2-RELEASE][root@pfSense.localdomain]/root: ifconfig
    em0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=9b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum>ether 00:0c:  :  :  :c2
            inet6 fe80::20c:   ff:fe   :f c2%em0 prefixlen 64 scopeid 0x1
            inet netmask 0xff000000 broadcast
            nd6 options=23 <performnud,accept_rtadv,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active
    em1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1492
            options=9b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum>ether 00:0c:  :  :  :cc
            inet netmask 0xffffff00 broadcast
            inet6 2003:56:ca3c:     :20c:  ff:fe  :   cc prefixlen 64
            inet6 fe80::1:1%em1 prefixlen 64 scopeid 0x2
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active
    pflog0: flags=100 <promisc>metric 0 mtu 33144
    pfsync0: flags=0<> metric 0 mtu 1500
            syncpeer: maxupd: 128 defer: on
            syncok: 1
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
            options=600003 <rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6>inet netmask 0xff000000
            inet6 ::1 prefixlen 128
            inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
            nd6 options=21 <performnud,auto_linklocal>enc0: flags=0<> metric 0 mtu 1536
            nd6 options=21 <performnud,auto_linklocal>pppoe0: flags=88d1 <up,pointopoint,running,noarp,simplex,multicast>metric 0 mtu 1492
            inet6 fe80::20c:  ff:f    :  c2%pppoe0 prefixlen 64 scopeid 0x7
            inet6 2003:56:ca7f:     :20c:   ff:fe   :  c2 prefixlen 64 autoconf
            inet 217.227.255.     --> 217.0.117.     netmask 0xffffffff
            nd6 options=23 <performnud,accept_rtadv,auto_linklocal></performnud,accept_rtadv,auto_linklocal></up,pointopoint,running,noarp,simplex,multicast></performnud,auto_linklocal></performnud,auto_linklocal></rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6></up,loopback,running,multicast></promisc></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum></up,broadcast,running,simplex,multicast> 

    ![Interfaces-Assign network ports.png](/public/imported_attachments/1/Interfaces-Assign network ports.png)
    ![Interfaces-Assign network ports.png_thumb](/public/imported_attachments/1/Interfaces-Assign network ports.png_thumb)

  • You did not get the IPv6 address (yet) :-
    Your Interfaces should show an "IPv6 Address" entry for PPPoE. And Dashboard-Interfaces should show at least a WAN IPv6 number entry.

    You have: pppoe0 as 2003:56:ca7f:–---; em1 as 2003:56:ca3c:-----; and  em0 as fe80::20c:----.
    What is all this ? Can you make a sensible explanation for it ? Devise a proper setup ?

    Your problem must/can be fixed with the corrrect pfSense-WAN config. This is Telekom/ISP specific...

  • Hello,

    I don't know why. But it works at the moment. I think it was a short disorder from my ISP. But I'm not sure.

    Thank you very much vor your help.

    Have I nice day.


  • @snowyrain:

    I don't know why…

    As a pfSense manager yourself, that is not a very satisfying position.  :P

Log in to reply