Terminais não acessão Servidor interno na rede com pfsense



  • Olá pessoal, já procurei em vários lugares aqui no fórum mas não encontrei uma explicação exata.
    tenho uma rede com 20 terminais e 1 servidor (Web) e 1 servidor de (Sistema Interno), os terminais não conseguem acessar o servidor do sistema interno, não fiz bloqueio algum no pfsense, esta tudo liberado.
    preciso que estas portas sejam acessives no servidor interno e no externo.
    1433 SQL Server / TPC e UDP
    1521 Oracle / TPC e UDP
    3389 RDP Windows / TPC
    3390 RDP Windows / TPC

    no Rules esta só com as regras padrão do pfsense.



  • Cria um alias com essas portas, depois vai em Rules e coloca para liberar tanto em wan quanto em lan…
    As regras padrão sao: se não está liberado, então está bloqueado...



  • Emerson, explica onde está o pfsense na sua rede.



  • EmersonDeBaldi

    Cara essa conexão para rede interna esta no print que estou te enviando é só fazer igual tem o nome de "TerminalService"!

    3389 RDP Windows /  TPC
    3390 RDP Windows /  TPC

    Essas duas portas se você não mexeu nas regras default já era pra té liberado o SQL e o ORACLE para o listener.ora aceitar a conexão, de toda forma abre essas porta na Lan esta no print que estou te mandando "AbriPortasNaLan"

    1433 SQL Server  /  TPC e UDP
    1521 Oracle  /  TPC e UDP

    Qualquer coisa posta ai…






  • claudevan, vou fazer o teste aqui agora…

    marcelloc meu pfsense esta em um pc somente pra ele.



  • Emerson, pergunto da posição dele na topologia da sua rede. Está entre as estações e o servidor? Cada um na sua faixa de rede?



  • marcelloc, desculpa não tinha entendido.
    Sim todos estão na mesma rede, todos em uma faixa de ip que começa do 192.168.1 até 192.168.8.200.
    meu servidor de sistema local também se conecta a um servidor web com apache, por isso não estou conseguindo.
    quando mudo uma linha de comando dos terminais, para o ip do servidor local ele da certo, porem quando mudo a linha de comando para o sistema web (sistemaweb.com.br) não da mais certo.

    conecta sistema = protocolo tcp (ip do servidor) (port = 1521) – > assim consigo conectar
    conecta sistema = protocolo tcp (sistema.dominio.com.br) (port = 1521) -- > assim não consigo conectar

    preciso abrir alguma porta ou fazer algum direcionamento?



  • Onde tá seu servidor de DNS?



  • Eu uso o pfsense como servidor de DNS.



  • @EmersonDeBaldi:

    conecta sistema = protocolo tcp (ip do servidor) (port = 1521) – > assim consigo conectar
    conecta sistema = protocolo tcp (sistema.dominio.com.br) (port = 1521) -- > assim não consigo conectar

    preciso abrir alguma porta ou fazer algum direcionamento?

    Se o ip de sistema.dominio.com.br for o seu ip da interface wan, terá que fazer um NAT em Firewall-> NAT, apontando para o ip do servidor e ativar o Nat Reflection em System->Advanced, conforme anexo.

    ou Criar um host no seu servidor de DNS para sistema.dominio.com.br ser o ip do seu servidor.

    ![Nat Reflection.png](/public/imported_attachments/1/Nat Reflection.png)
    ![Nat Reflection.png_thumb](/public/imported_attachments/1/Nat Reflection.png_thumb)



  • Agora deu certo de os terminais acessarem o sistema que esta no servidor.
    Agora só falta consegui acessar o sistema de fora da rede interna.
    Como faço pra abrir as portas para acessar o meu servidor de sistema.
    falei com o pessoal do nosso sistema e eles me disseram que só precisa abrir a porta 1521 e direcionar para o ip do servidor do sistema interno 192.168.8.3.
    mas ja tentei e não da certo.

    não sei se é assim que faz o direcionamento de fora para dentro.
    no meu servidor web esta com o ip 192.168.8.3




  • Se o programa usa a porta 1521 vc tem que redirecionar a porta 1521. Nas suas regras vc está redirecionando a porta 8088 para a porta 1521.

    Muda suas range porta destination para 1521 e testa



  • reinaldo.feitosa, fiz assim, mas só consigo conectar o sistema pela rede interna ainda.

    primeiro de tudo, meu servidor web é o mesmo servidor do sistema que usamos.
    como aqui é uma instituição se ensino, todos os alunos tem um usuário e senha pra acessar sua conta no servidor web, toda vez q o aluno acessa a pagina web da instituição ele é redirecionado para http://srv-vilhena.reges.com.br:8088/avec/logar.php?id=aluno.

    o sistema que usamos é interligado com o servidor web, pelo link srv-vilhena.reges.com.br.

    as portas q são utilizadas são:
    1433 SQL Server  /  TPC e UDP
    1521 Oracle  /  TPC e UDP
    3389 RDP Windows /  TPC
    3390 RDP Windows /  TPC

    segue ai as imagens para tentar entender…
    ta osso aqui...

    ![ip servidor web.jpg](/public/imported_attachments/1/ip servidor web.jpg)
    ![ip servidor web.jpg_thumb](/public/imported_attachments/1/ip servidor web.jpg_thumb)
    ![dominio servidor web.jpg](/public/imported_attachments/1/dominio servidor web.jpg)
    ![dominio servidor web.jpg_thumb](/public/imported_attachments/1/dominio servidor web.jpg_thumb)
    ![redirecionando 8088.jpg](/public/imported_attachments/1/redirecionando 8088.jpg)
    ![redirecionando 8088.jpg_thumb](/public/imported_attachments/1/redirecionando 8088.jpg_thumb)
    ![redirecionando 1521.jpg](/public/imported_attachments/1/redirecionando 1521.jpg)
    ![redirecionando 1521.jpg_thumb](/public/imported_attachments/1/redirecionando 1521.jpg_thumb)
    ![redirecionando 1433.jpg](/public/imported_attachments/1/redirecionando 1433.jpg)
    ![redirecionando 1433.jpg_thumb](/public/imported_attachments/1/redirecionando 1433.jpg_thumb)



  • Cara se seu servidor esta dentro da sua rede, não precisaria abrir a porta 1521(oracle) e nem a 1433(sql server), pois o servidor web que se conecta com o banco de dados e não a manquina do cliente. Abrir estas portas seria uma falha de segurança enorme.

    Eu consegui acessar seu site aqui normalmente, pediu usuário e senha e ao colocar qualqer coisa retornou usuario ou senha inválida. Isso indica que esta ok.

    Teria um aluno teste para eu testar pra vc?



  • Intendi, é q agora o servidor web esta no servidor firewall ipcop, quando eu coloco ele no pfsense ai não abre nada.
    é q não posso deixar em off este servidor, por isso esta com o ipcop, mas to tentando muda para o pfsense.

    tenta entrar agora.

    acabei de mudar para o servidor com o firewall pfsense.



  • @EmersonDeBaldi:

    Intendi, é q agora o servidor web esta no servidor firewall ipcop, quando eu coloco ele no pfsense ai não abre nada.
    é q não posso deixar em off este servidor, por isso esta com o ipcop, mas to tentando muda para o pfsense.

    tenta entrar agora.

    acabei de mudar para o servidor com o firewall pfsense.

    Se ainda estiver no pfsense está ok



  • Não estou no pfsense.
    não posso deixar muito tempo o site off…



  • O ip da interface WAN do pfSense é o mesmo do ipcop?



  • não reinaldo.feitosa, cada firewall tem um link dedicado da embratel.



  • Opa, desculpa a demora, mas ai esta o problema, pois seu domínio esta sempre apontando para o ip do ipcop, testa com o ip direto com o ip da sua WAN do pfsense.



  • opa reinaldo.feitosa tranquilo, mas eu não aponto para o ip do ipcop, tenho 2 link separados da embratel, um com o ipcop e outro com o pfsense.
    o link q eu uso com o pfsense, eu tenho um hostname no NO-IP (testepfsense.no-ip.org).



  • Posta a configuração da WAN ai para enter melhor



  • Ola reinaldo.feitosa, ai esta a configuração da Wan e do Nat.
    também criei um hostname (http://testepfsense.no-ip.org/) no NO-IP e coloquei a porta 10030, ai no nat estou direcionando a porta para a entrada da wan q seria a porta  (HTTP) 80, com o hostname que crei só consigo acessar com a rede interna.



    ![nat ip wan.png](/public/imported_attachments/1/nat ip wan.png)
    ![nat ip wan.png_thumb](/public/imported_attachments/1/nat ip wan.png_thumb)


Log in to reply