Failed to create RRD graphs



  • Hi all,

    On arecently updated machine (2.2.4) i have rrd graphs issue:

    php-fpm[6614]: /status_rrd_graph_img.php: Failed to create graph with error code 1, the error is: ERROR: This RRD was created on other architecture/usr/bin/nice -n20 /usr/local/bin/rrdtool graph /tmp/system-processor.rrd-eighthour.png –start 1438435981 --end 1438464781 --step 60 --vertical-label "utilization, number" --color SHADEA#eeeeee --color SHADEB#eeeeee --title "firewall.ideaplussolutions.net - System :: Processor - 8 hours - 1 minute average" --height 200 --width 620 DEF:"user=/var/db/rrd/system-processor.rrd:user:AVERAGE:step=60" DEF:"nice=/var/db/rrd/system-processor.rrd:nice:AVERAGE:step=60" DEF:"system=/var/db/rrd/system-processor.rrd:system:AVERAGE:step=60" DEF:"interrupt=/var/db/rrd/system-processor.rrd:interrupt:AVERAGE:step=60" DEF:"processes=/var/db/rrd/system-processor.rrd:processes:AVERAGE:step=60" AREA:"user#00AA00:user" AREA:"nice#990000:nice:STACK" AREA:"system#0000FF:system:STACK" AREA:"interrupt#DD9B00:interrupt:STACK" LINE2:"processes#000000:processes" COMMENT:"\n

    php-fpm[6614]: /status_rrd_graph_img.php: Failed to create graph with error code 1, the error is: ERROR: This RRD was created on other architecture/usr/bin/nice -n20 /usr/local/bin/rrdtool graph /tmp/system-processor.rrd-day.png –start 1438378381 --end 1438464781 --step 300 --vertical-label "utilization, number" --color SHADEA#eeeeee --color SHADEB#eeeeee --title "firewall.ideaplussolutions.net - System :: Processor - 1 day - 5 minutes average" --height 200 --width 620 DEF:"user=/var/db/rrd/system-processor.rrd:user:AVERAGE:step=300" DEF:"nice=/var/db/rrd/system-processor.rrd:nice:AVERAGE:step=300" DEF:"system=/var/db/rrd/system-processor.rrd:system:AVERAGE:step=300" DEF:"interrupt=/var/db/rrd/system-processor.rrd:interrupt:AVERAGE:step=300" DEF:"processes=/var/db/rrd/system-processor.rrd:processes:AVERAGE:step=300" AREA:"user#00AA00:user" AREA:"nice#990000:nice:STACK" AREA:"system#0000FF:system:STACK" AREA:"interrupt#DD9B00:interrupt:STACK" LINE2:"processes#000000:processes" COMMENT:"\n"

    any clue?




  • @nikkon:

    …the error is: ERROR: This RRD was created on other architecture...
    ...
    any clue?

    Explain this ?



  • i just wanted to check the latency and … no more graphs today as it can be seen in the screenshot.
    i have no clue how to fix-it. restart is not accepted now...so it may be restarted manually i guess.



  • No idea but, I see 2.2.3 in sig, to say for sure 2.2.4 is the better version…



  • is there a way to delete old logs/cache ?



  • See [Diagnostics: Execute command] ls -al /tmp ?



  • not much about rrd

    /root: ls -al /tmp
    total 408
    drwxrwxrwt  8 root    wheel      1536 Aug  2 01:31 .
    drwxr-xr-x  26 root    wheel      1024 Jul 30 17:54 ..
    drwxr-xr-x  2 root    wheel        512 Aug  1 00:29 .PBI.13407
    drwxr-xr-x  2 root    wheel        512 Aug  1 00:28 .PBI.44796
    srwxr-xr-x  1 clamav  wheel          0 Jul 31 23:50 .dguardianipc
    srwxr-xr-x  1 clamav  wheel          0 Jul 31 23:50 .dguardianurlipc
    drwxrwxr-x  2 root    operator    512 Jul 31 23:50 .snap
    -rw-rw-rw-  1 root    wheel          0 Aug  2 01:31 DDNS0.lock
    -rw-rw-rw-  1 root    wheel          0 Aug  1 23:50 aliasurl.lock
    -rw-r–r--  1 root    wheel        78 Aug  1 00:28 bootup_messages
    -rw-r--r--  1 root    wheel    144941 Aug  2 01:03 config.cache
    -rw-rw-rw-  1 root    wheel          0 Aug  2 01:31 config.lock
    -rw-r--r--  1 root    wheel        511 Jul 31 23:50 dhcpd.sh
    -rw-rw-rw-  1 root    wheel          0 Aug  2 01:31 filter.lock
    drwxr-xr-x  7 root    wheel        512 Aug  1 00:27 lighttpdcompress
    drwxr-xr-x  3 root    wheel        512 Jul 31 23:50 mnt
    -rw-rw-rw-  1 root    wheel          0 Aug  2 01:31 openvpn.lock
    -rw-r--r--  1 root    wheel        11 Jul 31 23:50 ovpns1_router
    -rw-r--r--  1 root    wheel          0 Jul 31 23:50 ovpns1up
    -rw-r--r--  1 root    wheel        118 Aug  1 00:29 pbi_delete_errors.txt
    -rw-r--r--  1 root    wheel          0 Jul 31 23:50 pfBaddfile
    -rw-r--r--  1 root    wheel        14 Aug  2 01:26 pfSense_version
    -rw-r--r--  1 root    wheel          0 Jul 31 23:50 pfbdeduptemp
    -rw-r--r--  1 root    wheel          0 Jul 31 23:50 pfbduptemp
    -rw-r--r--  1 root    wheel          0 Jul 31 23:50 pfbmatchfile
    -rw-r--r--  1 root    wheel          0 Jul 31 23:50 pfbsyncfile
    -rw-r--r--  1 root    wheel          0 Jul 31 23:50 pfbtempfile
    -rw-r--r--  1 root    wheel          0 Jul 31 23:50 pfbtempfile2
    -rw-r--r--  1 root    wheel          0 Jul 31 23:50 pfbtempmatchfile
    -rw-r--r--  1 root    wheel      1776 Aug  2 01:31 pfctl_si_out
    -rw-r--r--  1 root    wheel      95979 Aug  2 01:31 pfctl_ss_out
    -rw-r--r--  1 root    wheel          0 Jul 31 23:50 php_errors.txt
    -rw-r--r--  1 root    wheel      51330 Aug  1 00:29 pkg_info.cache
    -rw-r--r--  1 root    wheel          8 Jul 31 23:50 pppoe0_defaultgw
    -rw-r--r--  1 root    wheel          7 Jul 31 23:50 pppoe0_defaultgwv6
    -rw-r--r--  1 root    wheel        16 Jul 31 23:50 pppoe0_ip
    -rw-r--r--  1 root    wheel        15 Jul 31 23:50 pppoe0_ipv6
    -rw-r--r--  1 root    wheel          9 Jul 31 23:50 pppoe0_router
    -rw-r--r--  1 root    wheel          8 Jul 31 23:50 pppoe0_routerv6
    -rw-r--r--  1 root    wheel          0 Jul 31 23:50 pppoe0up
    -rw-r--r--  1 root    wheel          0 Jul 31 23:50 pppoe0upv6
    -rw-rw-rw-  1 root    wheel          0 Jul 31 23:50 resolvconf.lock
    -rw-r--r--  1 root    wheel      9114 Aug  2 01:31 rules.debug
    -rw-r--r--  1 root    wheel      9114 Aug  2 01:31 rules.debug.old
    -rw-r--r--  1 root    wheel        107 Aug  2 01:31 rules.limits
    -rw-r--r--  1 root    wheel        614 Aug  1 00:28 rules.test.packages
    -rw-------  1 root    wheel        216 Aug  2 01:31 sess_58b9b497995fc024e4afb17d95728898
    -rw-r--r--  1 root    wheel          0 Aug  2 01:31 tmpHOSTS
    drwxr-xr-x  2 root    wheel        512 Jul 31 23:50 xlsx



  • So the system did not make any *.png's store in /tmp with the data in /var/db/rrd ?



  • i got stuff in there:
    /var/db/rrd: ls
    DMZGW-quality.rrd    lan-packets.rrd      oltenia-quality.rrd  ovpns1-packets.rrd  system-mbuf.rrd      system-states.rrd    wan-traffic.rrd
    ipsec-packets.rrd    lan-traffic.rrd      opt1-packets.rrd    ovpns1-traffic.rrd  system-memory.rrd    updaterrd.sh
    ipsec-traffic.rrd    ntpd.rrd            opt1-traffic.rrd    ovpns1-vpnusers.rrd  system-processor.rrd wan-packets.rrd

    we'll delete all and see


  • Rebel Alliance

    If you want to "delete"  just go to "Status –> RRD Graphs --> Settings tab" and use the "Reset RRD Data" Button  ;)



  • done…that was what i intended.
    still have the old data...try to replace and not to loose the reports.
    in any case now it seems ok....it does work again.



  • During an upgrade you have switched from 32-bit ot 64-bit install (or even from 64-bit back to 32-bit). You should check on the dashboard if ou have 32 or 64 bit, and check in System->Firmware, Updater Settings to see if there is some special or wrong place selected for getting updates.
    If you change the 32/64 bit then the old RRD files will not work.