Network issues after 2.2.4 installation to disk



  • I installed from the live CD ISO image to a Dell PE850 with dual on board NICs.

    During the boot off the CD there were some nasty looking SCSI error messages and the boot was …s....l....o....w.... 
    The boot image is a straight image off a USB or HD isn't it? It tries to write to the image it's booting from and eventually times out doesn't it?
    (Other OS's boot fine off this CD drive, so yea, it's not hardware...)

    After finally getting the install onto the hard drive, I have the LAN interface connected to a switch, using the default 192.168.1.1 address, and a laptop manually configured at 192.168.1.2 on another port on the same switch.

    Neither machine can access the other --- no ping. pfSense command line actually returns a "no buffer" message after a bit.

    I logged into a shell from the console on the Dell and ifconfig shows both interfaces on the box with "no carrier", which I assume means no network/device link.
    I have confirmed that the NIC on the Dell and the switch port both indicate a 1GB connection/link is present. (I have briefly connected the other interface on the Dell to the same network to ensure that I have not made a mistake and selected the wrong port.  Same results.)

    I was at least able to get 2.2.(2 ? I think it was past this point).

    Any clues? 
    Where am I failing in what appears to be a very obvious installation path?



  • I can confirm the trouble installing 2.2.4 release directly on 2G CF-card on an ALIX.2d31. It was my first try with pfSense. After changing the baud-rate to 115200 I could

    read the boot messages:

    Welcome to pfSense 2.2.4-RELEASE  …

    Creating symlinks......ELF ldconfig path: /lib /usr/lib /usr/lib/compat /usr/local/lib
    a.out ldconfig path: /usr/lib/aout /usr/lib/compat/aout
    done.

    Under 512 megabytes of ram detected.  Not enabling APC.
    External config loader 1.0 is now starting...
    Launching the init system... done.
    Initializing...................... done.
    Starting device manager (devd)...done.
    Loading configuration......done.

    Default interfaces not found -- Running interface assignment option.
    vr0: link state changed to DOWN
    vr1: link state changed to DOWN
    vr2: link state changed to DOWN

    Valid interfaces are:

    vr0    00:0d:b9:20:d4:38  (up) VIA VT6105M Rhine III 10/100BaseTX
    vr1    00:0d:b9:20:d4:39  (up) VIA VT6105M Rhine III 10/100BaseTX
    vr2    00:0d:b9:20:d4:3a  (up) VIA VT6105M Rhine III 10/100BaseTX

    Do you want to set up VLANs first?

    If you are not going to use VLANs, or only for optional interfaces, you should
    say no here and use the webConfigurator to configure VLANs later, if required.

    Do you want to set up VLANs now [y|n]? vr0: link state changed to UP


    this was the end and the network 192.168.1.1 is not coming up. My NIC connected to LAN got

    following addresses:

    Ethernet-Adapter LAN-Verbindung:

    Verbindungsspezifisches DNS-Suffix:
      Verbindungslokale IPv6-Adresse  . : fe80::7cb3:965d:c1eb:67f8%11
      IPv4-Adresse (Auto. Konfiguration): 169.254.103.248
      Subnetzmaske  . . . . . . . . . . : 255.255.0.0
      Standardgateway . . . . . . . . . :


    after some slef-doubts I looked for an older image and found
    pfSense-2.1.3-RELEASE-2g-i386-nanobsd-20140501-1552.img
    which I could install succesfully and read with 9600 baudrate. Newer images I did not find out there.

    Bootup complete

    FreeBSD/i386 (pfSense.localdomain) (console)

    *** Welcome to pfSense 2.1.3-RELEASE-nanobsd (i386) on pfSense ***

    WAN (wan)      -> vr1        ->
    LAN (lan)      -> vr0        -> v4: 192.168.1.1/24

    1. Logout (SSH only)                  8) Shell
    2. Assign Interfaces                  9) pfTop
    3. Set interface(s) IP address      10) Filter Logs
    4. Reset webConfigurator password    11) Restart webConfigurator
    5. Reset to factory defaults        12) pfSense Developer Shell
    6. Reboot system                    13) Upgrade from console
    7. Halt system                      14) Enable Secure Shell (sshd)
    8. Ping host                        15) Restore recent configuration

    Enter an option:

    My NIC connected to LAN

    Ethernet-Adapter LAN-Verbindung:
      Verbindungsspezifisches DNS-Suffix: localdomain
      Verbindungslokale IPv6-Adresse  . : fe80::7cb3:965d:c1eb:67f8%11
      IPv4-Adresse  . . . . . . . . . . : 192.168.1.10
      Subnetzmaske  . . . . . . . . . . : 255.255.255.0
      Standardgateway . . . . . . . . . : fe80::1:1%11
                                          192.168.1.1

    Obviously the problem occured with 2GB NanoBSD (no VGA) flash issues (and upgrade issues) with 2.2.2
    https://forum.pfsense.org/index.php?topic=92709.0

    Please check and fix this issue.



  • This was solved here https://forum.pfsense.org/index.php?topic=92709.0 from what I read over there.

    I saw:

    Under 512 megabytes of ram detected.  Not enabling APC.

    How much RAM do you have ?



  • @Gertjan:

    This was solved here https://forum.pfsense.org/index.php?topic=92709.0 from what I read over there.

    I saw:

    Under 512 megabytes of ram detected.  Not enabling APC.

    How much RAM do you have ?

    I have been able to stumble on through the install, and it's working at this point.
    2GB of RAM in a Dell PowerEdge 850.

    After the installation of 2.2.4 I have gotten further with a functioning installation than any other attempt.
    Maybe I'm just learning a bit more  ???


Log in to reply