• Hi,

    I'm on 2.2.4, and I'm seeing most of my RRD Graphs working just fine … but throughput is blank (always). I have tried a data reset - no joy.

    Thoughts?

    Thanks!


  • Hi,

    FYI, on v2.2.5 … still empty Throughput plots.

    Is anyone else seeing this?

    Thanks!


  • Hmmm…....

    Just checked 7 of my systems upgraded ->2.2.5 ( 5x64 and 2x386 variously from 2.15, 2.2, 2.2.2, 2.2.4) and 6 had proper Throughput graphs.
    The last (one of the 386 systems 2.2.4->2.2.5) shows the grey graph page background and "dividing" lines for the seven expected graphs.
    Instead of a graph image I get a single link holder icon that's labelled "Graph".
    If I chose "System->Allgraphs", I get the full expected set WITHOUT the Throughput graphs at all.

    The two distinctive things about the problem system is that it has a largish number of Vlans (40+) and a dual WAN config for failover.

    Other than the (recently discovered) Throughput Graph issue, the site has been and remains problem free.
    For me, this is a purely cosmetic issue although it would be nice to get to the bottom of the issue.

    This may or may not be related to your issue…....

    Edit - updated system count and versions


  • Hi,

    Yep, my other plots are working - and I think this is a plotting issue … and I say this based on the attached plot. I reset my RRD data today, in case that was it, and you can see a blip of traffic in the plot, and totals down below that keep updating (as I refresh) - just no plot.

    Make sense?

    The other plots seem to work fine.

    Thanks!



  • Anything similar to mine as far as dual WAN, VLAN?

    I also have pretty minimal packages - OpenVPN Client export, check_mk, hmmm-RRD summary (hadn't noticed that before).

    What's your package load like?


  • Nope, no dual WAN, VLAN - even simpler … ;-). Pretty basic setup, but a few packages installed ... the list, below,

    • bandwidthd
    • darkstat
    • iperf
    • mailreport
    • nmap
    • ntopng
    • nut
    • RRD Summary
    • Shellcmd
    • System Patches
    • vnstat2

    Thoughts? Any look "suspicious" to you?

    Thanks!


  • Well, I see a cross match at "RRD summary" right off the bat.

    I may just try and shut that down and see if it helps…..


  • Uninstalled it, cleared the RRD Data, and … the same thing ... :-(. I get one or two output points on the plot, then it stops working / updating.

    Very odd .. :(


  • Yah, I tried a quick remove of the RRD-Summary package and then (was forced to) wipe the RRD data.

    Got a brief display of the Throughput display with no indications of anything (data hadn't loaded yet), then the "graphs" icons as before.

    I'm also seeing an error message in the "System Logs->System" about:

    "ERROR: '/var/db/rrd/opt1-traffic.rrd' is not an RRD"

    I shelled into /var/db/rrd and removed all the opt1*.rrd files, hoping for an auto build on the next round, but no luck and same issue with Throughput.
    I'm guessing I may have some cron piece of the RRD-Summary package still running?????

    I have to deal with some other issues for now, need to run.
    I'll check back later to see if I can beat this up, still only cosmetic for me.


  • Checked here - nothing in the logs, at least that I can see … :(.


  • The Traffic RRD graphs are built from the output of /sbin/pfctl -vvsI -i <real interface="">by the /var/db/rrd/updaterrd.sh script.

    It may be worth trying the pfctl command at the command prompt. For example, on my box:

    /sbin/pfctl -vvsI -i pppoe0
    pppoe0
            Cleared:    Sat Nov  7 00:30:51 2015
            References:  162             
            In4/Pass:    [ Packets: 1884512            Bytes: 1356895688        ]
            In4/Block:  [ Packets: 207302            Bytes: 26537135          ]
            Out4/Pass:  [ Packets: 1677864            Bytes: 190624512          ]
            Out4/Block:  [ Packets: 0                  Bytes: 0                  ]
            In6/Pass:    [ Packets: 923306            Bytes: 699444896          ]
            In6/Block:  [ Packets: 2787              Bytes: 385954            ]
            Out6/Pass:  [ Packets: 969469            Bytes: 90639385          ]
            Out6/Block:  [ Packets: 0                  Bytes: 0                  ]</real>


  • Tried the command, it works great. Is there a way to manually look at the RRD file?

    Thanks!


  • rrdtool dump <filename>| less
    should do what you want.

    The RRDtool documentation should guide you further.</filename>


  • Managed to get back to the box and try a few things.

    Definitely something munged with the opt1-* data files so after removing the RRD-Summary package I did a second reset of the RRD data.

    Everything seems to have come back and I have Throughput graphs again.

    I've reinstalled RRD-Summary and will continue to watch as the summary stats will take at least an hour to build.


  • RRD-Summary traffic is beginning to appear and my Throughput graphs are definitely live as well.

    I'm willing to chalk this one up to mangled RRD data (perhaps in conjunction with RRD Summary?).

    Seems OK for me, the rest of the box is certainly stable and anything else (10+ and counting) I've upgraded to 2.2.5 has been fine.


  • Hmmm … tried another reset of the data here, just in case. Still no joy ... :-(. Is there a way to reinstall / "factory reset" RRD?

    Thanks!


  • You could manually clear the RRD files to make sure that the "Reset RRD Data" does indeed clear everything.

    The RRD data is in /var/db/rrd, you can just delete everything in that folder and then click on "Reset RRD Data" to make sure the files get rebuilt properly.

    In my case I had already removed the RRD Summary package before I did a "full" reset.

    You might try a manual wipe and see if the graphs come back, if not try and remove the Summary package and then do a manual wipe.
    I was able to successfully add the Summary package back in after I got the Throughput graphs back


  • Very odd - I did a manual and full reset, restarted it all (without summary) … data shows up (in the directory), but still no plots. Is there a particular file to look at for throughput?

    Thanks!


  • Still fighting with this … :(. Seems it's only the throughput graphs that are broken - all the other RRD plots are fine.

    Is there a way to manually "review" the throughput data?

    Thanks!


  • FYI, still not working on (fresh upgrade) to 2.2.6.

    Thoughts?

    Thanks!