Sg 2220 bricked



  • I bought an sg-2220 to replace the old pc I was using as my pfsense gateway .  I downloaded the config from the pc and began the set up of my new sg-2220.  I connected the serial cable to the console port and booted up but without any ethernet cables connected.  Everything proceeded as expected.  I logged into the web GUI and cancelled out of the set up wizard.  I then started a restore and pointed to the config file from my old installation.  I got a message about a misconfiguration of the interfaces so I assigned the WAN and LAN ports and a reboot began.  And that's where I am now stuck.

    The boot process gets as far as identifying the boot device and just hangs there.  I've tried a hardware reset to no effect.

    Any help would be appreciated.


  • LAYER 8 Netgate

    Depending on what you restored it might be setting the speed of the serial port to something else.  I think the SGs default to 115200. Try 9600.

    Also, try something on what should be LAN. You might get DHCP and be able to bring up the webgui there.

    Doubt it's really "bricked."



  • Tried to get to the web GUI using the default 192.168.1.1 and what was in my config file 10.0.1.1.  Nothing

    Using the console, the boot sequence starts.  There are 2 options F1 pfsense and F5 disk.  Trying to use F12 to open the boot options doesn't work.  The boot process chooses F1 pfsense and hangs.

    I put the pfsense factory image on a USB key and tried to boot from that.  No effect. At boot, it defaults to pfsense and stalls,.

    I've tried the reset button.  No effect.

    I'm out of ideas.



  • Here is what I see in the terminal window

    SeaBIOS (version SageBIOS-20150715_105142-localhost.localdomain)

    iPXE (http://ipxe.org) 00:14.0 C100 PCI2.10 PnP PMM+7FB809D0+7FAE09D0 C100

    iPXE (http://ipxe.org) 00:14.1 C200 PCI2.10 PnP PMM 7FB809D0 7FAE09D0 C200

    iPXE (http://ipxe.org) 00:14.2 C300 PCI2.10 PnP PMM 7FB809D0 7FAE09D0 C300

    iPXE (http://ipxe.org) 00:14.3 C400 PCI2.10 PnP PMM 7FB809D0 7FAE09D0 C400

    Press F12 for boot menu.

    F1  pfSense
    F5  Drive 1

    F6 PXE
    Boot:  F1
    |

    And that's where it stays no matter what I do.


  • LAYER 8 Netgate

    Did you try connecting ethernet like I suggested?

    If that doesn't work, make a USB drive and reinstall.  And the SG-2220 comes with support, I believe.



  • I connected a laptop to the LAN port and tried 192.168.1.1 and 10.0.1.1 and nothing.  I was finally able to bring up the boot menu by changing a parameter on my terminal emulator and the eMMC drive is shown as not being bootable.


  • LAYER 8 Netgate

    Reinstall I guess.  Or call support.



  • I reinstalled and everything is in working order.  The question I now have is why trying to configure my new device using the config file from my old device broke the new one?  How is someone supposed to replace old hardware.  I thought this would be easy.



  • This:
    @denningsrogue:

    …..  I've tried a hardware reset to no effect.

    normally hasn't any side effects. But ones in a while it can even turn a PC in a brick.
    These things happened and will continue to happen.
    Pressing the reset button is and was a scary thing.
    Anyway, you thought there was no other choice, so done is done.

    Your system doesn't boot anymore which probably means that files need for booting are 'destroyed'. This has nothing to do with the config that you fed to pfSense. This file (config.xml) is read when the entire system is up, and about to finalize settings. And even if NIC's aren't set up correctly (important a plain config from PC to a 'sg-2220' will give network conflict, drivers aren't the same, etc) it will not break the code that handles the serial connection.

    You probably had your terminal software not setup correctly, so you thought the sg-2220 wasn't answering …. because it didn't receive info from you.
    As soon as the serial connection is ok, you can take control over your sg-2220 and have it boot from anything.



  • The device is now up and working.  I booted using the Netgate image on a USB stick and reinstalled to the eMMC.  So what's the recommended way of moving the configuration of my old pc to my new sg-2220.  I looked through the config.xml and I didn't see anything that obviously needed to change.  Can I just do the restore using the existing config.xml and use the GUI to fix any bits that break or do I have to follow a different approach.  I really want to avoid reconfiguring the whole thing manually – especially the OpenVPN server because my users (kids) are scattered around the world and having them reconfigure their clients would be quite and undertaking.

    Any help would be appreciated.


  • LAYER 8 Netgate

    What you did should have worked.  Edit the config.xml and change the interfaces to the new interface names (igp0/igb1?)

    Beware search and replace or you'll probably whack some crypto blobs. Be sure every replacement is actually an interface name. Should only take a couple minutes.  Then it should restore without the interface reassignment phase.

    Not that that's what blew up. It should have worked.


Log in to reply