Port forwarding not working after upgrade to 2.5



  • I'm running a Watchguard x750e that I updated to pfsense 2.2.5-RELEASE

    I had some rules that worked before for port forwarding.

    One in particular is for plex. (none of my rules are working yet)

    I went through my nat and deleted everything for the old plex forwarding and readded.  That didn't help.

    I'm not sure what I'm doing wrong.

    For the x750e, I'm only using 2 NICs right now.  1 for wan, 1 for lan.

    My plex box sits on the lan.

    From within my lan, I can use plex from a browser, so I know that parts working.

    But, the hole that poked through doesnt seem to be working.

    Here's what I have.

    Under firewall->nat

    1 Rule
    Interface:wan
    protocol:tcp/udp (also tried just tcp)
    Destination port range: 32400
    Redirect target IP: 192.168.1.71 (that's the port of my server on the lan)
    Nat reflection: use system default
    Filter rule association: Rule NAT plex32400

    Under Firewall->Rules

    1 Rule
    Action:Pass
    Interface:wan
    TCP/IP Version: ipv4
    Protocol: tcpudp
    Destination: Single host or alias 192.168.1.71 / 31
    Destination port range: 32400 32400

    From my server:
    The following shows the ip is correct, the server can get out to the interwebs, and the port is correct.

    ifconfig -a | grep 192
              inet addr:192.168.1.71

    ping pfsense.org
    PING pfsense.org (208.123.73.69) 56(84) bytes of data.
    64 bytes from www2.atx.pfmechanics.com (208.123.73.69): icmp_seq=1 ttl=44 time=69.1 ms

    lsof -i :32400
    COMMAND  PID USER  FD  TYPE DEVICE SIZE/OFF NODE NAME
    Plex    2077 plex  54u  IPv4  20779      0t0  TCP *:32400 (LISTEN)

    What did I do wrong?



  • Resolved.

    When I updated pfsense, my ISP gave my router a new IP.  My internet box had NAT to the old ip.  Updated the ip, and it's working now.


  • LAYER 8 Netgate

    Try using Destination: WAN address instead.



  • I had ipv6 enabled and all my rules didn't work after the upgrade.

    Try and enable " Prefer to use IPv4 even if IPv6 is available"



Log in to reply