Thank you!



  • I finally got arround to try and loadbalance my 2 X 2048 adsl connections, and this is just too cool!

    pfSense rocks!



  • How about failover?

    Does FTP / HTTP / SSH / PING / etc works when WAN is down, and OPT1 is up?

    If so, mind posting your detail configuration (except the real IP addresses)? Thanks.



  • I haven't tested it with WAN down yet, but I sure will.
    ftp in passive mode never really worked also not before I added load balance, never really got arround to figuring out why.

    I'll test with wan down tihis weekend and let you know if it works or not :)



  • Failover didn't work that well after unplugging the wan :(

    When trying to ping yahoo.dk (217.12.3.11 that I also use as monitor IP) it only worked every second time, from both linux and windows.
    The http download also didn't failover.

    print screen of tests: http://server.cybersite.dk/wan_down/

    should I have done anything on the clients or on pfSense for failover to work?

    my setup is like this

    pfSense Version  RELENG_1_SNAPSHOT_04-03-2006 built on Thu Mar 2 04:23:07 UTC 2006

    isp (dhcp) –> cheap router 10.42.1.1 DMZ -> static 10.42.1.2 OPT1 pfSense
    isp (dhcp) x-> cheap router 10.42.2.1 DMZ -> static 10.42.2.2 WAN  pfSense LAN 192.168.1.1 -> (dhcp) clients

    (x = where I broke the connection to test failover)

    I just noticed that my Load Balancer Pool says
    name = load_balance

    Servers/Gateways =
    10.42.1.1|217.12.3.11
    10.42.2.1|217.12.3.11

    but Monitor is empty ? shouldn't 217.12.3.11 be in there ?
    also if I click edit on the pool "list" is empty like I would have to add everything again?

    I have enabled advanced outbound NAT, adding " WAN 192.168.1.0/24 ***** NO" and "OPT1 192.168.1.0/24 ***** NO"

    In the firewall rules under LAN I added a rule for outgoing SMTP using 10.42.1.1 as gateway (I need that) and I change the gateway on the default LAN rule to "load_balance" (my pool from above).

    everything seems to work very nicely as long as both WAN's are up.



  • Blah so you've no luck as well on failover.

    Humm… in older snapshots one had to enter static routes to force "monitor pings" going through the correct gateway.
    Search in this sub-forum with keyword "gateway" or "static route" and you should see how others did that.

    Also newest snapshot is at 04-12. Maybe that will give you better luck as well.

    If all fails, at least submit a bug report about pool edit "empty list bug" that you've mentioned.

    (yeah yeah yeah I should try it myself as well... don't have time yet)



  • I only tested it because you asked me to.

    Failover isn't that important to me, so I'm not going to use a lot of time trying to make it work.



  • @usk:

    I only tested it because you asked me to.

    Failover isn't that important to me, so I'm not going to use a lot of time trying to make it work.

    Oh opps… sorry I didn't mean to ask you to test it just for me. Thank you though.



  • Guys – monitoring is currently broken.  We're working on a fix.  This should be set to go in Beta 3 which is scheduled for release tomorrow but this issue may push us back to Sunday.


Log in to reply