[SOLVED] - PPPoE can't set PPP-Max-Payload value



  • Recently I installed pfSense 2.3 and the last update ( today 2.3_1 ).

    I have the WAN1 an xDSL modem in bridge mode through which I am trying to accomplish a PPPoE connection and I'm not having success .

    To test, I created a PPPoE connection on a PC with Windows, connected to the same modem and it worked perfectly.

    pfSense is showing the error " Invalid argument " when trying to set the MTU on PPPoE connection, as can be seen in the log below.

    Thanks.

    
    May 5 20:45:13	ppp		[wan_link0] Link: reconnection attempt 13 in 4 seconds
    May 5 20:45:17	ppp		[wan_link0] Link: reconnection attempt 13
    May 5 20:45:17	ppp		[wan_link0] PPPoE can't set PPP-Max-Payload value: Invalid argument
    May 5 20:45:17	ppp		[wan_link0] Link: DOWN event
    May 5 20:45:17	ppp		[wan_link0] LCP: Down event
    May 5 20:45:17	ppp		[wan_link0] Link: reconnection attempt 14 in 1 seconds
    May 5 20:45:18	ppp		[wan_link0] Link: reconnection attempt 14
    May 5 20:45:18	ppp		[wan_link0] PPPoE can't set PPP-Max-Payload value: Invalid argument
    May 5 20:45:18	ppp		[wan_link0] Link: DOWN event
    May 5 20:45:18	ppp		[wan_link0] LCP: Down event
    May 5 20:45:18	ppp		[wan_link0] Link: reconnection attempt 15 in 4 seconds
    May 5 20:45:22	ppp		[wan_link0] Link: reconnection attempt 15
    May 5 20:45:22	ppp		[wan_link0] PPPoE can't set PPP-Max-Payload value: Invalid argument
    May 5 20:45:22	ppp		[wan_link0] Link: DOWN event
    May 5 20:45:22	ppp		[wan_link0] LCP: Down event
    May 5 20:45:22	ppp		[wan_link0] Link: reconnection attempt 16 in 4 seconds
    
    


  • What's your "set pppoe max-payload" line have in /var/etc/mpd_wan.conf?



  • Cmb, thanks for answer!

    My entire /var/etc/mpd_wan.conf is here:

    As you can see, two facts:
    1 - does not exists a parameter "pppoe max-payload" in this file
    2 - the unique line refers to mtu, apparently has the wrong syntax, in the same line containing the "SET auth authname" command

    
    # cat mpd_wan.conf
    startup:
            # configure the console
            set console close
            # configure the web server
            set web close
    
    default:
    pppoeclient:
            create bundle static wan
            set bundle enable ipv6cp
            set iface name pppoe0
            set iface disable on-demand
            set iface idle 0
            set iface enable tcpmssfix
            set iface up-script /usr/local/sbin/ppp-linkup
            set iface down-script /usr/local/sbin/ppp-linkdown
            set ipcp ranges 0.0.0.0/0 0.0.0.0/0
            set ipcp enable req-pri-dns
            set ipcp enable req-sec-dns
            #log -bund -ccp -chat -iface -ipcp -lcp -link
    
            create link static wan_link0 pppoe
            set link action bundle wan
            set link disable multilink
            set link keep-alive 10 60
            set link max-redial 0
            set link disable chap pap
            set link accept chap pap eap
            set link disable incoming
            set link mtu 1492       set auth authname "***********"
            set auth password ********
            set pppoe service ""
            set pppoe iface rl0
            open
    
    


  • @GRM:

    2 - the unique line refers to mtu, apparently has the wrong syntax, in the same line containing the "SET auth authname" command

    <snip>set link mtu 1492      set auth authname "***********"</snip>

    So that is all on one line in the file? Did you make any code changes to the system? That's the only way I see that you could end up without a new line there.

    The code that sets "set link mtu" is (in /etc/inc/interfaces.inc):

                            $mpdconf .= <<<eod<br>set link mtu {$mtus[$pid]}
    
    EOD;</eod<br> 
    

    and that's the only place that gets set. That new line above EOD; means those two lines aren't concatenated.



  • Sorry, I really changed ( and unchange ) the interfaces.inc, trying to fix the mtu in 1500 in that line, and sure to undo the amendment eliminated the line is blank.

    Now I fix it and /var/etc/mpd_wan.conf is being generated correctly.

    Correction:

    
                            $mpdconf .= <<<eod<br>set link mtu {$mtus[$pid]}
    
    EOD;</eod<br> 
    

    new mpd_wan.conf generated:

    
    set link disable incoming
    set link mtu 1492
    set auth authname "*******"
    set auth password *****
    
    

    But unfortunately the initial problem remains. Thank you!

    May 6 01:14:01 ppp [wan_link0] PPPoE can't set PPP-Max-Payload value: Invalid argument



  • Now what does your mpd config look like?



  • My new mpd_wan.conf:

    
    startup:
            # configure the console
            set console close
            # configure the web server
            set web close
    
    default:
    pppoeclient:
            create bundle static wan
            set bundle enable ipv6cp
            set iface name pppoe0
            set iface disable on-demand
            set iface idle 0
            set iface enable tcpmssfix
            set iface up-script /usr/local/sbin/ppp-linkup
            set iface down-script /usr/local/sbin/ppp-linkdown
            set ipcp ranges 0.0.0.0/0 0.0.0.0/0
            set ipcp enable req-pri-dns
            set ipcp enable req-sec-dns
            #log -bund -ccp -chat -iface -ipcp -lcp -link
    
            create link static wan_link0 pppoe
            set link action bundle wan
            set link disable multilink
            set link keep-alive 10 60
            set link max-redial 0
            set link disable chap pap
            set link accept chap pap eap
            set link disable incoming
            set link mtu 1492
            set auth authname "*******"
            set auth password ********
            set pppoe service ""
            set pppoe iface rl0
            open
    
    

    The problem remains.

    Thank you cmb.



  • What exactly does your PPP log show now? Doesn't seem likely you'd be getting exactly the same log as that's specific to the invalid syntax you had.



  • Thanks cmb!

    After setting the /etc/interfaces.inc my mpd_wan.conf file was generated correctly, as in the above post, but the log still displays the following (as before):

    
    May 7 21:47:21	ppp		[wan_link0] Link: reconnection attempt 5
    May 7 21:47:21	ppp		[wan_link0] PPPoE can't set PPP-Max-Payload value: Invalid argument
    May 7 21:47:21	ppp		[wan_link0] Link: DOWN event
    May 7 21:47:21	ppp		[wan_link0] LCP: Down event
    May 7 21:47:21	ppp		[wan_link0] Link: reconnection attempt 6 in 4 seconds
    May 7 21:47:25	ppp		[wan_link0] Link: reconnection attempt 6
    May 7 21:47:25	ppp		[wan_link0] PPPoE can't set PPP-Max-Payload value: Invalid argument
    May 7 21:47:25	ppp		[wan_link0] Link: DOWN event
    May 7 21:47:25	ppp		[wan_link0] LCP: Down event
    May 7 21:47:25	ppp		[wan_link0] Link: reconnection attempt 7 in 2 seconds
    May 7 21:47:27	ppp		[wan_link0] Link: reconnection attempt 7
    May 7 21:47:27	ppp		[wan_link0] PPPoE can't set PPP-Max-Payload value: Invalid argument
    May 7 21:47:27	ppp		[wan_link0] Link: DOWN event
    May 7 21:47:27	ppp		[wan_link0] LCP: Down event
    May 7 21:47:27	ppp		[wan_link0] Link: reconnection attempt 8 in 2 seconds
    
    


  • Have you rebooted since fixing the config? Maybe mpd still has something from the old config stuck in it. Not sure how you could end up with that log with the correct config.



  • Yes! I reboot several times after the fix . Even now immediately before posting this response. Plus, every time something changed in the settings, to effect the changes, I disable and enable WAN1.



  • Hi!

    After some days trying to solve this issue without success, I decide reinstall pfSense 2.3. And Bingo!!! All works fine and the error message was gone!

    Conclusion: none!

    Thank you cmb.



  • Guessing there was something else still hanging around from the changes you made that was causing an issue. Glad it's working now.