Idle timeout (Minutes) not working welll



  • Hello dears,
    there is a problem in Idle timeout, it isn't working well I have made it 7200 minutes to be equal 2 hours but it expire throw 3 minutes of 16 minutes and so on …
    Please see my attached configuration ....






  • @computerz_man:

    Hello dears,
    there is a problem in Idle timeout, it isn't working well I have made it 7200 minutes to be equal 2 hours but it expire throw 3 minutes of 16 minutes and so on …
    Please see my attached configuration ....

    Hi,
    For me, 7200 minutes = 120 hours = 5 days.

    But true, your "ltadmin" is thrown out after approx 15 minutes ….

    edit : your pfSense version ?



  • Hi "Gertjan", i use pfsense  2.3.1-RELEASE-p5 (amd64)



  • How long is your :
    Default DHCP lease time ?
    Max DHCP lease time ?
    concerning your interfaces interfaces ?

    You are using a captive portal on LAN and OPT1 ?

    Btw : Captive portal users are 'DISCONNECTED' by the function captiveportal_prune_old() (/etc/inc/captiveportal.inc)

    Note : a "idletimeout" of 7200 minutes should NEVER log you out (= DISCONNECT). Today, every device does communicate all the time. For example, update checks are running all the time. A basic Windows system will sue the Internet - if a connection is available - all the time.
    This means that the activity indicator (see Status -> Captive portal - and hit the "Show last Activity" button) will be set to a recent time all the time. A period of 5 days of NO activity at all is impossible.
    This means that's something is very wrong ….

    note2 : Did you checked "Status -> Captive portal - (and hit the "Show last Activity" button)" ? The Colum "Last activity" stays on recent times ?