Squid cant redirect ssl website correctly to squidguard error page in a denied c



  • When you use "squid" with "squidguard" set in "NO" transparent mode, any category denied previously (squidguard) the browser shows an invalid cert for the domain "http", this happens always, if you ignore the warning, squid show an error

    ERROR
    The requested URL could not be retrieved

    The following error was encountered while trying to retrieve the URL: https://http/*

    Unable to determine IP address from host name http

    The DNS server returned:

    Name Error: The domain name does not exist.
    This means that the cache was not able to resolve the hostname presented in the URL. Check if the address is correct.

    But never shows the error page from squidguard, I tested many pages with the same result, the certificate issue only appears when the website is denied by a rule from squidguard when you inspect ssl.

    I attached screenshots with the tests.

    Package version:
    pfsense 2.3.2-RELEASE (amd64)
    squid 3.5.19_1
    squidguard 1.4_15

    This bug is present too in 2.3.3, someone can help? I tried to apply a workaround but I cant see where is the issue
    I reported this in https://redmine.pfsense.org/issues/6777

    Regards