Testing Needed: OpenVPN Client Export for OpenVPN 2.4


  • Rebel Alliance Developer Netgate

    A new version of OpenVPN client export for pfSense 2.3.x with OpenVPN 2.4 is up now for testing in the 2.3.3 snapshots.

    Key changes:

    • OpenVPN 2.4 is available to download. There is only one OpenVPN 2.4 installer, but it works on both 64 and 32 bit versions of Windows. This installer requires Windows Vista or later and will not work on Windows XP
    • The manager option for Windows has been removed from the export package and installer. The native OpenVPN-GUI uses the new service in OpenVPN 2.4 for managing connections, meaning unprivileged users can use OpenVPN and it will add routes properly. (Note that admin access is still required to install the OpenVPN client)
    • OpenVPN 2.3.x client options remain in the export package for the time being, and they have been updated to 2.3.14

    Changes for the server side of things should work as they always have. pfSense 2.3.3 does not have OpenVPN 2.4, so the package does not need to attempt to handle its settings.

    If this tests out OK, the package can be enabled for 2.3.2-p1 as well but it needs testing first.



  • Android export and use of is fine here.



  • An OpenVPN "client import" feature would also be good, when setting up site-to-site connections between two pfSense boxes. Using the Android-exported config (which contains all the config parameters and the certs/keys too), would be nice to be able to simply upload it on the other box (somewere at the client section), and present the uploaded file as an editable client config, which would be saved when the user just presses Save at the bottom. Client certs would be automatically added this way too.


  • Rebel Alliance Developer Netgate

    That is a much, much different and more difficult problem to solve, and has nothing to do with this topic.


Log in to reply