2.4 dhcp problem



  • Order of events

    Built in wireless card in laptop setup with static dhcp lease ip 192.168.1.125
    AC wireless dongle which was unused the MAC was entered with a static ip of 192.168.1.225
    I decided to start using the dongle.
    Disabled built in wireless card on laptop.
    Plugged in dongle to laptop.
    It connected using the correct 192.168.1.225 ip, however I want to use .125
    Changed the MAC for built in wireless card to use 192.168.1.25
    Changed AC dongle to use 192.168.1.125 and applied settings.
    Laptop still on 192.168.1.225
    Ran dhcp release in windows
    Recconected laptop and still 192.168.1.225
    Tried disabling the dongle in device manager and enabling again.
    Still 192.168.1.225

    On the Status - DHCP Leases screen the AC Dongle shows as online and using 192.168.1.125
    There is nothing showing at all on the leases screen using 192.168.1.225 although thats what the laptop is using.

    I have double checked the laptop is configured to use DHCP for ipv4.  There is no other DHCP server active on my lan.



  • I have also verified the following.

    The contents of '/var/dhcpd/etc/dhcpd.conf' is correct.

    If I restart the dhcpd service in the gui, the PID does change for the running service confirming its restarted.

    Never mind, seems a reboot on the laptop fixed it, I guess windows had some kind of caching going on.



  • 0_o


Log in to reply