Errors on startup



  • Hi,

    Everytime pfSense boots different errors are seen in the logs:

    
    There were error(s) loading the rules: pfctl: DIOCXCOMMIT: Device busy - The line in question reads [0]: @ 2017-06-02 10:22:07
    
    

    and when the Ipsec Package loads:

    
    route: writing to routing socket: Invalid argument
    
    

    output of dmesg -a

    
    Copyright (c) 1992-2016 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
            The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 11.0-RELEASE-p10 #107 70e0097c7ce(RELENG_2_4): Thu Jun  1 17:20:13 CDT 2017
        root@buildbot2.netgate.com:/builder/ce/tmp/obj/builder/ce/tmp/FreeBSD-src/sys/pfSense amd64
    FreeBSD clang version 3.8.0 (tags/RELEASE_380/final 262564) (based on LLVM 3.8.0)
    VT(vga): text 80x25
    CPU: Intel(R) Core(TM) i7 CPU         960  @ 3.20GHz (3197.73-MHz K8-class CPU)
      Origin="GenuineIntel"  Id=0x106a5  Family=0x6  Model=0x1a  Stepping=5
      Features=0x1fa3fbff <fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,dts,mmx,fxsr,sse,sse2,ss,htt>Features2=0x81b82221 <sse3,vmx,ssse3,cx16,sse4.1,sse4.2,x2apic,popcnt,tscdlt,hv>AMD Features=0x28100800 <syscall,nx,rdtscp,lm>AMD Features2=0x1 <lahf>Structured Extended Features=0x2 <tscadj>VT-x: PAT,HLT,MTF,PAUSE,EPT,VPID
      TSC: P-state invariant
    Hypervisor: Origin = "VMwareVMware"
    real memory  = 2147483648 (2048 MB)
    avail memory = 2023333888 (1929 MB)
    Event timer "LAPIC" quality 400
    ACPI APIC Table: <ptltd   ="" apic ="">FreeBSD/SMP: Multiprocessor System Detected: 4 CPUs
    FreeBSD/SMP: 2 package(s) x 2 core(s)
    MADT: Forcing active-low polarity and level trigger for SCI
    ioapic0 <version 1.1="">irqs 0-23 on motherboard
    random: entropy device external interface
    wlan: mac acl policy registered
    iwi_bss: You need to read the LICENSE file in /usr/share/doc/legal/intel_iwi.LICENSE.
    iwi_bss: If you agree with the license, set legal.intel_iwi.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (iwi_bss_fw, 0xffffffff8069ea50, 0) error 1
    iwi_ibss: You need to read the LICENSE file in /usr/share/doc/legal/intel_iwi.LICENSE.
    iwi_ibss: If you agree with the license, set legal.intel_iwi.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (iwi_ibss_fw, 0xffffffff8069eb00, 0) error 1
    iwi_monitor: You need to read the LICENSE file in /usr/share/doc/legal/intel_iwi.LICENSE.
    iwi_monitor: If you agree with the license, set legal.intel_iwi.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (iwi_monitor_fw, 0xffffffff8069ebb0, 0) error 1
    kbd1 at kbdmux0
    netmap: loaded module
    module_register_init: MOD_LOAD (vesa, 0xffffffff8122cb10, 0) error 19
    vtvga0: <vt vga="" driver="">on motherboard
    cryptosoft0: <software crypto="">on motherboard
    padlock0: No ACE support.
    acpi0: <intel 440bx="">on motherboard
    acpi0: Power Button (fixed)
    Timecounter "HPET" frequency 14318180 Hz quality 950
    cpu0: <acpi cpu="">numa-domain 0 on acpi0
    cpu1: <acpi cpu="">numa-domain 0 on acpi0
    cpu2: <acpi cpu="">numa-domain 0 on acpi0
    cpu3: <acpi cpu="">numa-domain 0 on acpi0
    attimer0: <at timer="">port 0x40-0x43 irq 0 on acpi0
    Timecounter "i8254" frequency 1193182 Hz quality 0
    Event timer "i8254" frequency 1193182 Hz quality 100
    atrtc0: <at realtime="" clock="">port 0x70-0x71 irq 8 on acpi0
    Event timer "RTC" frequency 32768 Hz quality 0
    Timecounter "ACPI-fast" frequency 3579545 Hz quality 900
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
    pcib0: <acpi host-pci="" bridge="">port 0xcf8-0xcff on acpi0
    pci0: <acpi pci="" bus="">on pcib0
    pcib1: <acpi pci-pci="" bridge="">at device 1.0 on pci0
    pci1: <acpi pci="" bus="">on pcib1
    isab0: <pci-isa bridge="">at device 7.0 on pci0
    isa0: <isa bus="">on isab0
    atapci0: <intel piix4="" udma33="" controller="">port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x1060-0x106f at device 7.1 on pci0
    ata0: <ata channel="">at channel 0 on atapci0
    ata1: <ata channel="">at channel 1 on atapci0
    pci0: <bridge>at device 7.3 (no driver attached)
    vgapci0: <vga-compatible display="">port 0x1070-0x107f mem 0xe8000000-0xefffffff,0xfe000000-0xfe7fffff irq 16 at device 15.0 on pci0
    vgapci0: Boot video device
    mpt0: <lsilogic 1030="" ultra4="" adapter="">port 0x1400-0x14ff mem 0xfeba0000-0xfebbffff,0xfebc0000-0xfebdffff irq 17 at device 16.0 on pci0
    mpt0: MPI Version=1.2.0.0
    pcib2: <acpi pci-pci="" bridge="">at device 17.0 on pci0
    pci2: <acpi pci="" bus="">on pcib2
    pcib3: <acpi pci-pci="" bridge="">at device 21.0 on pci0
    pcib3: [GIANT-LOCKED]
    pci3: <acpi pci="" bus="">on pcib3
    vmx0: <vmware vmxnet3="" ethernet="" adapter="">port 0x4000-0x400f mem 0xfd5fc000-0xfd5fcfff,0xfd5fd000-0xfd5fdfff,0xfd5fe000-0xfd5fffff irq 18 at device 0.0 on pci3
    vmx0: Ethernet address: 00:60:70:df:00:01
    pcib4: <acpi pci-pci="" bridge="">at device 21.1 on pci0
    pcib4: [GIANT-LOCKED]
    pci4: <acpi pci="" bus="">on pcib4
    vmx1: <vmware vmxnet3="" ethernet="" adapter="">port 0x8000-0x800f mem 0xfd1fc000-0xfd1fcfff,0xfd1fd000-0xfd1fdfff,0xfd1fe000-0xfd1fffff irq 18 at device 0.0 on pci4
    vmx1: Ethernet address: fc:d4:f2:df:00:04
    pcib5: <acpi pci-pci="" bridge="">at device 21.2 on pci0
    pcib5: [GIANT-LOCKED]
    pcib6: <acpi pci-pci="" bridge="">at device 21.3 on pci0
    pcib6: [GIANT-LOCKED]
    pcib7: <acpi pci-pci="" bridge="">at device 21.4 on pci0
    pcib7: [GIANT-LOCKED]
    pcib8: <acpi pci-pci="" bridge="">at device 21.5 on pci0
    pcib8: [GIANT-LOCKED]
    pcib9: <acpi pci-pci="" bridge="">at device 21.6 on pci0
    pcib9: [GIANT-LOCKED]
    pcib10: <acpi pci-pci="" bridge="">at device 21.7 on pci0
    pcib10: [GIANT-LOCKED]
    pcib11: <acpi pci-pci="" bridge="">at device 22.0 on pci0
    pcib11: [GIANT-LOCKED]
    pci5: <acpi pci="" bus="">on pcib11
    vmx2: <vmware vmxnet3="" ethernet="" adapter="">port 0x5000-0x500f mem 0xfd4fc000-0xfd4fcfff,0xfd4fd000-0xfd4fdfff,0xfd4fe000-0xfd4fffff irq 19 at device 0.0 on pci5
    vmx2: Ethernet address: fc:d4:f2:df:00:01
    pcib12: <acpi pci-pci="" bridge="">at device 22.1 on pci0
    pcib12: [GIANT-LOCKED]
    pci6: <acpi pci="" bus="">on pcib12
    vmx3: <vmware vmxnet3="" ethernet="" adapter="">port 0x9000-0x900f mem 0xfd0fc000-0xfd0fcfff,0xfd0fd000-0xfd0fdfff,0xfd0fe000-0xfd0fffff irq 19 at device 0.0 on pci6
    vmx3: Ethernet address: fc:d4:f2:df:00:05
    pcib13: <acpi pci-pci="" bridge="">at device 22.2 on pci0
    pcib13: [GIANT-LOCKED]
    pcib14: <acpi pci-pci="" bridge="">at device 22.3 on pci0
    pcib14: [GIANT-LOCKED]
    pcib15: <acpi pci-pci="" bridge="">at device 22.4 on pci0
    pcib15: [GIANT-LOCKED]
    pcib16: <acpi pci-pci="" bridge="">at device 22.5 on pci0
    pcib16: [GIANT-LOCKED]
    pcib17: <acpi pci-pci="" bridge="">at device 22.6 on pci0
    pcib17: [GIANT-LOCKED]
    pcib18: <acpi pci-pci="" bridge="">at device 22.7 on pci0
    pcib18: [GIANT-LOCKED]
    pcib19: <acpi pci-pci="" bridge="">at device 23.0 on pci0
    pcib19: [GIANT-LOCKED]
    pci7: <acpi pci="" bus="">on pcib19
    vmx4: <vmware vmxnet3="" ethernet="" adapter="">port 0x6000-0x600f mem 0xfd3fc000-0xfd3fcfff,0xfd3fd000-0xfd3fdfff,0xfd3fe000-0xfd3fffff irq 16 at device 0.0 on pci7
    vmx4: Ethernet address: fc:d4:f2:df:00:02
    pcib20: <acpi pci-pci="" bridge="">at device 23.1 on pci0
    pcib20: [GIANT-LOCKED]
    pcib21: <acpi pci-pci="" bridge="">at device 23.2 on pci0
    pcib21: [GIANT-LOCKED]
    pcib22: <acpi pci-pci="" bridge="">at device 23.3 on pci0
    pcib22: [GIANT-LOCKED]
    pcib23: <acpi pci-pci="" bridge="">at device 23.4 on pci0
    pcib23: [GIANT-LOCKED]
    pcib24: <acpi pci-pci="" bridge="">at device 23.5 on pci0
    pcib24: [GIANT-LOCKED]
    pcib25: <acpi pci-pci="" bridge="">at device 23.6 on pci0
    pcib25: [GIANT-LOCKED]
    pcib26: <acpi pci-pci="" bridge="">at device 23.7 on pci0
    pcib26: [GIANT-LOCKED]
    pcib27: <acpi pci-pci="" bridge="">at device 24.0 on pci0
    pcib27: [GIANT-LOCKED]
    pci8: <acpi pci="" bus="">on pcib27
    vmx5: <vmware vmxnet3="" ethernet="" adapter="">port 0x7000-0x700f mem 0xfd2fc000-0xfd2fcfff,0xfd2fd000-0xfd2fdfff,0xfd2fe000-0xfd2fffff irq 17 at device 0.0 on pci8
    vmx5: Ethernet address: fc:d4:f2:df:00:03
    pcib28: <acpi pci-pci="" bridge="">at device 24.1 on pci0
    pcib28: [GIANT-LOCKED]
    pcib29: <acpi pci-pci="" bridge="">at device 24.2 on pci0
    pcib29: [GIANT-LOCKED]
    pcib30: <acpi pci-pci="" bridge="">at device 24.3 on pci0
    pcib30: [GIANT-LOCKED]
    pcib31: <acpi pci-pci="" bridge="">at device 24.4 on pci0
    pcib31: [GIANT-LOCKED]
    pcib32: <acpi pci-pci="" bridge="">at device 24.5 on pci0
    pcib32: [GIANT-LOCKED]
    pcib33: <acpi pci-pci="" bridge="">at device 24.6 on pci0
    pcib33: [GIANT-LOCKED]
    pcib34: <acpi pci-pci="" bridge="">at device 24.7 on pci0
    pcib34: [GIANT-LOCKED]
    acpi_acad0: <ac adapter="">on acpi0
    atkbdc0: <keyboard controller="" (i8042)="">port 0x60,0x64 irq 1 on acpi0
    atkbd0: <at keyboard="">irq 1 on atkbdc0
    kbd0 at atkbd0
    atkbd0: [GIANT-LOCKED]
    psm0: <ps 2="" mouse="">irq 12 on atkbdc0
    psm0: [GIANT-LOCKED]
    psm0: model IntelliMouse, device ID 3
    qpi0: <qpi system="" bus="">on motherboard
    orm0: <isa option="" roms="">at iomem 0xc0000-0xc7fff,0xc8000-0xc9fff,0xca000-0xcafff,0xcb000-0xcbfff,0xcc000-0xccfff,0xcd000-0xcdfff,0xce000-0xcefff,0xcf000-0xcffff,0xdc000-0xdffff,0xe0000-0xe7fff on isa0
    vga0: <generic isa="" vga="">at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
    ppc0: cannot reserve I/O port range
    Timecounters tick every 1.000 msec
    nvme cam probe device init
    (da0:mpt0:0:0:0): UNMAPPED
    da0 at mpt0 bus 0 scbus2 target 0 lun 0
    da0: <vmware virtual="" disk="" 2.0="">Fixed Direct Access SPC-4 SCSI device
    SMP: AP CPU #1 Launched!
    SMP: AP CPU #2 Launched!
    SMP: AP CPU #3 Launched!
    da0: 320.000MB/s transfers (160.000MHz, offset 127, 16bit)
    da0: Command Queueing enabled
    da0: 8192MB (16777216 512 byte sectors)
    da0: quirks=0x40 <retry_busy>Trying to mount root from ufs:/dev/ufsid/55e0b2e79f855829 [rw]...
    Configuring crash dumps...
    Using /dev/label/swap0 for dump device.
    /dev/ufsid/55e0b2e79f855829: FILE SYSTEM CLEAN; SKIPPING CHECKS
    /dev/ufsid/55e0b2e79f855829: clean, 180263 free (17495 frags, 20346 blocks, 1.7% fragmentation)
    Filesystems are clean, continuing...
    Mounting filesystems...
    random: unblocking device.
    
         ___
     ___/ f \134
    / p \134___/ Sense
    \134___/   \134
        \134___/
    
    Welcome to pfSense 2.4.0-BETA...
    
    No core dumps found.
    ...ELF ldconfig path: /lib /usr/lib /usr/lib/compat /usr/local/lib /usr/local/lib/ipsec /usr/local/lib/perl5/5.24/mach/CORE
    32-bit compatibility ldconfig path: /usr/lib32
    done.
    External config loader 1.0 is now starting... da0s1 da0s1a da0s1b
    Launching the init system....... done.
    Initializing.................. done.
    Starting device manager (devd)...done.
    Loading configuration......done.
    Updating configuration...done.
    Cleaning backup cache.................................done.
    Setting up extended sysctls...done.
    Setting timezone...done.
    Configuring loopback interface...done.
    Starting syslog...done.
    Starting Secure Shell Services...done.
    Setting up interfaces microcode...done.
    Configuring loopback interface...done.
    Creating wireless clone interfaces...done.
    Configuring LAGG interfaces...done.
    Configuring VLAN interfaces...done.
    Configuring QinQ interfaces...done.
    Configuring WAN1 interface...
    vmx2: link state changed to UP
    done.
    Configuring LAN interface...
    vmx0: link state changed to UP
    done.
    Configuring WAN2 interface...
    vmx4: link state changed to UP
    done.
    Configuring WAN3 interface...
    vmx5: link state changed to UP
    gif0: link state changed to UP
    done.
    Configuring WAN4 interface...
    vmx1: link state changed to UP
    gif1: link state changed to UP
    gif2: link state changed to UP
    done.
    Configuring MOBILE interface...
    vmx3: link state changed to UP
    done.
    gif0: link state changed to DOWN
    gif0: link state changed to UP
    gif1: link state changed to DOWN
    gif1: link state changed to UP
    gif2: link state changed to DOWN
    gif2: link state changed to UP
    gif3: link state changed to UP
    Configuring WAN1IPV6 interface...done.
    Configuring WAN2IPV6 interface...done.
    Configuring WAN3IPV6 interface...done.
    Configuring WAN4IPV6 interface...done.
    Configuring CARP settings...done.
    Syncing OpenVPN settings...done.
    pflog0: promiscuous mode enabled
    Configuring firewall.....
    gif3: link state changed to DOWN
    gif3: link state changed to UP
    pf disabled
    pf enabled
    Starting PFLOG...done.
    Setting up gateway monitors...done.
    Starting DNS Resolver...done.
    Synchronizing user settings...done.
    Starting webConfigurator...done.
    Configuring CRON...done.
    Starting NTP time client...done.
    Starting DHCP service...done.
    Starting DHCPv6 service...done.
    Configuring firewall......done.
    Configuring IPsec VPN... route: writing to routing socket: Invalid argument
    route: writing to routing socket: Invalid argument
    done
    Generating RRD graphs...done.
    Starting UPnP service... done.
    Starting syslog...done.
    route: writing to routing socket: Invalid argument
    route: writing to routing socket: Invalid argument
    Starting CRON... done.
     Starting package Open-VM-Tools...done.
     Starting package squid3...done.
     Starting package nmap...done.
     Starting /usr/local/etc/rc.d/c-icap.sh...done.
     Starting /usr/local/etc/rc.d/clamd.sh...done.
     Starting /usr/local/etc/rc.d/sqp_monitor.sh...done.
     Starting /usr/local/etc/rc.d/vmware-guestd.sh...done.
     Starting /usr/local/etc/rc.d/vmware-kmod.sh...done.
    VMware memory control driver initialized
    pfSense 2.4.0-BETA amd64 Thu Jun 01 16:59:36 CDT 2017
    Bootup complete</retry_busy></vmware></generic></isa></qpi></ps></at></keyboard></ac></acpi></acpi></acpi></acpi></acpi></acpi></acpi></vmware></acpi></acpi></acpi></acpi></acpi></acpi></acpi></acpi></acpi></vmware></acpi></acpi></acpi></acpi></acpi></acpi></acpi></acpi></vmware></acpi></acpi></vmware></acpi></acpi></acpi></acpi></acpi></acpi></acpi></acpi></vmware></acpi></acpi></vmware></acpi></acpi></acpi></acpi></lsilogic></vga-compatible></bridge></ata></ata></intel></isa></pci-isa></acpi></acpi></acpi></acpi></at></at></acpi></acpi></acpi></acpi></intel></software></vt></version></ptltd ></tscadj></lahf></syscall,nx,rdtscp,lm></sse3,vmx,ssse3,cx16,sse4.1,sse4.2,x2apic,popcnt,tscdlt,hv></fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,dts,mmx,fxsr,sse,sse2,ss,htt> 
    

    How to troubleshoot?

    Regards,
    Donald.





  • Yes, I read that one, but i'm not using pfBlocker, I do have several tunnel brokers and some static and some dhcp WAN interfaces…



  • Problem is gone since updating to:

    2.4.0-BETA (amd64)
    built on Mon Jun 12 18:23:02 CDT 2017
    FreeBSD 11.0-RELEASE-p10



  • Problem returned when updating to latest snapshot:

    2.4.0-BETA (amd64)
    built on Tue Jun 13 12:12:29 CDT 2017
    FreeBSD 11.0-RELEASE-p10

    What to do?



  • same here with the

    route: writing to routing socket: Invalid argument error

    2.4 beta 6-26 build date