How to boot SG4860 into USB installer?



  • Seeking help for what I suspect is actually a simple problem, but the answer is eluding me…

    I have a SG4860, on 2.4.0 (updated through GUI).  I would like to reinstall and change to ZFS from UFS.  I have a Mac, and have followed the instructions here (https://doc.pfsense.org/index.php/Writing_Disk_Images) to create a bootable installer on a USB stick (the instructions do not specify how the USB stick should be formatted - I used Disk Utility to format as exFAT - could this be part of the problem?)

    I have inserted the USB stick into the topmost USB port on the SG4860 and rebooted.  I have console access to the device.  I can see the device booting in the console, but I cannot figure out how to get it to boot to the USB stick/installer.

    Could someone please help me out with this?


  • Netgate

    If the USB memstick has been properly-written and the boot order in the SG-4860 has not been toyed with, it will boot from:

    USB, if present
    mSATA, if present
    eMMC, if present
    PXE

    So you would need do nothing.

    This is the boot order with a USB memstick (1) AND an mSATA (2). The eMMC is (3).

    Press F12 for boot menu. (Pressed F12)

    1. USB MSC Drive Generic Flash Disk 8.07
    2. AHCI/0: Micron_M600_MTFDDAT128MBF ATA-10 Hard-Disk (119 GiB
    3. USB MSC Drive Generic Ultra HS-COMBO 1.98
    4. iPXE (PCI 00:14.0)
    5. iPXE (PCI 00:14.1)
    6. iPXE (PCI 00:14.2)
    7. iPXE (PCI 00:14.3)
    8. Payload [setup]

    This is what the default order should be:


    *** Sortbootorder payload    ver 1.1  Sage Electronic Engineering  *


    flash_address = 0x700000

    Type lower case letter to move device to top

    boot devices

    a  USB 1
      b  USB 2
      c  SATA3 1
      d  SATA3 2
      e  msata
      f  SATA2 1
      g  SATA2 2
      h  SATA2 3
      i  USB-eMMC
      j  PXE 1
      k  PXE 2
      l  PXE 3
      m  PXE 4

    Type upper case letter to invoke action

    R Restore boot order defaults
      E Exit setup with save
      X Exit setup without save

    The image contains all the formatting information necessary. There is nothing in that instruction doc that relates to prior formatting being necessary, but it should not hurt either.

    On the Mac, etcher.io is available now and eliminates some of the command-line things like diskutil and dd that can trip people up.

    You might try that.

    https://etcher.io/



  • Thanks.  Will try to re-burn the install disk using etcher.
    I have noticed that (using my mac) F12 keypresses do not seem to be acknowledged when accessing the console via terminal.  Is there another way to access the boot options?



  • One mother thing - do I have to decompress the gz file prior to using etcher?


  • Netgate

    No it does it for you.



  • Still not working.  I can't hit F12 to change boot order, and if I let it go, I get to a menu where I can select F1 to boot pfSense or F5 to boot disk1 or F6 (? not sure) to boot PXE or something like that.  Hitting F5 just fills the screen with # symbols (very slowly) and never seems to progress to anything - I have left it for up to 10 min and nothing more happens.  If I hit F1, it boots the already-installed pfSense.

    I am stuck here.  Can't seem to get the installer to work. (BTW, have tried 3 different flash drives, all USB2, all different manufacturers - same result with all)

    Any suggestions?


  • Netgate

    Try Fn-F12 on the Mac. You might have to coerce that platform to actually send the F-key.

    Not sure that ZFS would be the best choice on a small-disk platform anyway, but you need to know you can reinstall.



  • OK - was able to deal with F12 issue by using a third party terminal app.
    So it turns out that the SG-4860 is not "seeing" the USB drives (tried all 3, after reimaging using etcher)
    The default order of booting is exactly as you have indicated.
    However, when I hit F12, choice #1 does not show up at all - i.e. there is no listing for USB MSC Drive Generic Flash Disk 8.07.  The first choice is AHCI

    So that explains why the installer is not booting
    Now how can I fix it?


  • Netgate

    Not sure. Did you try both USB ports?

    Does the unit boot at all? When booted and you insert one do you get console messages about da0 or da1 being inserted?

    1. Halt system                      15) Restore recent configuration
    2. Ping host                        16) Restart PHP-FPM
    3. Shell

    Enter an option: ugen0.4: <generic mass="" storage="">at usbus0
    umass1 on uhub1
    umass1: <generic 0="" 4="" mass="" storage,="" class="" 0,="" rev="" 2.00="" 1.06,="" addr="">on usbus0
    da1 at umass-sim1 bus 1 scbus7 target 0 lun 0
    da1: <generic flash="" disk="" 8.07="">Removable Direct Access SPC-2 SCSI device
    da1: Serial Number 8291C764
    da1: 40.000MB/s transfers
    da1: 7681MB (15730688 512 byte sectors)
    da1: quirks=0x2 <no_6_byte>GEOM: da1: the secondary GPT header is not in the last LBA.
    GEOM: diskid/DISK-8291C764: the secondary GPT header is not in the last LBA.

    What about a mouse or something?

    1. Halt system                      15) Restore recent configuration
    2. Ping host                        16) Restart PHP-FPM
    3. Shell

    Enter an option: ugen0.4: <logitech optical="" usb="" mouse="">at usbus0
    ugen0.4: <logitech optical="" usb="" mouse="">at usbus0 (disconnected)

    Sounds like you might have broken USB ports.</logitech></logitech></no_6_byte></generic></generic></generic>



  • You led me to the answer.  I had followed the online instructions, which indicated that the topmost USB port should be used.  When I switched the USB stick to the bottom port, it worked, and I was able to boot into the installer.  I proceeded with the install and it seems to have been successful.  However, the console output became completely garbled after the reboot, and I am not sure how to fix that.  Was able to log into the default user name/password at 192.168.1.1, and then recover a configuration from backup.  Now up and running!

    Thanks for your help.  If you have any pointers about the garbled console output, it would probably be a good thing for me to know, fo the next time I have to rely on the console.


  • Netgate

    Sounds like your config might have the wrong console baud rate or something. Everything on the SG-4860 should always be 115200.

    It's at the bottom of System > Advanced.



  • Thanks. It was set correctly there, but I suspect it might not have been set correctly in the terminal app.  Have disconnected, so will try that again next time

    One more wrinkle I can't figure out:  when the system rebooted, I was not longer to access it by its internal name on the domain (pfsense.lan).  Everything else .lan is working (e.g. NAS.lan, etc), but not the pfsense device itself.  Can still access it no problem via its IP address.  This has persisted despite rebooting the device and all network hardware.  Any suggestions?


  • Netgate

    Does it not resolve or not connect? Is there a host name override for it?



  • @Derelict:

    Does it not resolve or not connect? Is there a host name override for it?

    It does not resolve at all.  There is a host name override for it in DNS resolver, and it is also set under system – general setup.  It had always worked prior to reinstalling 2.4.0 on ZFS (it worked on 2.4.0 on UFS - I can't imagine why that would be the issue). I even tried generating a new cert, but no success.  It is not a showstopper, as I can access directly via the IP address, but it is curious.



  • Actually, now I can't access anything .lan.
    Not sure what is going on here.



  • Seems to be only my main computer that can't access the .lan addresses.  Other devices on the network can.



  • And now it is working for every device.

    /end thread

    @Derelict - thank you very much for your help!


  • Netgate

    Glad it's all working.