Squid log rotate - bug ?



  • Hi,

    I just noticed that after upgrading to version 2.4.2 squid logrotation stopped working.
    It was set to 5 days and there's only one log file visible.
    I already tried disabling it completely, re-installing squid package with no success.
    Also squid.conf file shows - logfile_rotate 0. However when I modify that parameter manually rotation works ok until next reboot.
    Any idea what's going on?

    Thanks,

    Rafe



  • Same problem with me.
    I also tried installing fresh download from the download page.

    Both have the same problem.

    And also check for the squid proxy / filter, on my side both has stopped working since the logs are down.

    Pfsense 2.4.2-Release-p1

    squid 0.4.42_1
    squidGuard 1.16.4
    lightsquid 3.0.6_4

    some thing is wrong!!



  • Great to hear I'm not the only one with that issue. We have over 15 sites with PFSense with that issue. For the moment I'm using a cron job to delete the log file every night as it grows so fast and already caused lack of disk space on some sites.
    It would be great if the developers could describe how the squid config really works in terms of squid.conf and squid.inc etc.
    So far no reply from them.

    Thanks,

    Rafe


Log in to reply