ERR_EMPTY_RESPONSE admin interface



  • But only on one machine. Any machine on the network can access the admin app, except the one I use all day. Very convenient.

    • Most of the ERR_EMPTY_RESPONSE conversations I see here relate to Squid – not running Squid

    • I don't have a weird IP address or anything like that

    • DHCP scope does not include the pfSense address

    • I've cleared every cache, tried numerous browsers, same result

    Has anyone else faced & solved this? Thanks so much for any ideas.

    Cheers,
    TJ



  • What packages do you have installed?

    Edit:  Quite a few sites recommend the following series of commands to get past this error:

    ipconfig /release
    ipconfig /all
    ipconfig /flushdns
    ipconfig /renew
    netsh int ip set dns
    netsh winsock reset
    


  • Just Darkstat.  I can access that just fine, now that I look.

    I use all the other services provided by the appliance – NTP, DNS, DHCP, etc.

    I am one rev behind, on 2.3.4-RELEASE-p1 (amd64) but I believe this issue pre-dates that at least a couple updates.



  • I've been here for a few years and I don't recall this being a regular problem.  The fact that it's localized to one specific system tells me it isn't a generic pfSense issue.  Can I assume that you've already tried the commands I listed and they didn't work for you?



  • I did just complete all those commands (and am pretty sure I tried that in the past). No change.

    Agree it's probably not a widespread pfSense bug. Odd that it's just one machine, I can't find evidence of anyone else having the issue, and every other type of connection to that box works fine – it's our DNS server, NTP, DHCP, etc. all that, I SSH into it okay, access Darkstat okay... Network serves a hundred plus users just fine.

    I'm solving it by VNC-ing into a machine that I have installed in the server rack.  Mildly inconvenint, but works.

    Thanks for helping, any other ideas welcome.



  • I don't know if this will help or not but I had similar issues recently with several pfsense firewalls I have deployed.  It ended up being my Bitdefender antivirus on my laptop that was "protecting" me and causing the web gui to come back with the empty response.  I have to either disable the protection now or add all the sites/ips to the safe list to access the firewalls.  Looking for a new A/V software program now too…


Log in to reply