Package FRR OSPF Problem removing last interface



  • Hi,

    while testing the frr ospf package i run into massive problems.

    I installed frr on two pfsense 2.4.2 p1 which run in production without any problems. Configured everything and can suscessfully exchange ospf routes via openvpn links.

    After that i decided to stop frr and would like to remove the frr configs and the ospf configs, but cant.

    Finally i removed the last interface from the ospf interfaces tab, after that pfsense doesnt accept any changes to the system anymore. Got timeouts over and over.

    Restoring the backup (prior to frr config) from console and rebooting does the trick to get into the system again.

    Is there a correct way to stop and remove frr from pfense without restoring a config backup?

    What went wrong?


  • Rebel Alliance Developer Netgate

    I am not seeing that happen here. I disable OSPF and remove the interfaces and everything still works fine.

    You don't have to remove all of the settings if you don't want to use the package anymore though, just uninstall it.



  • I switched over to my testing environment and cant reproduce this problem.

    Before going to production i encounterd two more points:

    1. In a CARP enviroment the frr configurations are not going to the backup pfsense. Is this by design?

    2. There is the tab "OSPF Settings"; section "Distribute Networks" : it is not clear in which case (checked or unchecked) the subnet
          is excluded from distribution by ospf. I tested several subnets and checked and unchecked it, but in any case the subnet was
          distributed to the neighbor router within ospf. So i cant exclude subnets from redistribution. Excluding subnets would be nice to have.

    What is wrong here?


  • Rebel Alliance Developer Netgate

    1. Packages do not synchronize unless they have their own sync function, and FRR does not have a sync function at this time.

    2. When checked, the given subnet is added to an access list used to deny redistribution of routes controlled by the various "Redistribute" checkboxes higher up on the page. It worked last time I tried it, but I don't appear to have a current setup to confirm that again today.



  • I cant exclude Routes with the input filter in "OSPF Interfaces" "Accept Filter", this checkbox doesnt work in my environment.

    I checked this with Quagga OSPF . In the Tab "Global Settings" Section "These Rules … " : there is a checkbox "accepted subnets" ...

    This one is missing in the FRR OSPF. ...

    Cant made it work.


  • Rebel Alliance Developer Netgate

    In FRR, the accept filter list is under Global Settings in the Route Handling section since it's a function of Zebra, not OSPF. It was hacked into Quagga since it only handled OSPF.


Log in to reply