Install PFSense on a Sophos SG appliance



  • Hi Steve and thank you for replying.
    I opened the box and it is obvious that the LCD is connected to a COM-port, it says RS232 on the circuit board. Attached i have serial number and revision. So, when I read the documentation, Portwell Ezio means I have to choose "HD44780 and compatible", but after that, I'm lost......
    There are a few chioces under the "com port" and a few other choices under "Connection type"
    All suggestions are greatly appreciated.
    Thx, Mike!
    serialno.jpg lcd.jpg
    If i google "GFC1602AI" as it says on the sticker I find this manufacturer:
    GIFAR Technology

    here is the tech spec for GFC1602AI from the manufacturer.PDF



  • After a few combinations, I succeeded to achieve this:
    20190924_085731.jpg
    With these settings. Any ideas on what needs to be changed?

    garbled.jpg


  • Netgate Administrator

    Ok yeah that is the EZIO display. The driver itself should be in LCDproc but I don't think the option to select is in the package yet. You will probably have to start it separately until it is added. See: https://forum.netgate.com/post/795491

    Steve



  • @stephenw10 Thank you, I already read that post like 3 times and I think I understand what needs to be done. If I understand correctly, the driver is already in the package, I need to create a file called LCDd.conf under root.
    Unfortunately, as the other guy in the thread, I am quite novice at that(Unix, Linux, BSD). I'll try and fix it somehow.
    Do I need to uncheck "Enable LCDproc at startup" or just choose default settings?


  • Netgate Administrator

    Yes disable it in the package and use a shellcmd to start it instead so you can use a custom lcdd.conf file.



  • @stephenw10 I'll give it a try. I purchased 2 X XG-1537 HA for 1 month ago as a replacement for the Sophos SG330. They are way faster and better than Sophos.
    So far I'm happy with my choice. So these old Sophos machines are in no way in production, just my curiosity that needs to be satisfied.


  • Netgate Administrator

    Reuse beats Recycling IMO. 😉



  • @stephenw10 I created LCDd.conf under root.
    This is the content:
    [server]
    DriverPath=/usr/local/lib/lcdproc/
    Driver=hd44780
    Bind=127.0.0.1
    Port=13666
    ReportLevel=3
    ReportToSyslog=yes
    User=nobody
    Foreground=no
    ServerScreen=no
    GoodBye="Thanks for using"
    GoodBye=" pfSense "
    WaitTime=5
    ToggleRotateKey=Enter
    PrevScreenKey=Left
    NextScreenKey=Right
    ScrollUpKey=Up
    ScrollDownKey=Down
    [menu]
    MenuKey=Escape
    EnterKey=Enter
    UpKey=Up
    DownKey=Down
    [hd44780]
    driverpath=/usr/local/lib/lcdproc/
    ConnectionType=ezio
    Device=/dev/cuau1
    Keypad=yes
    Size=16x2
    KeyMatrix_4_1=Enter
    KeyMatrix_4_2=Up
    KeyMatrix_4_3=Down
    KeyMatrix_4_4=Escape

    I also added 2 shellcmd with this content:
    1: /usr/bin/nice-20/usr/local/sbin/LCDd -r 0 -c /root/LCDd.conf > /dev/null &
    2: /usr/bin/nice-20/usr/local/bin/lcdproc C T U &

    Not sure about the punctuation though, can you please check if there is a space too many or something similar?

    I get sh: /usr/bin/nice-20/usr/local/sbin/LCDd -r 0 -c /root/LCDd.conf not found
    and one more similar line


  • Netgate Administrator

    Yes. 'nice' is a separate command so the shellcmds should be:
    /usr/bin/nice -20 /usr/local/sbin/LCDd -r 0 -c /root/LCDd.conf > /dev/null &
    /usr/bin/nice -20 /usr/local/bin/lcdproc C T U &

    Steve



  • @stephenw10
    I still get:
    sh: /usr/bin/nice-20 not found twice

    The "Enable LCDproc package at start" is unchecked.
    I used the "Edit file" option found under diagnostic to create the LCDd.conf under the catalog root.
    b4cd0655-0db0-41fb-99cc-0a71e9c28f20-bild.png


  • Netgate Administrator

    Hmm, this is the actual code from the config.xml file from that box:

    		<shellcmd>/usr/bin/nice -20 /usr/local/sbin/LCDd -r 0 -c /root/LCDd.conf &gt; /dev/null &amp;</shellcmd>
    		<shellcmd>/usr/bin/nice -20 /usr/local/bin/lcdproc C T U &amp;</shellcmd>
    

    Ah! The space between nice and -20 is not clear.

    Steve



  • @stephenw10
    Progress is being made :-) For a short while I saw readable text, Hd44780 and Thank you for using pfSense and a serial number.
    But as soon as the boot sequence was finished everything is garbled again.
    Starting package LCDproc...done. That works now.
    Starting package Shellcmd...done


  • Netgate Administrator

    Sounds like the lcdproc package is still starting stuff separately. Make sure you have disabled the server and set the com port to 'none' and have unselected any screens in the gui.

    Steve



  • @stephenw10
    Happy dance :-)
    20190924_140634.jpg

    Thank you Steve, I knew that choosing pfSense was the best way to go because of the support and community.


  • Netgate Administrator

    Nice!
    Though when you see that it means the LCDd daemon is running but no clients are connecting to it.
    With the second shellcmd you should see the three output screens for CPU usage, Time and Uptime.

    Do the buttons work?

    Steve



  • @stephenw10
    Hmm..., no the buttons don't work:
    The shellcommands are as follows:

    1. /usr/bin/nice -20 /usr/local/sbin/LCDd -r 0 -c /root/LCDd.conf > /dev/null &
    2. /usr/bin/nice -20 /usr/local/bin/lcdproc C T U &

  • Netgate Administrator

    Hmm, potentially some timing issue. Try running the client command from the command line, see if it attaches to the server then.
    Check the system logs after booting you may well see the server and/or client being started/stopped several times.

    Steve



  • is there a step by step howto install on a sophos SG appliance and what about the UTM appliances ?



  • @randy_srs Hi Randy, I cannot say for other Sophos appliances, but for SG330, I created a bootable USB stick with Rufus and the installation is very easy.
    I could only auto identify one ethernet card. The rest were found automatically when the installation was finished. Other than the issue with the display, everything went smoothly.
    /Mike



  • @mickesanda thanks for the info . i figured . i think there is a workaround for the LCD display . ill have to play around with them


Log in to reply