Web interface stops responding



  • Using 1.2.3-PRERELEASE-TESTING-VERSION-pfSense downloaded yesterday.

    The web interface on my pfSense box has stopped responding a number of times now.

    I can ping the box and ssh into it, but HTTPS is completely unresponsive.

    I have restarted it with /etc/rc.restart_webgui to no avail.

    Previously this box had run 1.2.2 with absolutely no glitches noticed. I only upgraded to 1.2.3 to get NAT-T on IPSec.

    The last few entries from /var/log/lighttpd.log show nothing:
    2009-02-11 17:17:49: (log.c.97) server started
    2009-02-12 07:30:39: (log.c.97) server started
    2009-02-12 07:31:43: (log.c.97) server started
    Any ideas?



  • It looks as if the web server might be quietly dieing. Perhaps there is a log file that contains a clue to the cause of death.

    Try the command

    ps ax | grep http

    on the pfSense box when you get no response. This will show if the web server is still running.



  • Sorry, should have said that I'd tried all the obvious diagnostics.

    Yes, I'd tried "ps" and the server was up and listening on 443 but "telnet" and web browser requests were behaving as if I was firewalled off.

    I had to leave the house after posting this morning and when I've returned this evening, it's fine. I'll post back more details as/when it happens again.



  • Having dismissed the obvious, you may need to elaborate a little on what you mean by "https is completely unresponsive" and give some information about the system. My interactions with the pfSense web server use http, BUT, if I attempt to access https://pfsense/index.php rather than http://pfsense/index.php then Firefox tells me the server is taking too long to respond.

    Why use https rather than http?



  • Why use https rather than http?

    Because that's how I have it configured, by choice!

    My firewall worked flawlessly with HTTPS under 1.2.2 and it doesn't under 1.2.3. I'll post more diagnostics if/when it happens again.



  • @Bern:

    Why use https rather than http?

    Because that's how I have it configured, by choice!

    My firewall worked flawlessly with HTTPS under 1.2.2 and it doesn't under 1.2.3. I'll post more diagnostics if/when it happens again.

    I too prefer to use https so that admin stuff (including the password) doesn't go out in the clear over the wireless network for any decent wardriver to sniff.

    I was looking for a different post for my problem, but when I saw this I figured a small bug I've seen in 1.2.3 may have something to do with this: Trying to create a cert in the "advanced" menu fails with some sort of PHP error that flashes and is removed too quickly to read.  Because of this, I'm stuck at the moment using http.  I deleted the old 1.2 config off the flash key before making a whole new one from scratch (experience has taught me to do this) and so far most everything works fine except for this, which is a new error over previous versions.
    My snapshot is the latest 0224 version.

    Hope this helps, Mike



  • This happened to me in 1.2.3 as well. I thought that maybe i had left a packet capture running with no limit and it had filled up the disk space or something. I also use HTTPS for security reasons.

    When I was able to SSH and select the option to restart the webgui everything came back up fine. I did see an error about swap space in the logs but that was my only clue.

    btw, how do you run commands like ps ax from ssh? I got into the phpshell but couldn't find a way to run normal shell commands there.



  • btw, how do you run commands like ps ax from ssh? I got into the phpshell but couldn't find a way to run normal shell commands there.

    I choose option 8 and get a normal command line/shell:

    5 )  Reboot system
    6 )  Halt system
    7 )  Ping host
    8 )  Shell
    9 )  PFtop
    10 )  Filter Logs



  • @Bern:

    I choose option 8 and get a normal command line/shell:

    Wow, I really was just that blind. Thank you!



  • Happened to me now, on this build: pfSense-Full-Update-1.2.3-20090318-1630

    Crap, internet is working though, but i have no contact with the firewall gui. Gotto reinstall 1.22 tomorrow.  :-\



  • Did restarting the gui via ssh or from the terminal not work for you? It worked for me but not for Bern.



  • Here is the [new] problem, I doubt this goes back to February since I've been using the snapshots of 1.2.3 for a couple weeks with no issues… (20090319-0343 here):

    2009-03-19 02:51:21: (mod_fastcgi.c.1051) the fastcgi-backend /usr/local/bin/php failed to start:
    2009-03-19 02:51:21: (mod_fastcgi.c.1055) child exited with status 0 /usr/local/bin/php
    2009-03-19 02:51:21: (mod_fastcgi.c.1058) If you're trying to run PHP as a FastCGI backend, make sure you're using the FastCGI-enabled version.
    You can find out if it is the right one by executing 'php -v' and it should display '(cgi-fcgi)' in the output, NOT '(cgi)' NOR '(cli)'.
    For more information, check http://trac.lighttpd.net/trac/wiki/Docs%3AModFastCGI#preparing-php-as-a-fastcgi-programIf this is PHP on Gentoo, add 'fastcgi' to the USE flags.

    and

    /usr/local/bin/php -v

    PHP 4.4.9 with Suhosin-Patch 0.9.6 (cli) (built: Mar 19 2009 02:35:33)
    Copyright © 1997-2008 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies



  • I too have upgraded today, and have an unresponsive webgui at this moment.
    Everything else works just fine, vpn and all other traffic is working just great.

    How can I disable https, without a webgui ?
    In which folder can I edit this… is changing the https to http enough ??



  • I was downloading 1.2.3 from today to set up a new unit, and could not get in to web gui on http (80). Unit is running and can be configured over serial. After several atempts I gave up and installed 1.2.3 from 7th mars, web gui OK :-) My guess….. small bug!!  :P



  • Hi
    Gui back with pfSense-Full-Update-1.2.3-20090320-0534


Log in to reply