[fixed] Avahi php warning 2.4.5



  • Just upgraded to 2.4.5 from 2.4.4 and got this avahi package php error and it is not starting.

    Crash report begins.  Anonymous machine information:
    
    amd64
    11.2-RELEASE-p4
    FreeBSD 11.2-RELEASE-p4 #27 021c0c7c1ad(RELENG_2_4_4): Tue Oct  2 22:53:42 EDT 2018     root@buildbot3:/crossbuild/ce-master/obj/amd64/9kCJYnqE/crossbuild/ce-master/pfSense/tmp/FreeBSD-src/sys/pfSense
    
    Crash report details:
    
    PHP Errors:
    [02-Oct-2018 23:11:30 America/Vancouver] PHP Warning:  Use of undefined constant AVAHI_RCFILE - assumed 'AVAHI_RCFILE' (this will throw an Error in a future version of PHP) in /usr/local/pkg/avahi/avahi.inc on line 94
    
    
    No FreeBSD crash data found.
    

    edit2: reinstall the package and clicking save on config page fixed the issue


  • Rebel Alliance Developer Netgate

    Looks like there was a small typo/inconsistency in the name of that constant in the code. Should be fixed in the next new version when it shows up after the next snapshot run.



  • @jimp thanks



  • @jimp Sorry about that!