HAProxy 0.59_14: unable to add errorfile to backend



  • Hello,
    I've got troubles adding a custom errorfile to my backend.

    1. Added custom error file: OK
    2. Added custom backend to be used for serving that errorfile (the plan is to manually switch to the error file backend when required), specified the errorfile in the backend: OK, but the errorfile is missing from the backend config after reopening it
    3. Readded the custom errorfile configuration to the backend (on the older version - see below - I noticed that the errorfile isn't added when the backend is being added as new - I have to add it after the backend has been added): OK, but the errorfile is still missing.

    This is at:
    pfSense 2.4.4-RELEASE-p1
    haproxy 0.59_14 / haproxy17-1.7.11_1

    For comparison I've got an older pfSense installation (not yet updated) with pretty much the same configuration (one is clone of another) where the issue doesn't exist:
    pfSense 2.4.3-RELEASE-p1
    haproxy 0.54_2 / haproxy17-1.7.11_1

    Here, there's only the annoyance with having to add the errorfile to the already existing backend as it's impossible to successfully add it during a new backend creation.

    Can anyone confirm this, or am I doing something wrong?



  • @petrh
    Seeing the same, fix coming up shortly.. (On github side anyhow.)



  • @petrh
    Can you try 0.59_15 when it becomes available? Or until that happens apply this patch with patches package (or manually): https://github.com/pfsense/FreeBSD-ports/commit/75049a1d0649efb56d8eadd35bbca044c11be513.patch



  • Yes I can confirm it works after applying that patch. 👍