Connecting via PPPoE modem on WAN to TalkTalk (UK ISP)



  • Hi,
    New here, so if this is in the wrong section, please let me know.

    pfSense : 2.4.4
    Installed on AMD64 CPU with 2G Ram, 3 network cards (WAN/LAN/OPT)

    I am trying to get pfSense to connect to my ISP via a PPPoE modem to replace my ageing Draytek router.

    I can connect via PPPoE with my draytek without any issues. but when i try and configure pfSense with PPPoE on the WAN port, I can't get connected.
    On the draytec, I just need the Username and Password for the PPPoE connection, and am using the defaults in pfSense for setting WAN as PPPoE.
    This is a fresh install of pfSense 2.4.4 latest, no changes to install made other than setting internal LAN cards IP addy and then adding the username/password for the PPPoE connection under the WAN interface via the web portal.

    Anyone able to give me any pointers on getting this to work?
    I am using TalkTalk ISP in the UK, and a BT Openreach (ECI Telecom Ltd) PPPoE external modem.
    I can confirm that everything works fine when using the Draytek router in place of the psSense server.
    WAN Interface settings :
    Enable Interface
    ipv4 Configuration Type : PPPoE
    IPv6 Configuration Type : None
    MAC Address : BLANK
    MTU : BLANK
    MSS : BLANK
    Username : USERNAME@talktalkbusiness.net
    Password : <ISP-Password>
    Service Name : talktalkbusiness.net
    Dial on demand : Enabled
    Idle timeout : BLANK
    Periodic reset : disabled
    No Advanced/MLPPP settings changed.
    Block private networks and loopback addresses : Ticked
    Block bogon networks : Ticked

    Only thing i noticed was you can't save the settings without inputting a timeout, but after setting this to '0' and saving the setting shows blank when viewing the interface again.
    Have tried with both Dial on demand and without.

    /var/log/ppp.log
    PPPoE: Connecting to ''
    PPPoE connection timeout after 9 seconds
    Link: DOWN event
    LCP: Down event
    Link: reconnection attempt 44 in 4 seconds

    Please let me know what logs i can post back to help any diagnosis.

    Thanks
    Marl_Scot


  • Galactic Empire

    Looks about right, I'm with Zen Internet and also have the same modem, try leaving the Service name blank.

    Talktalk don't use vlans on the PPPoE interface do they ?

    https://forum.netgate.com/topic/53589/vlan-support-for-pppoe-connections-in-the-gui/3


  • Netgate Administrator

    There is a VLAN required but the Openreach modem adds it by default, you should not need it in pfSense.

    Check the PPP setup directly in Interfaces > Assignments > PPPs.

    If it looks good there check the actual WAN PPP sections in the config file.

    Do you see anything else in the ppp log? It looks like it's missing a connection name there somehow.

    Steve


Log in to reply