Shared object "libarchive.so.7" not found, required by "pkg"


  • [2.4.4-RELEASE][root@pfSense.localdomain]/tmp: pkg add http://pkg.freebsd.org/FreeBSD:11:amd64/quarterly/All/pimd-2.3.2.txz
    Shared object "libarchive.so.7" not found, required by "pkg"
    
    

    Any advise, should I downgrade pkg?

    [2.4.4-RELEASE][root@pfSense.localdomain]/tmp: pkg-static install -f pkg
    pkg-static: Warning: Major OS version upgrade detected.  Running "pkg bootstrap -f" recommended
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    The following 1 package(s) will be affected (of 0 checked):
    
    Installed packages to be DOWNGRADED:
            pkg: 1.12.0 -> 1.10.5_6 [pfSense]
    
    Number of packages to be downgraded: 1
    
    The operation will free 15 MiB.
    3 MiB to be downloaded.
    
    Proceed with this action? [y/N]: ^C
    
    

    @jimp Just a thought; "Could it be, this happened because of the install of PIMD using the GUI (v0.1), as it was meant for 2.5 and up?

    Cheers Qinn

  • Netgate Administrator

    Hmm 1.12.0 is certainly the version of pkg from 2.4.5 and 1.10.5_6 is what I expect to see in 2.4.4p3.


  • @stephenw10 Thanks for your quick response and conformation, so I will downgrade and maybe come across the culprit a.s.a.p., as I am currently testing the PIMD package against the one in the pfSense package manager, as some have experienced that "they" behave different...


  • Downgraded pkg

    [2.4.4-RELEASE][root@pfSense.localdomain]/tmp: pkg -v
    1.10.5
    
    

    Tried to install PIMD and got

     pkg add http://pkg.freebsd.org/FreeBSD:11:amd64/quarterly/All/pimd-2.3.2.txz
    pkg: warning: database version 35 is newer than libpkg(3) version 34, but still compatible
    Fetching pimd-2.3.2.txz: 100%   67 KiB  68.4kB/s    00:01
    Installing pimd-2.3.2...
    Newer FreeBSD version for package pimd:
    To ignore this error set IGNORE_OSVERSION=yes
    - package: 1103000
    - running kernel: 1102000
    Allow missmatch now?[Y/n]: ^C
    
    
  • Netgate Administrator

    Do you see that installing the pfSense package?

    You probably want the 11.2 package if you're installing directly from the FreeBSD repo in 2.4.4p3:
    http://pkg.freebsd.org/FreeBSD:11:amd64/release_2/All/pimd-2.3.2.txz

    Steve


  • @stephenw10 did that this is the result

    [2.4.4-RELEASE][root@pfSense.localdomain]/root: pkg add http://pkg.freebsd.org/FreeBSD:11:amd64/release_2/All/pimd-2.3.2.txz
    pkg: warning: database version 35 is newer than libpkg(3) version 34, but still compatible
    Fetching pimd-2.3.2.txz: 100%   68 KiB  70.1kB/s    00:01
    Installing pimd-2.3.2...
    Extracting pimd-2.3.2: 100%
    
    
  • Netgate Administrator

    Hmm, sure looks like it pulled something from 2.4.5 at some point.
    I have no idea what that might have been though. 😕


  • Yes, looks like it, but all will right when 2.4.5 will be released...


  • Think I found it, the pkg package gets updated when in GUI from System/Update/System update you select "Update Latest 2.4.x development version (2.4.5)" in Branch and I did not confirm it, just selected it!

    [2.4.4-RELEASE][root@pfSense.localdomain]/root: pkg -v
    1.12.0
    [2.4.4-RELEASE][root@pfSense.localdomain]/root: pkg-static install -f pkg
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking integrity... done (0 conflicting)
    The following 1 package(s) will be affected (of 0 checked):
    
    Installed packages to be DOWNGRADED:
            pkg: 1.12.0 -> 1.10.5_6 [pfSense]
    
    Number of packages to be downgraded: 1
    
    The operation will free 1 MiB.
    
    Proceed with this action? [y/N]: y
    [1/1] Downgrading pkg from 1.12.0 to 1.10.5_6...
    [1/1] Extracting pkg-1.10.5_6: 100%
    You may need to manually remove /usr/local/etc/pkg.conf if it is no longer needed.
    [2.4.4-RELEASE][root@pfSense.localdomain]/root: pkg -v
    1.10.5
    

    Selected it and...

    [2.4.4-RELEASE][root@pfSense.localdomain]/root: pkg -v
    1.12.0
    [2.4.4-RELEASE][root@pfSense.localdomain]/root:
    
  • Netgate Administrator

    Hmm, seems similar to this: https://redmine.pfsense.org/issues/9873 Though not as bad....

    Might need to open bug report for that.

    Steve

  • Rebel Alliance Developer Netgate

    @Qinn said in Shared object "libarchive.so.7" not found, required by "pkg":

    [2.4.4-RELEASE][root@pfSense.localdomain]/tmp: pkg add http://pkg.freebsd.org/FreeBSD:11:amd64/quarterly/All/pimd-2.3.2.txz

    Why would you do that? It's completely unnecessary for the pimd GUI package and probably the source of your issues. You do not need to have any third party repos enabled. It's a proper pfSense package.


  • "First of all, try pkg bootstrap -f (or pkg install -f pkg).
    If it fails then try pkg-static bootstrap -f (or pkg-static install -f pkg) as it doesn't require any shared objects.
    If everything else doesn't work then you can install pkg from ports:
    
    cd /usr/ports/ports-mgmt/pkg
    make
    make reinstall clean
    You should be able to use pkg now."
    
    Source:   https://unix.stackexchange.com/questions/369372/shared-object-libarchive-so-7-not-found-required-by-pkg
    

    I get the same error warning while trying to install virtualbox-ose-additions with "pkg install virtualbox-ose-additions" command in pfSense 2.4.5-Release.

    I have fixed it with "pkg bootstrap -f" command. pkg version is 1.12.0 now from pfSense repository.