Installed 2.5 in Bare Metal but network/gui is not accessible-Fixed


  • Hi All,

    I'm new to pfsense and I just installed pfsense 2.5 in a small appliance which equipped with 6 intel 82583V NIC ports and intel 3865U CPU.

    However, I'm unable to access the network and also the GUI interface for 2.5. I can't ping the LAN ip from my WIN10 desktop and the WAN port also can't get the IP from DHCP. Before installing the 2.5. I tried the 2.4.5 which is working fine and no issue encountered. Before install to bare metal , I tried 2.4.5 and 2.5 running on EXSI VM with the same box and hardware which were also working fine. Not sure if it is hardware compatibility or driver issue on 2.5. Did anyone encounter similar issue ? any clue to solve it ? Thanks !

  • LAYER 8 Global Moderator

    Moved to 2.5 section.. What specific snap you installed, and what does the console show?


  • @johnpoz

    I tried 0331, 0403 and 0406. There is no any error shown in console and I can assign interfaces and ip via the console without any issue. But just can't communicate outside the box.

  • LAYER 8 Global Moderator

    So interface comes up, shows you at say 1000 mbps... What does the arp table show, if you try and ping a device on your lan network.. you day dhcp is not working - well does pfsense see the dhcp discover.

    How do you have the lan connected - is there a switch, are you plugging a pc directly into a port.. You have multiple nics.. Possible your just not assigning the correct one, etc..


  • The interface shows up for both LAN and WAN. Could you please guide me to get the arp table in console ? My LAN connection is via a switch and I also tried all the ports but no one worked. Actually, I just used the default setting from pfsense. i.e. em0 as WAN and em1 as LAN , the LAN ip is 192.168.1.1 and my local LAN network is 192.168.1.0/24. I tried to install 2.4.5 with same default setting and cabling. It was working fine.

  • LAYER 8 Global Moderator

    Sure you didn't reverse them.. Where you have wan on lan and lan on wan... This is quite common issue to be honest on multiple port systems..

    To view your arp table while on the console - just

    [2.4.5-RELEASE][admin@sg4860.local.lan]/: arp -a
    sg4860.wguest.local.lan (192.168.6.253) at 00:08:a2:0c:e6:20 on igb2.6 permanent [vlan]
    alexa-show.local.lan (192.168.4.78) at 50:dc:e7:28:08:70 on igb2.4 expires in 608 seconds [vlan]
    LB110-EndTable.local.lan (192.168.4.92) at 50:c7:bf:21:73:52 on igb2.4 expires in 189 seconds [vlan]
    LB110-ChairLamp.local.lan (192.168.4.93) at 50:c7:bf:21:81:58 on igb2.4 expires in 1194 seconds [vlan]
    <snipped>
    

    Depending on the nic, and software and whatever - its possible for nics to come up different.. You need to validate your on the right ports... Simple way is just pull one of the cables - does the correct wan/lan interface go down?


  • Thanks !
    Here is the arp output.

    6064f7ed-ee8b-4d7e-806e-40d7ec14e8b8-image.png

    I've tried and validated all the ports but no luck. 😢


  • it is strange, I unplugged all the cables , the em0 and em1 interfaces status still show (up)

    f0c12f93-7207-420e-8f10-a971bfd98f24-image.png


  • I just got fixed the issue. It is due to 82583V not support MSI-X but the FreeBSD 12 haven't disabled MSI-X on such NIC. Details can be found here : https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=235147

    workaround :
    Disable MSI-X by adding hw.pci.enable_msix="0" to /boot/loader.conf and reboot which fixed for me