HAProxy Not Working With Zammad



  • Hi - I'm attempting to get HAProxy working with Zammad. From my understanding the web application listens on port 3000.

    I have a HTTPS front for SSL offloading and a HTTP backend (port 3000) for Zammad, however under HAProxy stats I see 'Layer 4 connection problem - connection refused'

    Here is my HAProxy config:

    acl helpdesk-acl var(txn.txnhost) -m str -i ticket.somedomain.com
    use_backend helpdesk_ipvANY if helpdesk-acl

    HTTP Zammad Backend:

    backend helpdesk_ipvANY
    mode http
    id 104
    log global
    http-response set-header Strict-Transport-Security max-age=31536000;
    timeout connect 30000
    timeout server 30000
    retries 3
    option httpchk GET /
    server server 192.168.5.184:3000 id 122 check inter 1000

    The nginx configuration for Zammad has been left untouched, apart from changing the hostname to my external FQDN.

    Many thanks



  • @yuljk
    Can you check with a netstat -noa or something like that that the Zammad server is really listening on 192.168.5.184:3000 ? or 0.0.0.0:3000 perhaps.. What happens when you try and visit that http://192.168.5.184:3000 with a regular browser from a computer on the network? Does it connect? i guess not..



  • Layer 4 connection problem - connection refused is clearly says that port you mention doesn't open or listen. So: or you have firewall issues on your server or app not listen on server IP you are pointing.


Log in to reply