VMware error



  • Hi dears

    i am new in PFsense

    i whant to run pfsense with  ' VMware Appliance ' but when i give the address of pfsense files to VMware and power on it i recieve This eroor :

    –--------------------------------------------------------------------------------------------------

    VMware Workstation cannot open one of the virtual disks needed by this VM because it is larger than the maximum file size supported by the host file system.  Some remote file systems do not support files larger than 2 GB, even though the file system on the server might.
    Cannot open the disk 'C:\Documents and Settings\MOJY\Desktop\pfSense-1.2.2-VM\pfSense-1.2.2-VM.vmdk' or one of the snapshot disks it depends on.
    Reason: The file is too large.


    i don't know what's the problem.

    Please , thanks



  • (Note, this belongs in the Virtualisation forum)

    I see the same error message twice.  That seems a good candidate for starting with.

    What size is the file it's complaining about?



  • It means that one of the files on the host computer, which represent the disk of the VM, is larger that 2GB, and your host OS (windows) does not support single files that are larger than 2GB.

    I don't understand how the file has gotten so large: on a freshly downloaded & once-booted pfsense-1.2.2-VM, I see a pfsense-1.2.2-VM.vmdk file size of about 158M, and for 1.2.3RC-VM, I see 161MB.  Have you had this VM running for a while (adding packages and logging data, etc), or is this the first time you have tried booting the VM?

    When creating a new VM from scratch in VMWare Workstation, you have the option of creating either a single host file to represent the guest HD, or multiple host files each 2G maximum, for the guest HD.  There may be a way to change between the two methods by editing the vmx file, but I believe it has to be done at disk creation time.  For the most flexibility in making appliances, the disk should be created using multiple 2G files, since the appliance may be deployed on a host that does not handle 2G files.

    Please post a directory listing of your VM directory, and also the contents of your pfSense-1.2.2-VM.vmx file.

    regards, ….... Charlie



  • when unzip the pfSense-1.2.2-VM.zip file the size of files are 155 MB  , pfSense-1.2.2-VM.vmdk is 158MB too .

    pfSense-1.2.2-VM Directory Contents :

    pfSense-1.2.2-VM.nvram
    pfSense-1.2.2-VM.vmdk
    pfSense-1.2.2-VM.vmsd
    pfSense-1.2.2-VM.vmx
    pfSense-1.2.2-VM.vmxf

    ( pfSense-1.2.2-VM.vmx ) –>  VMware virtual machine configurations are :

    Memory : i changed to 72 MB / Hard Disk (SCSI) 4GB / Network Adapter : Bridged



  • What version of windows are you running as a VMWare host?  What is the host filesystem type (FAT-16, FAT32, or NTFS)?

    FAT filesystems have a file size limit of 2G-1 byte and 4G-1 byte for FAT-16 and FAT-32 respectively.

    regards ….... Charlie



  • I have the same problem when I move vmware to a FAT32 partition.

    Just reformat/convert the partition to NTFS.  ;)


Locked