PONDESK MNHO-073 Installation Issue


  • I have a brand new PICO PC (MNHO-073) with 2G RAM (soon to be upgraded to 4GB) and a 120GB SSD. I have downloaded pfSense-CE-memstick-2.4.5-RELEASE-p1-amd64.img.gz and used Rufus to write it to a USB memory stick. When I turn the solution on it boots fine, getting to the normal/initial dialogue up to and past the initial menu (the black one, I don't get to the blue menus). However it stopped responding soon after, consistently (in the same place). Once there it appears completely dead (caps lock on/off not responding). After a power cycle the same happens again. This is the last line on the screen.

    uart0: <16550 or compatible> port 0x3f8-0x3ff irq 6 flags 0x10 on acpi0

    I do wonder if it's not a crash but it may be switching from the HDMI/Keyboard connectivity to the serial Console port during boot. I have connected a serial cable but there is no output (it's an RJ45 console port and I am not sure I have the correct cable though). I have also tried disabling the serial port in the BIOS but that didn't help.

    Any thoughts appreciated.

    Thanks in advance.

  • Netgate Administrator

    Can we see a screenshot of exactly where it stops?

    Unless you have console redirect enabled in the BIOS you will not see any output on the serial console unless you use the memstick-serial image.

    Steve


  • @stephenw10, sure here you go (FYI I also tried OPNsense and it behaves exactly the same).

    IMG_9857 pfSense 2.png

    Once I am at this point there is no response from the keyboard any more (caps lock light stops responding).

  • Netgate Administrator

    Hmm, that does not bode well. 😕

    That's an odd place to stop if it were purely a console issue.
    That's just after it start loading ACPI devices. Could be an ACPI error.

    Did you try the memstick serial image? Or enabling console redircet in the BIOS?

    Steve


  • I will try the serial image. Although I have no way to prove my serial cable to the RJ45 console port so may be of limited use.


  • @stephenw10, Well the serial image behaves in the same way. Same output via HDMI and also via serial. Only difference is the last line.

    IMG_9857 pfSense Serial.png

    At this point it seems to have crashed, no response from keyboard or serial connection.

  • Netgate Administrator

    Hmm, OK. Well it appears something it detects and tries to load something at that point that fails badly!

    Try going into the BIOS and disabling any hardware components you don't need.

    You might also try a 2.5 snapshot. They are built on FreeBSD 12-stable so have newer drivers.
    https://www.pfsense.org/snapshots/

    Steve


  • @stephenw10 thanks for your ongoing help with this. FYI, I just tried the snapshot as suggested and it's just the same. So I will dive into the BIOS settings, I'll loop back here with any findings.

  • Netgate Administrator

    I am assuming you are using those settings in putty, 115200 8n1?

    It would not explain the HDMI console though, and that more informational not setting it, but if you are using a different console rate try setting that instead.


  • @stephenw10 Yes when I tried the serial version I am using putty (with those settings).

    So to summarise, I seemingly have the exact same issue regardless of whether I use the VGA or Serial version (so it seems my initial thoughts that it had anything to do with the console was a red-herring). FYI I have no need for the console connection, it was just part of my investigation of this issue.

    Thanks again.

  • Netgate Administrator

    Was this working with pfSense previously and just failed recently?

    Does it have any extra components, wifi or modems?


  • @stephenw10 It's a completely new device (i.e. just purchased new).

    I'm thinking that I'll throw a scratch installation of W10 on the unit just to prove the hardware (to some extent).

    There's no Wi-Fi/mobile cards or anything else installed (there is a new 120GB SSD (but I took that out as a test and the problem persists).

  • Netgate Administrator

    Mmm, that box doesn't look particularly exotic. I wouldn't expect to have much of an issue installing to it. I'm pretty sure there are quite a few other users with the same hardware with other branding.

    Steve


  • @stephenw10 Yes that what I had hoped when I bought it, LoL.

    I've got W10 installing on it now, just as a test.

    I know the unit I have is advertised as supporting pfSense (among other things). I wonder if the issue is relating to newer versions of pfSense. Is there anywhere I can download older versions, as a comparison.

  • Netgate Administrator

    Not easily, though there are images out there. But you really wouldn't want to be on an older image anyway.


  • @stephenw10 Was just thinking of a test (not to keep).

    BTW, I got W10 on it and all seems completely fine.

    So now I'm back to playing with pfSense and the BIOS tweaking :-)

  • Netgate Administrator

    Not exactly the same but a similar Soc, you might try the tweak shown here:
    https://forum.netgate.com/topic/133355/installing-pfsense-on-sophos-xg-105-rev-2


  • @stephenw10 Hi fella, thanks for the further suggestions.
    Good news, I got it fixed. As per your (earlier) suggestion I started playing with the BIOS settings and I had also emailed PONDESK support in parallel. I actually got a reply from them with the fix about 1 minute after I had found it by accident (i.e. by trial and error), so at least they confirmed what I found.

    The fix is to go here in the BIOS and disable the following:

    Advanced -> IT8613 Super IO Configuration -> CIR Controller Configuration -> CIR Controller = Disabled

    They said they'd made a recent change to the BIOS which had caused this and will be addressing it in the next update (I'm not sure how, perhaps setting the default to be disabled).

    BTW, I did a quick Google and apparently CIR is Consumer Infrared, so nothing I will miss for my use case.

    Thanks for your help on this, it was most appreciated.