Disable webui redirection (http -> https) on WAN port?



  • In v2, how do I disable the HTTP redirection on the WAN port? I have some internal web servers (on port 80), that I want to NAT through, however, I cant because whenever anyone hits my public IP, they are redirected to the webGUI login.

    (Its great to have this redirection on the LAN side - however, if I would prefer to turn it off completely if it cant be disabled on the WAN side.)



  • actually, my bad, i think it is not redirecting as expected :)

    I was connecting to my public IP from inside the network (which does redirect to the webgui https port).

    But when connecting to my public IP from outside, it is nating through correctly :)


  • Rebel Alliance Developer Netgate

    The NAT rules should always override local services, so as you found out, it does work correctly from the outside. Not sure what might happen with NAT reflection turned on though.



  • So I really love this is a really great feature but I would really like to limit it to just the port I has configured the webGUI to run on.

    For example, say I have the webGUI running on 8080.  If I try and access anything on port 8080 without https, then go ahead and redirect.  If I hit my public IP (whether on my internal network or not) on any other port, either then trust my firewall/NAT rules.

    I also have several websites running behind pfsense that I would like to be able to access using their full URL regardless of whether I am behind my pfsense router or not.  I have even tried to disable the "WebGUI redirect" option inside the advanced settings but it seems to have no impact.

    Any ideas?



  • So I figured it out.  On the NAT rule I had to enable NAT reflection (the default setting is off).


Locked