System unable to startup after upgrade to 1.0.1 with squid installed



  • The system stop booting halfway after upgrade to 1.0.1 from 1.0-RC3. It stops at:
    syncing packages
    syncing packages: squid
    Executing rc.d items
        Stopping /usr/local/etc/rc.d/proxy_monitor.sh…...

    This is what i had tried....

    1. Reinstall pfsense 1.0 and straight upgrade to 1.0.1 without squid.. the system work fine... after adding package squid 2.5.14_2-p7 and reboot the system, it stop again at "executing rc.d items"

    2. Reinstall pfsense 1.0 and upgrade to RC3, install squid package (2.5.14_2-p7), reboot system... working. upgrade firmware to 1.0.1.... boot stop at "executing rc.d items"

    I believed that something not compatible between 1.0.1 with squid..... any advise??



  • I have confirmed that this is indeed a problem on my site as well. When upgrading from 1.0 to 1.0.1 I get the same waiting for squid to stop. However, everything has already booted and the web configurator is up so I simply ssh'd in started squid again, and left it hung. The routing and firewall is working fine, it's just this upgrade script that's jacked up. Apparently when upgrading from the 0.1 or 0.3 squid to the latest it has a serious issue. Squid works, it's just the upgrade framework that's confused. I haven't had time to manually hack the script into submission, so I'll just run with it as is for now.

    Oh but I had to manually reinstall the latest squid using the gui, the upgrade script hung and never finished properly.

    But yes, my rig has the same:

    syncing packages
    syncing packages: squid
    Executing rc.d items
        Stopping /usr/local/etc/rc.d/proxy_monitor.sh…...

    it sits there forever....

    anyways if you can ssh in you can just do a squid -D and be up and running.

    Hopefully 1.0.2 or a hotfix will patch this?



  • Reinstall the squid package.



  • Already tried that, it doesn't fix the problem that upgrade script originated from the 1.0.1 upgrade not squid.



  • The problem is that the script that's called won't kill squid. I have a 25GB squid cache so it takes awhile to stop and start squid, but mostly, the script that's called just won't kill squid. If I manually kill squid, the script goes on and is happy.

    I tried removing the squid package entirely, deleting all references to it in the xml config file. Rebooting and the system sync'd the packages just fine. However, the second I installed a clean squid package, on the next reboot I was greeted by the same hang trying to stop squid.

    The side effect is that all services including spamd stay stopped until I manually start them because the 1.0.1 squid stop script being called at boot time doesn't really stop squid.



  • Uninstall and then reinstall the squid package.  I just changed the way it stops.



  • The change did indeed stop squid, and at least for me, transparent proxying is working.

    I've found that way back in the dark ages of pfense (RC1, pre) transparent proxying and QoS didn't get along, so I always enabled transparent proxying first, got that working, then worried about the packet scheduling later.

    I know this was fixed at some point, but it's entirely possible that the people having trouble with clean installs and squid may be having issues with the order in which rules are being added again.

    Just my 2 cents…



  • Hi! I've got the same problem here.
    After a "normal" action on my webGUI the system freezed and I had to restart it.
    But during startup I get this message :

    Executing rc.d items
        Stopping /usr/local/etc/rc.d/proxy_monitor.sh…...

    And nothing more. Systems freezes.
    My problem is not to know what to do to make it working back (re-install is the less time-consuming way)
    but the problem is that I've never made any backup of my rules and settings  :-
    I know...The only config file I've got is very similar to default one.
    So I want first to backup my config.xml but there's another problem : it's that the only way to acces my box is by the way of the webGUI (https)  :'( Or by rescue options at boot time.

    I'm not a UNIX user at all, so I don't know how to proceed. I've already try to boot the box on a
    Knoppix LiveCD (v.5.0.1 if I remember correctly) but was unable to mount freeBSD partitions (or I
    didn't know how to do that).
    What I know is that I've used default type partitions and filesystem during PfSense installation.

    Maybe someone more experimented in UNIX-based systems could take a moment to tell me how to proceed ?
    Thanks in advance to everyone for your help and this wonderfull project!

    (PM me if neccessary)



  • Squid was removed for a reason..  I would deinstall it.



  • Maybe this answer is intend to solve my problem ? Don't have any doubt.
    But I just want to know HOW (or in which file) I could disable the automatic startup of Squid.
    So : what's the full path of that file and what's its name ? ;D
    And like I said before: I'm not friendly at all with FreeBSD, so don't blame me, I'm just a PfSense user!
    Not an administrator with production servers or anything else you can even dream! :P

    (And don't take in consideration the second part of my first post, I found a way to open and save files that are on the hard disk :) )



  • rm /usr/local/etc/rc.d/squid* will keep it from starting.



  • 'Love you! Thanks a lot man!!
    I'm going to test and if I don't post anymore consider my problem as solved! ;)
    Thanks again! 8)



  • Hem ;D
    I need your help again :-[
    I've tried many ways to delete these files but each time I've got the same problem :
    It says me that I "Cannot write to read-only filesystem" :-X
    I understand the message but I don't know how to bypass this problem in a easy way ?  ???
    Many thanks and sorry again but my home network is locked since 2 weeks because of that problem :'( :)



  • read-only filesystem? are you running an embedded install? and why did you install squid on this? embedded systems don't have package support.

    with the following commands you can set the filesystem rw and ro:
    /etc/rc.conf_mount_rw
    /etc/rc.conf_mount_ro

    however, this only should be needed on embedded systems.

    Maybe a reinstal is in order and something is hosed.



  • Strange so! Because I've installed PfSense on a (old) computer using the LiveCD installer by choosing the 99 option making then a permanent installation on the hard-disk of the computer :-X
    So, you're right, I've installed (cause I can) the package named squid and this one seems to cause my system freezing during startup.
    And when I try to do "rm /usr/local/etc/rc.d/squid*" in recovery options I've got the message I wrote before this post :)
    Maybe you can see where is the problem with this informations but as I'm not friendly at all with linux I don't know how to operate to execute this command.
    Command I must execute to start at least one time my old PfSense installation to backup all my settings/rules before reinstall it :)
    Many thanks for all your work and your patience team! (with linux-n00bz like me  ;D) ;)

    (Sorry for my poor english, if there's something you don't understand, don't hesitate to ask me more! ;) )



  • The currently available squid package shoudl "just work"



  • @databeestje:

    The currently available squid package shoudl "just work"

    On a recent snapshot that is.  I fixed a bug from 1.0.1 that would halt the packages from starting on bootup.

    Scott



  • Ok, thanks for the informations.  :)
    Anyway I still have my box down because even if PfSense can now boot up succesfully, I'm not able to login into my webGUI. I don't kow why.
    So I've reinstalled PfSense on another disk and for now I'm trying to "force" importation of my rules from disk1 to disk2. But the problem is : where are they ? ;D
    Are the rules (for each interfaces) and the alias created stored somewhere (Like a conf file or anything else) ?
    And do you think that a brutal import will work ? I'd like to have your opinion on that  :)
    Thanks in advance  :)



  • The complete configuration is stored at /conf/config.xml. Try to cut it down to just the rule block and do a partitial diagnostics>backup/restore of only the parts you need or you might end up with the same situation that you have already on the old install.



  • I had uninstall the squid package and install the new beta 2.6.5_1-p15 but the same error still happened. any way to stop and squid the service properly?

    system stopped

    Executing rc.d items
        Stopping /usr/local/etc/rc.d/proxy_monitor.sh…...



  • @hsiang:

    I had uninstall the squid package and install the new beta 2.6.5_1-p15 but the same error still happened. any way to stop and squid the service properly?

    system stopped

    Executing rc.d items
        Stopping /usr/local/etc/rc.d/proxy_monitor.sh…...

    This question has been asked atleast 15 times now.  Update to the latest snapshot from: http://snapshots.pfsense.com/FreeBSD6/RELENG_1/


Log in to reply