Switch of the accesspoint? (WRAP)



  • I have wrap with cf card and integrated wirelesscard. Is there a possible way to switch of the accesspoint (perhaps from 24.00 until 8.00 in the morning…)? Because I think the radiation is not very healthy.
    Thank you for your answers!

    Leinad



  • You can add custom cronjobs to do so. Go to diagnostics, edit file "/etc/crontab" and add an ifconfig up or down at the desired times for this interface. I guess you'll have to run the wireless config shellscript that the webgui creates after bringing up the interface again too. You'll find it in /tmp/. Depending on the name of the interface it has different names but you should easily find it by checking the content of this folder (don't have a system as reference available right now to look it up exactly).



  • Thank you very much for the fast answer!!!
    8)

    Leinad



  • If you get this to work please share your cronjob settings. Others might be interested in this as well.



  • That is exactly what I was looking for in the forum.

    I just need the wireless card occasionally, so I would like to switch the wireless card off during the other time. I think I can extract the necesary commands out of the cron job.



  • Just looked up the script that brings up the wireless interface (located in /tmp): ath0_setup.sh (for my ath0 interface, name depends on the used nic and the amount of this type you have in your box)



  • It would be nice if there was a switch in the webGUI to power off the wireless card (not just disable), so there is no radiation anymore.



  • if it is disabeled then its powerd off so then it will not send any more so there is no radiation anymore



  • @jeroen234:

    if it is disabeled then its powerd off so then it will not send any more so there is no radiation anymore

    Are you shure about that, I think it doesn't power off the card. I'm quite sensitive on radiation…



  • It does, there is not even a channel or frequency configured if the device is disabled. Check with http://www.netstumbler.com/downloads/ if you are paranoid  ;)



  • If you do a "sysctl -a |grep rfsilent" and "sysctl -a |grep rfkill" you will find two sysctl strings that can possibly disable your card as well. If you are lucky your card supports this. Try to change the sysctls from 1 to 0 and 0 to 1 to enable/disable the card. If you can get this to work then use that sysctl line in a cron job to enable/disable the radio part of your card.


Log in to reply