NUT: Data Stale!



  • my log is chock full of this:

    Mar 2 16:40:05 upsmon[28156]: Poll UPS [Cyberpower@localhost] failed - Data stale
    Mar 2 16:40:05 upsmon[28156]: Poll UPS [Cyberpower@localhost] failed - Data stale
    Mar 2 16:40:00 upsmon[28156]: Poll UPS [Cyberpower@localhost] failed - Data stale
    Mar 2 16:40:00 upsmon[28156]: Poll UPS [Cyberpower@localhost] failed - Data stale
    Mar 2 16:39:55 upsmon[28156]: Poll UPS [Cyberpower@localhost] failed - Data stale

    over and over and over and over.

    if i reset the pfsense box, everything goes back to normal, and then maybe an hour later ? the logs start filling up again.

    whats going on here ?

    here is the contents of my 'ups.conf'

    user=root
    [Cyberpower]
    driver=usbhid-ups
    port=auto
    
    

    edit:
    under status –> services it shows NUT as running.

    under services --> NUT, it shows

    Monitoring: 	Local UPS
    ERROR: 	Data stale!
    

    i should mention this has been occurring for about 2 weeks or so.



  • You could try and increase the polling frequency, e.g. add "pollinterval=5" to your ups.conf



  • ups.conf, or upsmon.conf ?

    upsmon.conf already contains "POLLFREQ 3"



  • bump  ???



  • In the ups.conf file you define how frequently the local UPS status is refreshed. The default pollinterval is 2 seconds, however that might be too often in some cases, thus you can try to increase the interval e.g. 5 seconds.

    The upsmon.conf configures the monitoring part, that decides when it has to shutdown the system. The polling frequency (POLLFREQ) is by default 5 seconds, and should be larger than the configured pollinterval. You may even use a larger POLLFREQ and additionally configure POLLFREQALERT (default 5 seconds), that is the polling frequency if the UPS is detected to run on battery. The POLLFREQALERT should always be equal or lower than the POLLFREQ.



  • ive done this and there is no change.



  • The configured POLLFREQ in upsmon.conf might be too small. Try to use the default values:

    ups.conf: "pollinterval=2"
    upsmon.conf: "POLLFREQ 5"



  • id like to add that i have not changed these config files since i first set nut up…

    but alright i will give this a try, and get back to you.

    thanks for the help



  • overnight, my logs are just FULL of this again.

    Mar 5 10:11:31 upsmon[12387]: Poll UPS [Cyberpower@localhost] failed - Data stale
    Mar 5 10:11:31 upsmon[12387]: Poll UPS [Cyberpower@localhost] failed - Data stale
    Mar 5 10:11:26 upsmon[12387]: Poll UPS [Cyberpower@localhost] failed - Data stale
    Mar 5 10:11:26 upsmon[12387]: Poll UPS [Cyberpower@localhost] failed - Data stale
    Mar 5 10:11:21 upsmon[12387]: Poll UPS [Cyberpower@localhost] failed - Data stale
    Mar 5 10:11:21 upsmon[12387]: Poll UPS [Cyberpower@localhost] failed - Data stale



  • This has been an issue for a very long time. If you search for "Stale data" you'll see. I just restart nut every 15 minutes in cron and that keeps it going. I've fiddled with all kinds of settings to no avail. Anyway, this seems to work for me.



  • thanks coldfusion;
    thats a good idea.

    what cron entry do you have in your setup to achieve this ?



  • /usr/local/etc/rc.d/nut.sh start

    minute hour mday month wday who  command

    */15  *          *          *            *      root    /usr/local/etc/rc.d/nut.sh start



  • coldfusion,

    this has worked perfectly, thanks.
    hopefully the devs will work on a fix for this.


Log in to reply