Webgui inaccessable after LAN IP change



  • I hope that someone can inject some logic and explanation into my issue on Pfsense 2.0. The problem is quite simple, I changed the LAN IP from 192.168.1.45 to 192.168.1.1 and amended all F/w rules to reflect the new address.

    Upon reboot of the firewall and a restart of Network manager on my Linux server(192.168.1.2) I find that I cannot access webgui, using http://192.168.1.1. I can, however, ping the Pfsense box, gain a static ip from it, heck I can even telnet to port 80 but firefox times out saying the web server is taking too long to respond.

    I was  able to ssh to the Pfsense box on .1.1 and run filter logs. The only thing that I saw, and unfortunately I did not keep the logs, was traffic passing the rules to 1.1 on port 443. Come to think of it that was strange, given I was trying on port 80??

    I tried resetting to factory defaults and then defining my new Ip numbers but no cigar; I could not access the http interface. Its like some other config setting(within the web server config??) was not being updated to the new address.

    I have now recovered to my old settings by re-defining the LAN IP to the old .45 address, then restoring my old settings from a backup file(thank <your deity="" of="" choice="">for that feature).

    So what I'm asking from any pfsense guns out there is a) what did I do wrong and b) what is the procedure to carry out an LAN ip change.

    TIA </your>



  • If you set it to any other IP address, do you have any problems accessing the GUI?



  • Good question; haven't tried that, yet. Will let you know, when part two of the battle begins tonite ;-)



  • Sorry to resurrect such an old thread but i'm having the exact same problem. I changed my LAN IP from 192.168.0.1/24  to 192.168.0.5/20 in 2.0.1 and now can't access the web GUI but I can still ping and SSH in using the new IP. Also I had specifically put in a pass rule for TCP port 80 from anywhere to 192.168.0.5 so i'd assume it's not a firewall thing but rather something to do with the web GUI. When I change the LAN IP back to 192.168.0.1/20 either through the console or SSH it works again so the netmask isn't the problem. Will get some more details on monday as it's a work project.



  • If you change your IP to be what you want and then reboot, does it work?



  • Not sure what causes the problem but changing the GUI from http to https did the trick for me. When I first changed the IP from 192.168.0.1/24 to 192.168.0.5/20 with the GUI set for http and ran a tcpdump on the inside interface, I noticed that when I tried browsing to http://192.168.0.5 I wouldn't get any packets other than replies from 192.168.0.1 on https so i'm not sure what was up with that. This was a replacement for a production firewall though so I didn't have time to play but i'll see about recreating it on a fresh install sometime this week hopefully.

    To answer the question though. No, changing the IP and doing a reboot didn't solve the problem.

    Mark


Locked